summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Joyce2017-05-12 21:35:58 +0100
committerMatthew Joyce2017-05-12 21:35:58 +0100
commite2b955a65b5a48e378f8da9a24cd086e0af8218d (patch)
tree883bb839f8a3a67786f1038e1b584a1d454d6297
downloadaur-e2b955a65b5a48e378f8da9a24cd086e0af8218d.tar.gz
Initial package
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD35
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0cd2ece7b588
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = thonny-git
+ pkgdesc = Python IDE for beginners.
+ pkgver = r1403.40455c1
+ pkgrel = 1
+ url = http://thonny.org/
+ arch = any
+ license = MIT
+ depends = openssl
+ depends = python
+ depends = python-beautifulsoup4
+ depends = python-jedi
+ depends = tcl
+ depends = tk
+ source = git+https://bitbucket.org/plas/thonny.git
+ sha256sums = SKIP
+
+pkgname = thonny-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5bb92b0b4c86
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+pkgname=thonny-git
+pkgver=r1403.40455c1
+pkgrel=1
+pkgdesc="Python IDE for beginners."
+arch=('any')
+url="http://thonny.org/"
+license=('MIT')
+depends=('openssl' 'python' 'python-beautifulsoup4' 'python-jedi' 'tcl' 'tk')
+source=("git+https://bitbucket.org/plas/thonny.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir"
+
+ install -Dm 755 "$pkgname/packaging/linux/thonny" "$pkgdir/usr/bin/thonny"
+
+ sed -i 's|$target_dir|/usr|' "$pkgname/packaging/linux/Thonny.desktop"
+ install -Dm 644 "$pkgname/packaging/linux/Thonny.desktop" \
+ "$pkgdir/usr/share/applications/thonny.desktop"
+
+ install -Dm 644 "$pkgname/LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ # Install.py currently does not allow for setting root for creating a package
+ # Files must by copied manually for now in section below.
+ install -d 644 "$pkgdir/usr/lib/python3.6/site-packages/thonny"
+ cp -dr --no-preserve=ownership "$pkgname/thonny" \
+ "$pkgdir/usr/lib/python3.6/site-packages"
+
+ pip3 install --install-option="--prefix=$pkgdir/usr" --force distro tkinterhtml
+}