summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPablo Lezaeta Reyes2015-08-08 20:35:12 -0300
committerPablo Lezaeta Reyes2015-08-08 20:35:12 -0300
commitdbb2c439580776fc7c5d0bc78fa9c64c26e00f13 (patch)
tree286111cded174b1b961514aec4989215cd6b1a6f
downloadaur-dbb2c439580776fc7c5d0bc78fa9c64c26e00f13.tar.gz
Initial import
Signed-off-by: Pablo Lezaeta Reyes <prflr88@gmail.com>
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore10
-rw-r--r--PKGBUILD40
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5ecd682123b6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = thor-codec
+ pkgdesc = The Thor video codec is a block-based hybrid video codec similar in structure to widespread standards.
+ pkgver = r11.191fcb3
+ pkgrel = 1
+ url = https://tools.ietf.org/html/draft-fuldseth-netvc-thor
+ arch = i686
+ arch = x86_64
+ license = custom:BSD
+ source = thor::git+https://github.com/cisco/thor.git
+ md5sums = SKIP
+
+pkgname = thor-codec
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..00391408c1dc
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,10 @@
+src
+srcdir
+pkg
+pkgdir
+thor
+*.gz
+*.bz2
+*.zip
+*.rar
+*.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..399609e0a4a7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Pablo Lezaeta <prflr 88 (arro'a) gmail puntocom>
+
+pkgname=thor-codec
+_pkg=thor
+pkgver=r11.191fcb3
+pkgrel=1
+url=https://tools.ietf.org/html/draft-fuldseth-netvc-thor
+pkgdesc="The Thor video codec is a block-based hybrid video codec similar in structure to widespread standards."
+license=("custom:BSD")
+arch=("i686" "x86_64")
+
+source=("${_pkg}::git+https://github.com/cisco/thor.git")
+md5sums=("SKIP")
+
+pkgver() {
+ cd "${_pkg}"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd "${srcdir}/${_pkg}"
+
+ make DESTDIR=${pkgdir} prefix=/usr \
+ localstatedir=/var sysconfdir=/etc \
+ sbindir=/usr/bin bindir=/usr/bin \
+ libdir=/usr/lib libexecdir=/usr/lib
+}
+
+package() {
+ cd "${srcdir}/${_pkg}"
+
+ make DESTDIR=${pkgdir} prefix=/usr \
+ localstatedir=/var sysconfdir=/etc \
+ sbindir=/usr/bin bindir=/usr/bin \
+ libdir=/usr/lib libexecdir=/usr/lib \
+ install
+}