summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2018-04-26 20:24:51 +0200
committerGrey Christoforo2018-04-26 20:24:51 +0200
commitfe2a6d6faa9604f34aaaa26c6ae185a49b1b5adf (patch)
treea103d4cd3746ed20c673c9f0f80a4b2c19a68fab
parent82595db7dfcc1e6c4ec46d0868d48c2bde5fa489 (diff)
downloadaur-fe2a6d6faa9604f34aaaa26c6ae185a49b1b5adf.tar.gz
add tester utility
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 3 deletions
diff --git a/.gitignore b/.gitignore
index cb050aac7c01..57a44ab4244f 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@ src/
pkg/
*.pkg.tar.xz
*.exe
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index cde1eeb43bbe..4e70ab814678 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Grey Christoforo <first name at last name dot net>
pkgname=thorspec
pkgver=2.8.0
-pkgrel=1
+pkgrel=2
pkgdesc="Driver for Thorlabs spectrometers"
arch=('any')
url="https://www.thorlabs.com/newgrouppage9.cfm?objectgroup_id=3482&pn=CCS175/M"
@@ -9,11 +9,13 @@ license=('custom')
makedepends=('innoextract' 'python2')
_dlver=${pkgver//./}
_dlver=V${_dlver::1}_${_dlver: -2}
-source=(setupblob_${pkgver}.exe::"https://www.thorlabs.com/software/THO/OSA/${_dlver}/ThorlabsOSASW_Full_setup.exe" "cyusb-fw-extract-py2.py" "80-spectrometer.rules")
+_cver=0.1
+source=(setupblob_${pkgver}.exe::"https://www.thorlabs.com/software/THO/OSA/${_dlver}/ThorlabsOSASW_Full_setup.exe" "cyusb-fw-extract-py2.py" "80-spectrometer.rules" "https://github.com/greyltc/thorspec/archive/${_cver}.tar.gz")
noextract=("setupblob_${pkgver}")
md5sums=('1301c516d4bd64aa348a9936ea8ee4ab'
'793c35c7b9b08baa950a63564dfb782f'
- '7083e7b40cbd3095640d227190cdd08d')
+ '7083e7b40cbd3095640d227190cdd08d'
+ '33ced3a70111e0fcffea26b780df2a48')
_firmware_loc="app/CCS/inf/Loader"
@@ -30,6 +32,9 @@ build() {
do
python2 cyusb-fw-extract-py2.py -o${firmware//.spt/} $firmware || true
done
+
+ cd thorspec-${_cver}/build
+ make
}
@@ -40,4 +45,6 @@ package() {
install -D -m644 "${firmware}" "$pkgdir/usr/lib/firmware/$(basename ${firmware})"
done
install -D -m644 80-spectrometer.rules "$pkgdir/etc/udev/rules.d/80-spectrometer.rules"
+
+ install -D -m644 thorspec-${_cver}/build/thorspec "$pkgdir/usr/bin/thorspec"
}