summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-11-20 18:59:32 +0800
committerzxp198210052023-11-20 18:59:32 +0800
commit1672939ffe37b8054300750b7864570419f1f149 (patch)
treecefe813c06248a7e90c56ecdbd4af3544742440b
parent84562ee4a274db45cd47209ae0b01b8a1123ca7b (diff)
downloadaur-1672939ffe37b8054300750b7864570419f1f149.tar.gz
fix errors
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD33
-rw-r--r--thoughts.sh7
3 files changed, 35 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3dbe070af7b9..7587f3ad2c9e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,19 @@
pkgbase = thoughts-bin
pkgdesc = 一个还算强大的Web思维导图。A relatively powerful web mind map.
pkgver = 0.7.0
- pkgrel = 1
+ pkgrel = 2
url = https://wanglin2.github.io/mind-map/#/index
arch = x86_64
license = MIT
makedepends = squashfuse
- depends = bash
depends = electron
depends = hicolor-icon-theme
+ depends = libx11
+ depends = gdk-pixbuf2
+ depends = libxext
+ depends = libdbusmenu-glib
+ depends = gtk2
+ depends = dbus-glib
provides = thoughts=0.7.0
conflicts = thoughts
source = thoughts-0.7.0.AppImage::https://github.com/wanglin2/mind-map/releases/download/electron_0.7.0/-0.7.0.AppImage
@@ -16,6 +21,6 @@ pkgbase = thoughts-bin
source = thoughts.sh
sha256sums = bdbc17da2ec25aff79057fbacfbb0f0be1dd6a6abb694dcac53854e6b8edd9cc
sha256sums = 8a19b651678a6a644640524d984ed89d0b9a78c662545715218a05130c7329c7
- sha256sums = 07dbb44e73197dfcb97193689058141b84aa6a562a5f21ae782b918bec049eca
+ sha256sums = c36118c1c69c968ba18d7be76b0869e0b15668b678f234bb8749d47f43dda039
pkgname = thoughts-bin
diff --git a/PKGBUILD b/PKGBUILD
index e1eb0117941c..25f67ecb3c3c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,44 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=thoughts-bin
pkgver=0.7.0
-pkgrel=1
+pkgrel=2
pkgdesc="一个还算强大的Web思维导图。A relatively powerful web mind map."
arch=("x86_64")
url="https://wanglin2.github.io/mind-map/#/index"
-_githuburl="https://github.com/wanglin2/mind-map"
+_ghurl="https://github.com/wanglin2/mind-map"
license=("MIT")
-depends=('bash' 'electron' 'hicolor-icon-theme')
-makedepends=('squashfuse')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
-source=("${pkgname%-bin}-${pkgver}.AppImage::${_githuburl}/releases/download/electron_${pkgver}/-${pkgver}.AppImage"
+depends=(
+ 'electron'
+ 'hicolor-icon-theme'
+ 'libx11'
+ 'gdk-pixbuf2'
+ 'libxext'
+ 'libdbusmenu-glib'
+ 'gtk2'
+ 'dbus-glib'
+)
+makedepends=(
+ 'squashfuse'
+)
+source=(
+ "${pkgname%-bin}-${pkgver}.AppImage::${_ghurl}/releases/download/electron_${pkgver}/-${pkgver}.AppImage"
"LICENSE::https://raw.githubusercontent.com/wanglin2/mind-map/electron_${pkgver}/LICENSE"
- "${pkgname%-bin}.sh")
+ "${pkgname%-bin}.sh"
+)
sha256sums=('bdbc17da2ec25aff79057fbacfbb0f0be1dd6a6abb694dcac53854e6b8edd9cc'
'8a19b651678a6a644640524d984ed89d0b9a78c662545715218a05130c7329c7'
- '07dbb44e73197dfcb97193689058141b84aa6a562a5f21ae782b918bec049eca')
-prepare() {
+ 'c36118c1c69c968ba18d7be76b0869e0b15668b678f234bb8749d47f43dda039')
+build() {
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
sed "s|AppRun --no-sandbox %U|${pkgname%-bin}|g;s|Utilities|Utility|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
- install -Dm644 "${srcdir}/squashfs-root/resources/app.asar" -t "${pkgdir}/opt/${pkgname%-bin}/resources"
- install -Dm644 "${srcdir}/squashfs-root/usr/lib/"* -t "${pkgdir}/opt/${pkgname%-bin}/usr/lib"
+ install -Dm644 "${srcdir}/squashfs-root/resources/app.asar" -t "${pkgdir}/usr/lib/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/squashfs-root/usr/lib/"* -t "${pkgdir}/opt/${pkgname%-bin}/lib"
install -Dm644 "${srcdir}/squashfs-root/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
for _icons in 32x32 128x128 256x256;do
install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/${_icons}/apps/${pkgname%-bin}.png" \
diff --git a/thoughts.sh b/thoughts.sh
index 5999c4080fd2..df59255254b9 100644
--- a/thoughts.sh
+++ b/thoughts.sh
@@ -1,8 +1,9 @@
#!/bin/bash
-APPDIR="/opt/thoughts"
-export LD_LIBRARY_PATH="${APPDIR}/usr/lib:${LD_LIBRARY_PATH}"
_ELECTRON=/usr/bin/electron
-_ASAR="${APPDIR}/resources/app.asar"
+APPDIR="/usr/lib/thoughts"
+export PATH="${APPDIR}:${PATH}"
+export LD_LIBRARY_PATH="${APPDIR}/lib:${LD_LIBRARY_PATH}"
+_ASAR="${APPDIR}/app.asar"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
exec ${_ELECTRON} ${_ASAR} "$@"
else