summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-01 16:35:28 +0800
committerzxp198210052024-03-01 16:35:28 +0800
commitb79e7db7bce78e14578abc1cfc82e45086594ee7 (patch)
tree8c22cf0cc7bdc53319c151b2e77f8fd5f5545ac1
parentcca3c4d156c23f13de5a7cdecc265ab54811dde7 (diff)
downloadaur-b79e7db7bce78e14578abc1cfc82e45086594ee7.tar.gz
fix errors
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD11
-rw-r--r--thoughts.sh9
3 files changed, 12 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d50941c222cb..cb4a73f40892 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,13 @@
pkgbase = thoughts-bin
pkgdesc = 一个还算强大的Web思维导图。A relatively powerful web mind map.
pkgver = 0.9.6
- pkgrel = 1
+ pkgrel = 2
url = https://wanglin2.github.io/mind-map/#/index
arch = x86_64
license = MIT
- makedepends = squashfuse
+ makedepends = fuse2
depends = electron28
depends = hicolor-icon-theme
- depends = dbus-glib
- depends = libdbusmenu-glib
- depends = gtk2
provides = thoughts=0.9.6
conflicts = thoughts
source = thoughts-0.9.6.AppImage::https://github.com/wanglin2/mind-map/releases/download/electron-0.9.6/-0.9.6.AppImage
@@ -18,6 +15,6 @@ pkgbase = thoughts-bin
source = thoughts.sh
sha256sums = 699755da1894dccb8b65c97a05e573f031cbc441b3dee0b609c3e0c62e7e1755
sha256sums = 8a19b651678a6a644640524d984ed89d0b9a78c662545715218a05130c7329c7
- sha256sums = 1d3f21d54a2d9d1a53661bd91c2afd00df79b0ce4057a66b4c953febfc464cd8
+ sha256sums = 50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe
pkgname = thoughts-bin
diff --git a/PKGBUILD b/PKGBUILD
index 62e69c9007ff..456df31a1bc4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=thoughts-bin
pkgver=0.9.6
_electronversion=28
-pkgrel=1
+pkgrel=2
pkgdesc="一个还算强大的Web思维导图。A relatively powerful web mind map."
arch=("x86_64")
url="https://wanglin2.github.io/mind-map/#/index"
@@ -13,12 +13,9 @@ conflicts=("${pkgname%-bin}")
depends=(
"electron${_electronversion}"
'hicolor-icon-theme'
- 'dbus-glib'
- 'libdbusmenu-glib'
- 'gtk2'
)
makedepends=(
- 'squashfuse'
+ 'fuse2'
)
source=(
"${pkgname%-bin}-${pkgver}.AppImage::${_ghurl}/releases/download/electron-${pkgver}/-${pkgver}.AppImage"
@@ -27,11 +24,11 @@ source=(
)
sha256sums=('699755da1894dccb8b65c97a05e573f031cbc441b3dee0b609c3e0c62e7e1755'
'8a19b651678a6a644640524d984ed89d0b9a78c662545715218a05130c7329c7'
- '1d3f21d54a2d9d1a53661bd91c2afd00df79b0ce4057a66b4c953febfc464cd8')
+ '50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
- -e "s|@appasar@|app.asar|g" \
+ -e "s|@runname@|app.asar|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
diff --git a/thoughts.sh b/thoughts.sh
index 0d20cddc70ca..86cb3dc6a9bf 100644
--- a/thoughts.sh
+++ b/thoughts.sh
@@ -1,14 +1,15 @@
-#!/bin/sh
+#!/bin/bash
set -e
_APPDIR="/usr/lib/@appname@"
-_ASAR="${_APPDIR}/@appasar@"
+_RUNNAME="${_APPDIR}/@runname@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
+export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_ASAR}" "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
else
- exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file