summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-09-26 17:03:05 +0800
committerzxp198210052023-09-26 17:03:05 +0800
commitbec111bddbad96bfd0f73403f007cd5849c4a2b7 (patch)
tree46f7fe1b21851a749ac8e5a48e72db5c4f35d122
parentb399c379bc7afa014df1a884d2f87e408460b8cd (diff)
downloadaur-bec111bddbad96bfd0f73403f007cd5849c4a2b7.tar.gz
fix errors
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
-rw-r--r--thoughts.sh4
3 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8801bbecf671..80c9ad3fcd09 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,10 +11,10 @@ pkgbase = thoughts-bin
provides = thoughts=0.5.0
conflicts = thoughts
source = thoughts-0.5.0.AppImage::https://github.com/wanglin2/mind-map/releases/download/electron_0.5.0/linux0.5.0.AppImage
- source = LICENSE::https://raw.githubusercontent.com/wanglin2/mind-map/main/LICENSE
+ source = LICENSE::https://raw.githubusercontent.com/wanglin2/mind-map/electron_0.5.0/LICENSE
source = thoughts.sh
sha256sums = 856b46f6008d8c2d109be866ed49cf4e10a16b0091cbb251b237df86b6db0913
sha256sums = 8a19b651678a6a644640524d984ed89d0b9a78c662545715218a05130c7329c7
- sha256sums = 63dd3e4550c82c3ef47a2080c86712b2ec7d26df4a08d0cc401c2281796b1903
+ sha256sums = 07dbb44e73197dfcb97193689058141b84aa6a562a5f21ae782b918bec049eca
pkgname = thoughts-bin
diff --git a/PKGBUILD b/PKGBUILD
index 27c0cc2f0614..43c72dbfb3ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,12 +10,12 @@ license=("MIT")
depends=('bash' 'electron' 'hicolor-icon-theme')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
-source=("${pkgname%-bin}-${pkgver}.AppImage::${_githuburl}/releases/download/electron_${pkgver}/linux0.5.0.AppImage"
- "LICENSE::https://raw.githubusercontent.com/wanglin2/mind-map/main/LICENSE"
+source=("${pkgname%-bin}-${pkgver}.AppImage::${_githuburl}/releases/download/electron_${pkgver}/linux${pkgver}.AppImage"
+ "LICENSE::https://raw.githubusercontent.com/wanglin2/mind-map/electron_${pkgver}/LICENSE"
"${pkgname%-bin}.sh")
sha256sums=('856b46f6008d8c2d109be866ed49cf4e10a16b0091cbb251b237df86b6db0913'
'8a19b651678a6a644640524d984ed89d0b9a78c662545715218a05130c7329c7'
- '63dd3e4550c82c3ef47a2080c86712b2ec7d26df4a08d0cc401c2281796b1903')
+ '07dbb44e73197dfcb97193689058141b84aa6a562a5f21ae782b918bec049eca')
prepare() {
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
@@ -23,11 +23,12 @@ prepare() {
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
- install -Dm644 "${srcdir}/squashfs-root/resources/app.asar" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}.asar"
+ install -Dm644 "${srcdir}/squashfs-root/resources/app.asar" -t "${pkgdir}/opt/${pkgname%-bin}/resources"
+ install -Dm644 "${srcdir}/squashfs-root/usr/lib/"* -t "${pkgdir}/opt/${pkgname%-bin}/usr/lib"
install -Dm644 "${srcdir}/squashfs-root/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
for _icons in 32x32 128x128 256x256;do
install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/${_icons}/apps/${pkgname%-bin}.png" \
-t "${pkgdir}/usr/share/icons/hicolor/${_icons}/apps"
done
install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
-} \ No newline at end of file
+}
diff --git a/thoughts.sh b/thoughts.sh
index 699c3b540a84..5999c4080fd2 100644
--- a/thoughts.sh
+++ b/thoughts.sh
@@ -1,6 +1,8 @@
#!/bin/bash
+APPDIR="/opt/thoughts"
+export LD_LIBRARY_PATH="${APPDIR}/usr/lib:${LD_LIBRARY_PATH}"
_ELECTRON=/usr/bin/electron
-_ASAR="/opt/thoughts/thoughts.asar"
+_ASAR="${APPDIR}/resources/app.asar"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
exec ${_ELECTRON} ${_ASAR} "$@"
else