summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-01-29 10:48:33 +0800
committerzxp198210052024-01-29 10:48:33 +0800
commitcca3c4d156c23f13de5a7cdecc265ab54811dde7 (patch)
treecc9caad0732609fb9c7d88366a63edbd2d7c84cc
parent758bfa75ed96bef06a9091f65a44b6d406fb1c09 (diff)
downloadaur-cca3c4d156c23f13de5a7cdecc265ab54811dde7.tar.gz
update to 0.9.6
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD13
-rw-r--r--thoughts.sh9
3 files changed, 16 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bacbf1e63d45..d50941c222cb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,23 @@
pkgbase = thoughts-bin
pkgdesc = 一个还算强大的Web思维导图。A relatively powerful web mind map.
- pkgver = 0.9.2
+ pkgver = 0.9.6
pkgrel = 1
url = https://wanglin2.github.io/mind-map/#/index
arch = x86_64
license = MIT
makedepends = squashfuse
- depends = electron25
+ depends = electron28
depends = hicolor-icon-theme
- depends = libx11
- depends = gdk-pixbuf2
- depends = libxext
+ depends = dbus-glib
depends = libdbusmenu-glib
depends = gtk2
- depends = dbus-glib
- provides = thoughts=0.9.2
+ provides = thoughts=0.9.6
conflicts = thoughts
- source = thoughts-0.9.2.AppImage::https://github.com/wanglin2/mind-map/releases/download/electron-0.9.2/-0.9.2.AppImage
- source = LICENSE-0.9.2::https://raw.githubusercontent.com/wanglin2/mind-map/electron-0.9.2/LICENSE
+ source = thoughts-0.9.6.AppImage::https://github.com/wanglin2/mind-map/releases/download/electron-0.9.6/-0.9.6.AppImage
+ source = LICENSE-0.9.6::https://raw.githubusercontent.com/wanglin2/mind-map/electron-0.9.6/LICENSE
source = thoughts.sh
- sha256sums = 225197c56ef546f8cdf560d1b849927b124373d72af1d4cedfeb41fff2403341
+ sha256sums = 699755da1894dccb8b65c97a05e573f031cbc441b3dee0b609c3e0c62e7e1755
sha256sums = 8a19b651678a6a644640524d984ed89d0b9a78c662545715218a05130c7329c7
- sha256sums = 5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf
+ sha256sums = 1d3f21d54a2d9d1a53661bd91c2afd00df79b0ce4057a66b4c953febfc464cd8
pkgname = thoughts-bin
diff --git a/PKGBUILD b/PKGBUILD
index 252f81588dfc..62e69c9007ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=thoughts-bin
-pkgver=0.9.2
-_electronversion=25
+pkgver=0.9.6
+_electronversion=28
pkgrel=1
pkgdesc="一个还算强大的Web思维导图。A relatively powerful web mind map."
arch=("x86_64")
@@ -13,12 +13,9 @@ conflicts=("${pkgname%-bin}")
depends=(
"electron${_electronversion}"
'hicolor-icon-theme'
- 'libx11'
- 'gdk-pixbuf2'
- 'libxext'
+ 'dbus-glib'
'libdbusmenu-glib'
'gtk2'
- 'dbus-glib'
)
makedepends=(
'squashfuse'
@@ -28,9 +25,9 @@ source=(
"LICENSE-${pkgver}::https://raw.githubusercontent.com/wanglin2/mind-map/electron-${pkgver}/LICENSE"
"${pkgname%-bin}.sh"
)
-sha256sums=('225197c56ef546f8cdf560d1b849927b124373d72af1d4cedfeb41fff2403341'
+sha256sums=('699755da1894dccb8b65c97a05e573f031cbc441b3dee0b609c3e0c62e7e1755'
'8a19b651678a6a644640524d984ed89d0b9a78c662545715218a05130c7329c7'
- '5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf')
+ '1d3f21d54a2d9d1a53661bd91c2afd00df79b0ce4057a66b4c953febfc464cd8')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
diff --git a/thoughts.sh b/thoughts.sh
index c77c53567639..0d20cddc70ca 100644
--- a/thoughts.sh
+++ b/thoughts.sh
@@ -6,12 +6,9 @@ export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
export NODE_ENV=production
+cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- cd "${_APPDIR}"
- exec electron@electronversion@ "${_ASAR}" "$@"
- exit
+ exec electron@electronversion@ "${_ASAR}" "$@" || exit $?
else
- cd "${_APPDIR}"
- exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
- exit
+ exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file