summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-13 09:42:44 +0800
committerzxp198210052024-03-13 09:42:44 +0800
commitde5cfee0b856eeee99a7ce833f65d021a98e6974 (patch)
tree3798c9a72e61d1091003a335e79ac666cebbe035
parentb79e7db7bce78e14578abc1cfc82e45086594ee7 (diff)
downloadaur-de5cfee0b856eeee99a7ce833f65d021a98e6974.tar.gz
update to 0.9.8
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD15
-rw-r--r--thoughts.sh5
3 files changed, 19 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb4a73f40892..9a996a00078b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,20 @@
pkgbase = thoughts-bin
pkgdesc = 一个还算强大的Web思维导图。A relatively powerful web mind map.
- pkgver = 0.9.6
- pkgrel = 2
+ pkgver = 0.9.8
+ pkgrel = 1
url = https://wanglin2.github.io/mind-map/#/index
arch = x86_64
license = MIT
makedepends = fuse2
- depends = electron28
+ depends = electron23
depends = hicolor-icon-theme
- provides = thoughts=0.9.6
+ provides = thoughts=0.9.8
conflicts = thoughts
- source = thoughts-0.9.6.AppImage::https://github.com/wanglin2/mind-map/releases/download/electron-0.9.6/-0.9.6.AppImage
- source = LICENSE-0.9.6::https://raw.githubusercontent.com/wanglin2/mind-map/electron-0.9.6/LICENSE
+ source = thoughts-0.9.8.AppImage::https://github.com/wanglin2/mind-map/releases/download/electron-0.9.8/-0.9.8.AppImage
+ source = LICENSE-0.9.8::https://raw.githubusercontent.com/wanglin2/mind-map/electron-0.9.8/LICENSE
source = thoughts.sh
- sha256sums = 699755da1894dccb8b65c97a05e573f031cbc441b3dee0b609c3e0c62e7e1755
+ sha256sums = 75d34ee9f257a9495ffc5f9a56b021077f2a94934c3e4e82fe3ef88550e60f37
sha256sums = 8a19b651678a6a644640524d984ed89d0b9a78c662545715218a05130c7329c7
- sha256sums = 50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe
+ sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
pkgname = thoughts-bin
diff --git a/PKGBUILD b/PKGBUILD
index 456df31a1bc4..4ebebf8c4cf0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=thoughts-bin
-pkgver=0.9.6
-_electronversion=28
-pkgrel=2
+pkgver=0.9.8
+_electronversion=23
+pkgrel=1
pkgdesc="一个还算强大的Web思维导图。A relatively powerful web mind map."
arch=("x86_64")
url="https://wanglin2.github.io/mind-map/#/index"
@@ -22,22 +22,23 @@ source=(
"LICENSE-${pkgver}::https://raw.githubusercontent.com/wanglin2/mind-map/electron-${pkgver}/LICENSE"
"${pkgname%-bin}.sh"
)
-sha256sums=('699755da1894dccb8b65c97a05e573f031cbc441b3dee0b609c3e0c62e7e1755'
+sha256sums=('75d34ee9f257a9495ffc5f9a56b021077f2a94934c3e4e82fe3ef88550e60f37'
'8a19b651678a6a644640524d984ed89d0b9a78c662545715218a05130c7329c7'
- '50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe')
+ 'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|app.asar|g" \
+ -e "s|@options@||g" \
-i "${srcdir}/${pkgname%-bin}.sh"
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
- sed "s|AppRun --no-sandbox|${pkgname%-bin}|g;s|Utilities|Utility|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
+ sed "s|AppRun --no-sandbox|${pkgname%-bin}|g;s|Utilities|Office|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
install -Dm644 "${srcdir}/squashfs-root/resources/app.asar" -t "${pkgdir}/usr/lib/${pkgname%-bin}"
- install -Dm644 "${srcdir}/squashfs-root/usr/lib/"* -t "${pkgdir}/opt/${pkgname%-bin}/lib"
+ install -Dm644 "${srcdir}/squashfs-root/usr/lib/"* -t "${pkgdir}/usr/lib/${pkgname%-bin}/lib"
install -Dm644 "${srcdir}/squashfs-root/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
for _icons in 32x32 128x128 256x256;do
install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/${_icons}/apps/${pkgname%-bin}.png" \
diff --git a/thoughts.sh b/thoughts.sh
index 86cb3dc6a9bf..7ddcaab8d734 100644
--- a/thoughts.sh
+++ b/thoughts.sh
@@ -2,6 +2,7 @@
set -e
_APPDIR="/usr/lib/@appname@"
_RUNNAME="${_APPDIR}/@runname@"
+_OPTIONS="@options@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
@@ -9,7 +10,7 @@ export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "$@" || exit $?
else
- exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file