summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-08-31 13:11:19 +0800
committerzxp198210052023-08-31 13:11:19 +0800
commitf13e14058a491b45da8e058a876d1482b5bfb139 (patch)
tree03817f0ab2885d8f02c3956652801d72dc7e7d47
downloadaur-f13e14058a491b45da8e058a876d1482b5bfb139.tar.gz
update to 0.5.0
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD33
-rw-r--r--thoughts.sh8
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..abf4dc9d7f61
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = thoughts-bin
+ pkgdesc = 一个还算强大的Web思维导图。A relatively powerful web mind map.
+ pkgver = 0.5.0
+ pkgrel = 1
+ url = https://wanglin2.github.io/mind-map/#/index
+ arch = x86_64
+ license = MIT
+ depends = bash
+ depends = electron
+ depends = hicolor-icon-theme
+ provides = thoughts=0.5.0
+ conflicts = thoughts
+ source = thoughts-0.5.0.AppImage::/releases/download/electron_0.5.0/linux0.5.0.AppImage
+ source = LICENSE::https://raw.githubusercontent.com/wanglin2/mind-map/main/LICENSE
+ source = thoughts.sh
+ sha256sums = 856b46f6008d8c2d109be866ed49cf4e10a16b0091cbb251b237df86b6db0913
+ sha256sums = 8a19b651678a6a644640524d984ed89d0b9a78c662545715218a05130c7329c7
+ sha256sums = 63dd3e4550c82c3ef47a2080c86712b2ec7d26df4a08d0cc401c2281796b1903
+
+pkgname = thoughts-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1bced4df7c71
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname=thoughts-bin
+pkgver=0.5.0
+pkgrel=1
+pkgdesc="一个还算强大的Web思维导图。A relatively powerful web mind map."
+arch=("x86_64")
+url="https://wanglin2.github.io/mind-map/#/index"
+_githuburl="https://github.com/wanglin2/mind-map"
+license=("MIT")
+depends=('bash' 'electron' 'hicolor-icon-theme')
+provides=("${pkgname%-bin}=${pkgver}")
+conflicts=("${pkgname%-bin}")
+source=("${pkgname%-bin}-${pkgver}.AppImage::${_downurl}/releases/download/electron_${pkgver}/linux0.5.0.AppImage"
+ "LICENSE::https://raw.githubusercontent.com/wanglin2/mind-map/main/LICENSE"
+ "${pkgname%-bin}.sh")
+sha256sums=('856b46f6008d8c2d109be866ed49cf4e10a16b0091cbb251b237df86b6db0913'
+ '8a19b651678a6a644640524d984ed89d0b9a78c662545715218a05130c7329c7'
+ '63dd3e4550c82c3ef47a2080c86712b2ec7d26df4a08d0cc401c2281796b1903')
+prepare() {
+ chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
+ "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
+ sed "s|AppRun --no-sandbox %U|${pkgname%-bin}|g;s|Utilities|Utility|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
+}
+package() {
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/squashfs-root/resources/app.asar" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}.asar"
+ install -Dm644 "${srcdir}/squashfs-root/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
+ for _icons in 32x32 128x128 256x256;do
+ install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/${_icons}/apps/${pkgname%-bin}.png" \
+ -t "${pkgdir}/usr/share/icons/hicolor/${_icons}/apps"
+ done
+ install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+} \ No newline at end of file
diff --git a/thoughts.sh b/thoughts.sh
new file mode 100644
index 000000000000..699c3b540a84
--- /dev/null
+++ b/thoughts.sh
@@ -0,0 +1,8 @@
+#!/bin/bash
+_ELECTRON=/usr/bin/electron
+_ASAR="/opt/thoughts/thoughts.asar"
+if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
+ exec ${_ELECTRON} ${_ASAR} "$@"
+else
+ exec ${_ELECTRON} ${_ASAR} --no-sandbox "$@"
+fi \ No newline at end of file