summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTolga HOŞGÖR2015-06-09 03:27:32 +0300
committerTolga HOŞGÖR2015-06-09 03:28:39 +0300
commit1f13e5588bd7e9f0377bd46e2e5b35b1f5fd37c3 (patch)
tree44a3615ba892771e70f770c855b9b64dc611c534
downloadaur-1f13e5588bd7e9f0377bd46e2e5b35b1f5fd37c3.tar.gz
initial commit
Signed-off-by: Tolga HOŞGÖR <fasdfasdas@gmail.com>
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..095289d31208
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = threadpool11-git
+ pkgdesc = A fast, lock-free, cross-platform C++11 thread pooling library that is aiming to be lightweight and simple.
+ pkgver = 2.0.6.r3.g31e6849
+ pkgrel = 1
+ url = https://github.com/tghosgor/threadpool11
+ arch = any
+ license = LGPL3
+ makedepends = boost
+ options = staticlibs
+ source = threadpool11-git::git+https://github.com/tghosgor/threadpool11.git
+ sha512sums = SKIP
+
+pkgname = threadpool11-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4014df9b1ec5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+pkgname=threadpool11-git
+pkgdesc='A fast, lock-free, cross-platform C++11 thread pooling library that is aiming to be lightweight and simple.'
+pkgver=2.0.6.r3.g31e6849
+pkgver() {
+ cd "$pkgname"
+ git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+pkgrel=1
+source=("$pkgname"'::git+https://github.com/tghosgor/threadpool11.git')
+arch=('any')
+url=('https://github.com/tghosgor/threadpool11')
+license=('LGPL3')
+makedepends=(
+ 'boost' # Boost.Lockfree is used, there is an internal copy if you do not have it installed but we want it to be recent for this.
+)
+sha512sums=('SKIP')
+options=('staticlibs')
+
+package() {
+ cd "$srcdir"/$pkgname
+ cmake -DCMAKE_INSTALL_PREFIX="$pkgdir"/usr
+ make install
+}