summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTolga Hoşgör2021-03-30 16:45:55 +0300
committerTolga Hoşgör2021-03-30 16:46:40 +0300
commit21298463d36d7d885f0cc330245ed269c8aab532 (patch)
treef1c1ff55069625daff8908959571fc43fbf6ec57
parentb101ada6e406afb92181978f84c0100e6713b0b8 (diff)
downloadaur-21298463d36d7d885f0cc330245ed269c8aab532.tar.gz
fix: update makedepends & license
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ca4abc262ced..1730cbbf185b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,14 @@
pkgbase = threadpool11-git
pkgdesc = A fast, lock-free, cross-platform C++11 thread pooling library that is aiming to be lightweight and simple.
- pkgver = 2.0.8.r0.g46c9afc
+ pkgver = 3.0.0.r3.g8998e5c
pkgrel = 1
url = https://github.com/tghosgor/threadpool11
arch = any
license = LGPL3
makedepends = boost
+ makedepends = cmake
+ makedepends = git
+ makedepends = make
options = staticlibs
source = threadpool11-git::git+https://github.com/tghosgor/threadpool11.git
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 7b4f222e7d6c..80b2904a2244 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=threadpool11-git
pkgdesc='A fast, lock-free, cross-platform C++11 thread pooling library that is aiming to be lightweight and simple.'
-pkgver=2.0.8.r0.g46c9afc
+pkgver=3.0.0.r3.g8998e5c
pkgver() {
cd "$pkgname"
git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
@@ -8,10 +8,13 @@ pkgver() {
pkgrel=1
source=("$pkgname"'::git+https://github.com/tghosgor/threadpool11.git')
arch=('any')
-url=('https://github.com/tghosgor/threadpool11')
-license=('LGPL3')
+url='https://github.com/tghosgor/threadpool11'
+license=('MIT')
makedepends=(
- 'boost' # Boost.Lockfree is used, there is an internal copy if you do not have it installed but we want it to be recent for this.
+ 'boost'
+ 'cmake'
+ 'git'
+ 'make'
)
sha512sums=('SKIP')
options=('staticlibs')