summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwincak2018-01-18 23:04:29 +0200
committerwincak2018-01-18 23:04:29 +0200
commit0518d030b6254492019f60c1380cd7e3d5c238f6 (patch)
treef30587adf3efb5a679b6522b0a66db394b66f66b
downloadaur-0518d030b6254492019f60c1380cd7e3d5c238f6.tar.gz
First testing version
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD35
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2cd4f2883021
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = threshy
+ pkgdesc = ThinkPad battery threshold configuration using TLP and D-Bus
+ pkgver = 0.1
+ pkgrel = 0
+ url = https://gitlab.com/wincak/threshy
+ arch = x86_64
+ license = GPL
+ makedepends = cmake>=3.10
+ depends = tlp>=1.0
+ depends = dbus>=1.12
+ depends = qt5-base>=5.9
+ source = git+https://gitlab.com/wincak/threshy.git#branch=master
+ md5sums = SKIP
+
+pkgname = threshy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d573268a8ece
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: wincak <wincak@seznam.cz>
+pkgname=threshy
+pkgver=0.1
+pkgrel=0
+pkgdesc="ThinkPad battery threshold configuration using TLP and D-Bus"
+arch=('x86_64')
+url="https://gitlab.com/wincak/threshy"
+license=('GPL')
+#groups=()
+depends=('tlp>=1.0' 'dbus>=1.12' 'qt5-base>=5.9')
+makedepends=('cmake>=3.10')
+install=
+source=("git+https://gitlab.com/wincak/threshy.git#branch=master")
+md5sums=('SKIP')
+
+prepare() {
+ cd "$pkgname"
+}
+
+build() {
+ cd "$pkgname"
+
+ cmake -DCMAKE_INSTALL_PREFIX="/usr" CMakeLists.txt
+ make
+}
+
+check() {
+ cd "$pkgname"
+ #make -k check
+}
+
+package() {
+ cd "$pkgname"
+ make DESTDIR="$pkgdir/" install
+}