summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkaptoxic2016-04-29 12:40:04 -0400
committerkaptoxic2016-04-29 12:40:04 -0400
commit1edf00afaf89c810edbff094054e32a6351fff90 (patch)
tree26e6ef4807bdd7f9f02c720e7e04eaa116356e90
parent547e29783256cdacab8d01355e3859027da1e5a1 (diff)
downloadaur-1edf00afaf89c810edbff094054e32a6351fff90.tar.gz
Update and fix build
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
2 files changed, 29 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 23f595dfe5bd..5f18ac1a7cae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,29 +1,28 @@
# Generated by mksrcinfo v8
-# Fri Apr 29 06:26:42 UTC 2016
+# Fri Apr 29 16:40:01 UTC 2016
pkgbase = thrift-java
pkgdesc = Java bindings for Thrift, a scalable cross-language services framework for IPC/RPC
- pkgver = 0.9.1
+ pkgver = 0.9.3
pkgrel = 1
url = http://thrift.apache.org/
arch = i686
arch = x86_64
license = APACHE
makedepends = automake
+ makedepends = libevent
makedepends = autoconf
makedepends = libtool
makedepends = apache-ant
makedepends = java-environment
- depends = zlib
- depends = libevent
+ depends = gcc-libs
depends = openssl
depends = java-runtime
- optdepends = thrift-base: for the Thrift compiler
- optdepends = vim-thrift: for syntax highlighting in vim
+ optdepends = thrift: for the Thrift compiler and syntax highlighting in vim/emacs
options = !emptydirs
options = !makeflags
- source = http://www.apache.org/dist/thrift/0.9.1/thrift-0.9.1.tar.gz
+ source = https://github.com/apache/thrift/archive/0.9.3.tar.gz
source = maven-repo-path.patch
- md5sums = d2e46148f6e800a9492dbd848c66ab6e
+ md5sums = 193ecb66ff1cc4282e7625aa263622bf
md5sums = bfcb3b12a8c07d5d0d9e96a7e712a74c
pkgname = thrift-java
diff --git a/PKGBUILD b/PKGBUILD
index 5db8b5a08abf..daefc418a783 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,22 @@
+# Contributor: kaptoxic@yahoo.com
# Contributor: Jochen Schalanda <jochen+aur@schalanda.name>
# Contributor: Byron Clark <byron@theclarkfamily.name>
+
pkgname=thrift-java
-pkgver=0.9.1
+pkgver=0.9.3
pkgrel=1
pkgdesc="Java bindings for Thrift, a scalable cross-language services framework for IPC/RPC"
arch=(i686 x86_64)
url="http://thrift.apache.org/"
license=(APACHE)
-depends=(zlib libevent openssl java-runtime)
-makedepends=(automake autoconf libtool apache-ant java-environment)
+depends=(gcc-libs openssl java-runtime)
+makedepends=(automake libevent autoconf libtool apache-ant java-environment)
optdepends=(
- 'thrift-base: for the Thrift compiler'
- 'vim-thrift: for syntax highlighting in vim')
+ 'thrift: for the Thrift compiler and syntax highlighting in vim/emacs')
options=(!emptydirs !makeflags)
-source=(http://www.apache.org/dist/thrift/$pkgver/thrift-$pkgver.tar.gz
+source=(https://github.com/apache/thrift/archive/$pkgver.tar.gz
maven-repo-path.patch)
-md5sums=('d2e46148f6e800a9492dbd848c66ab6e'
+md5sums=('193ecb66ff1cc4282e7625aa263622bf'
'bfcb3b12a8c07d5d0d9e96a7e712a74c')
build() {
@@ -26,6 +27,7 @@ build() {
# apache-ant is not installed in a normal path location
. /etc/profile.d/apache-ant.sh
+ ./bootstrap.sh
./configure --prefix=/usr \
--without-cpp \
--without-qt4 \
@@ -40,7 +42,19 @@ build() {
--without-ruby \
--without-haskell \
--without-go \
- --without-d
+ --without-d \
+ --without-haskell \
+ --without-php \
+ --without-ruby \
+ --without-python \
+ --without-erlang \
+ --without-perl \
+ --without-c_sharp \
+ --without-d \
+ --without-php \
+ --without-go \
+ --without-lua \
+ --without-nodejs
make
}