summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Kuc2020-12-12 18:18:55 +0000
committerMichael Kuc2020-12-12 18:18:55 +0000
commit8240cf37675b07a481c6f470126aa9c36abdb791 (patch)
tree93b2405f87c721d85ec46262216c18430cf3a797
parentf5882f0357a424ae37032feb17392164e626428a (diff)
downloadaur-8240cf37675b07a481c6f470126aa9c36abdb791.tar.gz
Fix packaging issues with install directory variable expansion.
Fixes an issue with a submodule's CMakeLists. Also fixes some CMake default install path issues.
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD24
-rw-r--r--foxxll_CMakeLists.txt.patch19
3 files changed, 40 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8d82dc276fe0..a26c14d25f86 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,18 @@
pkgbase = thrill-git
pkgdesc = Thrill is an EXPERIMENTAL C++ framework for algorithmic distributed Big Data batch computations on a cluster of machines.
pkgver = 12c5b59bc
- pkgrel = 1
+ pkgrel = 2
epoch = 1
url = https://github.com/thrill/thrill
arch = x86_64
license = BSD
+ depends = cmake
provides = thrill
conflicts = thrill
source = thrill::git+https://github.com/thrill/thrill.git
+ source = foxxll_CMakeLists.txt.patch
sha256sums = SKIP
+ sha256sums = d6fae47a05ee842dbc68568f2da22de01d3f7035a2993bde54cd3dd8486750b4
pkgname = thrill-git
diff --git a/PKGBUILD b/PKGBUILD
index b9da6175f9b1..18df6c16dfa4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,29 +2,39 @@
_pkgname=thrill
pkgname=${_pkgname}-git
pkgver=12c5b59bc
-pkgrel=1
+pkgrel=2
pkgdesc="Thrill is an EXPERIMENTAL C++ framework for algorithmic distributed Big Data batch computations on a cluster of machines."
arch=('x86_64')
url="https://github.com/thrill/thrill"
license=('BSD')
-depends=()
+depends=('cmake')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
epoch=1
-source=("${_pkgname}::git+https://github.com/thrill/thrill.git")
-
-sha256sums=('SKIP')
+source=("${_pkgname}::git+https://github.com/thrill/thrill.git" "foxxll_CMakeLists.txt.patch")
+sha256sums=(
+ 'SKIP'
+ 'd6fae47a05ee842dbc68568f2da22de01d3f7035a2993bde54cd3dd8486750b4'
+)
pkgver() {
cd "${srcdir}/${_pkgname}"
git describe --long --tags --always | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-build() {
+prepare() {
+ patch -p1 < foxxll_CMakeLists.txt.patch
cd "${srcdir}/${_pkgname}"
+ git submodule update --init --recursive
mkdir -p build
cd build
- cmake -DTHRILL_BUILD_TESTS=OFF ..
+ cmake -DTHRILL_BUILD_TESTS=OFF -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_INCLUDE_DIR=/usr/include ..
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ cd build
+ make
}
package() {
diff --git a/foxxll_CMakeLists.txt.patch b/foxxll_CMakeLists.txt.patch
new file mode 100644
index 000000000000..e1e20223d29c
--- /dev/null
+++ b/foxxll_CMakeLists.txt.patch
@@ -0,0 +1,19 @@
+*** src/thrill/extlib/foxxll/CMakeLists.txt 2020-12-12 18:07:40.834330158 +0000
+--- CMakeLists.txt 2020-12-12 18:09:34.745282128 +0000
+***************
+*** 507,513 ****
+
+ # also copy the config file with build options!
+ install(FILES ${PROJECT_BINARY_DIR}/foxxll/config.hpp
+! DESTINATION ${INSTALL_INCLUDE_DIR}/foxxll/)
+
+ ###############################################################################
+ # prepare pkg-config file
+--- 507,513 ----
+
+ # also copy the config file with build options!
+ install(FILES ${PROJECT_BINARY_DIR}/foxxll/config.hpp
+! DESTINATION ${FOXXLL_INSTALL_INCLUDE_DIR}/foxxll/)
+
+ ###############################################################################
+ # prepare pkg-config file