summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastien Duthil2017-08-05 17:41:44 -0400
committerSebastien Duthil2017-08-05 17:43:18 -0400
commit7a93658dd6963502194ff827cb264e1b63fe49d5 (patch)
tree49ca50fee756172fdcff20fc20fc7522f85febda
downloadaur-7a93658dd6963502194ff827cb264e1b63fe49d5.tar.gz
package for version 0.3.4
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD30
-rw-r--r--thrive.sh4
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..74fe364d05ed
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = thrive
+ pkgdesc = Game about evolution, in which the player guides a species from their origin as a microbe to the space age and beyond.
+ pkgver = 0.3.4
+ pkgrel = 1
+ url = http://revolutionarygamesstudio.com
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = p7zip
+ depends = jasper
+ depends = ilbc
+ depends = libidn2
+ source = https://github.com/Revolutionary-Games/Thrive/releases/download/v0.3.4/LINUX_Thrive.0.3.4.7z
+ source = thrive.sh
+ sha256sums = 2d1cb3bc0c808aa6ca32f8c0d8979c2a79e81879a70e5d227723d7a782017502
+ sha256sums = d4ffae8d96c0a2e2f23a281053a6d5817f964668556e770c2b62574d86c74ce7
+
+pkgname = thrive
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f8163a526c41
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Sebastien Duthil <duthils@free.fr>
+
+pkgname=thrive
+pkgver=0.3.4
+pkgrel=1
+pkgdesc="Game about evolution, in which the player guides a species from their origin as a microbe to the space age and beyond. "
+arch=('i686' 'x86_64')
+url="http://revolutionarygamesstudio.com"
+license=('GPL')
+depends=('jasper' 'ilbc' 'libidn2')
+makedepends=('p7zip')
+source=(https://github.com/Revolutionary-Games/Thrive/releases/download/v${pkgver}/LINUX_Thrive.${pkgver}.7z
+ thrive.sh)
+sha256sums=('2d1cb3bc0c808aa6ca32f8c0d8979c2a79e81879a70e5d227723d7a782017502'
+ 'd4ffae8d96c0a2e2f23a281053a6d5817f964668556e770c2b62574d86c74ce7')
+_Pkgname=Thrive
+
+package() {
+ cd "$srcdir/$_Pkgname-$pkgver"
+
+ mkdir -p "$pkgdir/opt/thrive"
+ cp -r * "$pkgdir/opt/thrive"
+ chgrp -R games "$pkgdir/opt/thrive"
+ chmod -R g+w "$pkgdir/opt/thrive"
+ install -Dm755 "$srcdir/thrive.sh" "$pkgdir/usr/bin/thrive"
+
+ # workaround hard dependency to libilbc.so.0, when ilbc only provides libilbc.so
+ mkdir -p "$pkgdir/usr/lib"
+ ln -s libilbc.so "$pkgdir/usr/lib/libilbc.so.0"
+}
diff --git a/thrive.sh b/thrive.sh
new file mode 100644
index 000000000000..36bb4e584690
--- /dev/null
+++ b/thrive.sh
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+cd /opt/thrive/bin
+LD_LIBRARY_PATH="$(pwd)" ./Thrive