summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaroslav Lichtblau2014-11-28 20:17:14 +0100
committerJaroslav Lichtblau2014-11-28 20:17:14 +0100
commit26517b30c9a016b5c83aea54147214c229a23761 (patch)
tree64a04d916fc879697d3c5188e3382fa0f8f938ea
downloadaur-26517b30c9a016b5c83aea54147214c229a23761.tar.gz
Initial PKGBUILD status as of 28.11.2014
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD21
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..60aa69b77600
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = throttle
+ pkgdesc = Copies the standard input to the standard output while limiting bandwidth to the specified maximum.
+ pkgver = 1.2
+ pkgrel = 1
+ url = http://klicman.org/throttle/
+ arch = i686
+ license = GPL
+ depends = glibc
+ source = http://klicman.org/throttle/throttle-1.2.tar.gz
+ md5sums = bb8abf5a9a63ed7d80951f056543a88c
+
+pkgname = throttle
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4f151751c3fa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Contributor: Dragonlord <archlinux[at]dragonlord[.]cz>
+
+pkgname=throttle
+pkgver=1.2
+pkgrel=1
+pkgdesc="Copies the standard input to the standard output while limiting bandwidth to the specified maximum."
+arch=('i686')
+url="http://klicman.org/throttle/"
+license=('GPL')
+depends=('glibc')
+source=(http://klicman.org/$pkgname/$pkgname-$pkgver.tar.gz)
+
+md5sums=('bb8abf5a9a63ed7d80951f056543a88c')
+
+build() {
+ cd "$startdir/src/$pkgname-$pkgver"
+
+ ./configure --prefix=/usr --mandir=/usr/share/man
+ make || return 1
+ make DESTDIR="$startdir/pkg" install
+}