summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaroslav Lichtblau2014-11-29 13:41:24 +0100
committerJaroslav Lichtblau2014-11-29 13:41:24 +0100
commit84de686550dd2c2a9e1fb82615469381349982c4 (patch)
treecbe8165bd5a0c98715a7505b860c0aa86bcc31fc
parent26517b30c9a016b5c83aea54147214c229a23761 (diff)
downloadaur-84de686550dd2c2a9e1fb82615469381349982c4.tar.gz
throttle-1.2-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD21
2 files changed, 15 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 60aa69b77600..4ab2d22a3cdf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = throttle
- pkgdesc = Copies the standard input to the standard output while limiting bandwidth to the specified maximum.
+ pkgdesc = Copies the standard input to the standard output while limiting bandwidth to the specified maximum
pkgver = 1.2
pkgrel = 1
url = http://klicman.org/throttle/
arch = i686
+ arch = x86_64
license = GPL
- depends = glibc
- source = http://klicman.org/throttle/throttle-1.2.tar.gz
+ source = ftp://ftp.fi.freebsd.org/pub/FreeBSD/ports/distfiles/throttle-1.2.tar.gz
md5sums = bb8abf5a9a63ed7d80951f056543a88c
pkgname = throttle
diff --git a/PKGBUILD b/PKGBUILD
index 4f151751c3fa..46cd992e2abf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,24 @@
-# Contributor: Dragonlord <archlinux[at]dragonlord[.]cz>
+# Maintainer: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
pkgname=throttle
pkgver=1.2
pkgrel=1
-pkgdesc="Copies the standard input to the standard output while limiting bandwidth to the specified maximum."
-arch=('i686')
+pkgdesc="Copies the standard input to the standard output while limiting bandwidth to the specified maximum"
+arch=('i686' 'x86_64')
url="http://klicman.org/throttle/"
license=('GPL')
-depends=('glibc')
-source=(http://klicman.org/$pkgname/$pkgname-$pkgver.tar.gz)
-
+source=(ftp://ftp.fi.freebsd.org/pub/FreeBSD/ports/distfiles/$pkgname-$pkgver.tar.gz)
md5sums=('bb8abf5a9a63ed7d80951f056543a88c')
build() {
- cd "$startdir/src/$pkgname-$pkgver"
+ cd "${srcdir}"/$pkgname-$pkgver
./configure --prefix=/usr --mandir=/usr/share/man
- make || return 1
- make DESTDIR="$startdir/pkg" install
+ make
+}
+
+package() {
+ cd "${srcdir}"/$pkgname-$pkgver
+
+ make DESTDIR="${pkgdir}" install
}