summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQue Quotion2016-10-23 20:48:55 +0900
committerQue Quotion2016-10-23 20:48:55 +0900
commit05779cb5dacae2965958e9d55ebef3c43b6e3ef2 (patch)
treee023da0516e75c8c0b3851b7c44befc84b2cc244
parent636a03b0b6b7e5e2a45d37459d992953904a845d (diff)
downloadaur-05779cb5dacae2965958e9d55ebef3c43b6e3ef2.tar.gz
cpufreq_cpu_exists is replaced by cpupower_is_cpu_online
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
-rw-r--r--cpu-online.patch22
3 files changed, 32 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 00a4deebc135..7f0bb428b454 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Mar 22 06:12:33 UTC 2016
+# Sun Oct 23 11:47:10 UTC 2016
pkgbase = indicator-powersave
pkgdesc = User discretion power managment utility forked from CPU frequency indicator (bzr version)
pkgver = r98
- pkgrel = 4
+ pkgrel = 5
url = https://launchpad.net/indicator-cpufreq
arch = i686
arch = x86_64
@@ -30,6 +30,7 @@ pkgbase = indicator-powersave
source = indicator-cpufreq.rules
source = 0001_Use_cpupower.patch
source = indicator-powersave.patch
+ source = cpu-online.patch
source = throttle
source = throttle-cut.service
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index ea1c54e93e04..5b1eb505f23e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=indicator-powersave
pkgver=r98
-pkgrel=4
+pkgrel=5
pkgdesc="User discretion power managment utility forked from CPU frequency indicator (bzr version)"
arch=('i686' 'x86_64')
url="https://launchpad.net/indicator-cpufreq"
@@ -17,12 +17,14 @@ source=("bzr+lp:indicator-cpufreq"
'indicator-cpufreq.rules'
'0001_Use_cpupower.patch'
'indicator-powersave.patch'
+ 'cpu-online.patch'
'throttle'
'throttle-cut.service')
sha512sums=('SKIP'
'5427f1dcd51fe7fb43bbce1bc020a32312e2f82ccf643129b9887262730989197e2ce2cd4494922df058e78bdb8fbe220eccd69588ff917a891d5a56b3366a24'
'8aad00c00a95d71f221647263422eef89a0207bdb55d883520f3871f28551c316860560207c96144e22dda2ab5f5fc9b8c7bfa0fc642283de160bfd61458b8c0'
'de7f3471d842700811869ff388906218ec19fb85b7fd2faecff2eb9b341c5c5acbdfdc246e67b556c2d45eafbe25ca13d860dc09825c913a11b49532d6982ee5'
+ '8e929aa5d00a17be32b33085eb09aa66002a48696651adcd99678663230d73ed215b88634bb6364867140b8a336566cd02e0b04927423980ca4be9833f316b2a'
'99983956adefafd45292c86616ab847e9221745dff47120b0a28f00002c46ed1e5abd270a7320088513db10a7f647ebf6d5a3423de5aa9af95ee7fe819c21c14'
'aa86b5d6028033d6fbcc3d74d63c33298c0d437972d576990dfc4cae51d5c5128d789695e98fc5612ec7f8a4e2e68ea0576cf072e98fce4e0c22896be2f8b996')
@@ -35,7 +37,11 @@ pkgver() {
prepare() {
cd "${srcdir}/indicator-cpufreq"
+ #Fixes
patch -Np1 -i "${srcdir}/0001_Use_cpupower.patch"
+ patch -Np1 -i "${srcdir}/cpu-online.patch"
+
+ #Indicator-Powersave
patch -Np1 -i "${srcdir}/indicator-powersave.patch"
}
diff --git a/cpu-online.patch b/cpu-online.patch
new file mode 100644
index 000000000000..3009200acd24
--- /dev/null
+++ b/cpu-online.patch
@@ -0,0 +1,22 @@
+--- src/indicator-cpufreq/indicator_cpufreq/cpufreq.py 2016-10-19 07:45:42.210318252 +0900
++++ src/indicator-cpufreq/indicator_cpufreq/cpufreq.py 2016-10-19 08:13:35.815333349 +0900
+@@ -56,8 +56,8 @@
+
+ ###############################################################################
+
+-_libcpufreq.cpufreq_cpu_exists.argtypes = [c_uint]
+-_libcpufreq.cpufreq_cpu_exists.restype = c_int
++_libcpufreq.cpupower_is_cpu_online.argtypes = [c_uint]
++_libcpufreq.cpupower_is_cpu_online.restype = c_int
+
+ _libcpufreq.cpufreq_get_freq_kernel.argtypes = [c_uint]
+ _libcpufreq.cpufreq_get_freq_kernel.restype = c_ulong
+@@ -118,7 +118,7 @@
+ _libcpufreq.cpufreq_set_frequency.restype = c_int
+
+ def cpu_exists(cpu):
+- return _libcpufreq.cpufreq_cpu_exists(cpu)
++ return _libcpufreq.cpupower_is_cpu_online(cpu)
+
+ def get_freq_kernel(cpu):
+ return _libcpufreq.cpufreq_get_freq_kernel(cpu)