summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBarry Smith2019-04-18 15:53:46 -0400
committerBarry Smith2019-04-18 15:53:46 -0400
commit079a93c83324ec72def7225cd75aeaccd4983f67 (patch)
tree342f610b84ee19ee79a98d8ae8596966f297f7b0
parent9d95c5045fa798cd685e0c16f41f5e2f5c642409 (diff)
downloadaur-079a93c83324ec72def7225cd75aeaccd4983f67.tar.gz
Notify user to enable service
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD3
-rw-r--r--package.install8
3 files changed, 12 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 228b418984d4..cab5bff8528f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = throttled
pkgdesc = Workaround for Intel throttling issues in Linux.
pkgver = 0.6
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/erpalma/throttled
+ install = package.install
arch = x86_64
license = MIT
depends = python-dbus
diff --git a/PKGBUILD b/PKGBUILD
index a5878066ac04..c03e08eacc36 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=throttled
pkgver=0.6
-pkgrel=1
+pkgrel=2
pkgdesc="Workaround for Intel throttling issues in Linux."
arch=('x86_64')
url="https://github.com/erpalma/throttled"
@@ -10,6 +10,7 @@ license=('MIT')
depends=('python-dbus' 'python-psutil' 'python-gobject')
provides=('lenovo-throttling-fix' 'throttled')
conflicts=('lenovo-throttling-fix-git' 'lenovo-throttling-fix')
+install="package.install"
backup=('etc/lenovo_fix.conf')
source=("$pkgname-$pkgver.tar.gz::https://github.com/erpalma/$pkgname/archive/v$pkgver.tar.gz")
sha256sums=('93d11b78d35b99ce345e41291f0268e4c21d0ccb2a80922839e51ec2fe3ae0c1')
diff --git a/package.install b/package.install
new file mode 100644
index 000000000000..ed8e192b4da2
--- /dev/null
+++ b/package.install
@@ -0,0 +1,8 @@
+## arg 1: the new package version
+post_install() {
+ # Remind user to enable the systemd service
+ echo -------------------------------------------------------------
+ echo 'After customizing the configuration in /etc/lenovo_fix.conf,'
+ echo 'enable the service by running: systemctl enable lenovo_fix'
+ echo -------------------------------------------------------------
+}