summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanila.Gornushko2022-02-08 11:10:20 +0300
committerDanila.Gornushko2022-02-08 11:10:20 +0300
commit1eac1f62edafa537c049dd9164a76667a23a71c6 (patch)
tree591cb4232529800cc1423264f00695f5dcb6f8c9
parente761b089725a74737d57079d0df9052f6bf22ad5 (diff)
downloadaur-1eac1f62edafa537c049dd9164a76667a23a71c6.tar.gz
fix
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8e2d8a41cd82..0973fbf9e014 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = throttled-git
pkgdesc = Workaround for Intel throttling issues in Linux.
- pkgver = 0.9.2
+ pkgver = r304.581038c
pkgrel = 1
url = https://github.com/erpalma/throttled
arch = any
@@ -10,7 +10,9 @@ pkgbase = throttled-git
depends = python-gobject
conflicts = lenovo-throttling-fix-git
conflicts = lenovo-throttling-fix
+ conflicts = throttled
replaces = lenovo-throttling-fix
+ replaces = throttled
backup = etc/lenovo_fix.conf
source = git+https://github.com/erpalma/throttled.git
source = throttled.service
diff --git a/PKGBUILD b/PKGBUILD
index ff0082d2405f..c20f0e8bb9c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,25 @@
+# Maintainer: okhsunrog <me@gornushko.com>
pkgname=throttled-git
-pkgver=0.9.2
+pkgver=r304.581038c
pkgrel=1
pkgdesc="Workaround for Intel throttling issues in Linux."
arch=('any')
url="https://github.com/erpalma/throttled"
license=('MIT')
depends=('python-dbus' 'python-psutil' 'python-gobject')
-conflicts=('lenovo-throttling-fix-git' 'lenovo-throttling-fix')
-replaces=('lenovo-throttling-fix')
+conflicts=('lenovo-throttling-fix-git' 'lenovo-throttling-fix' 'throttled')
+replaces=('lenovo-throttling-fix' 'throttled')
backup=('etc/lenovo_fix.conf')
source=("git+https://github.com/erpalma/throttled.git"
'throttled.service')
sha256sums=('SKIP'
'SKIP')
+pkgver() {
+ cd "${srcdir}/throttled/"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
build() {
cd "${srcdir}/throttled/"