summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor2023-04-18 07:44:39 +0200
committerVictor2023-04-18 07:44:39 +0200
commitdf1704ce501d5ef3377e3fa9db687f87b2c9e0be (patch)
treed43a0a60252f3785c2dc7e7b67417716ec8f641f
parent6718aaf7b18230a0eb771450992ceb349ef2f55f (diff)
downloadaur-thrust.tar.gz
Update to 2.1.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD6
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5335d73a6fe6..49a76d2c1b6d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = thrust
pkgdesc = A C++ parallel programming library which resembles the C++ Standard Library
- pkgver = 2.0.1
+ pkgver = 2.1.0
pkgrel = 1
url = https://github.com/thrust/thrust
arch = any
@@ -8,9 +8,9 @@ pkgbase = thrust
optdepends = cuda: for CUDA backend
optdepends = openmp: for OMP backend
optdepends = intel-tbb: for TBB backend
- source = thrust-2.0.1.tar.gz::https://github.com/thrust/thrust/archive/2.0.1.tar.gz
- source = cub-2.0.1.tar.gz::https://github.com/thrust/cub/archive/2.0.1.tar.gz
- sha256sums = 06df373cf487cf3710be6798bc5441a03685b78e5c1338e2f14005f7ccd030e6
- sha256sums = beeef0962c87eca994db06cb9e9168a71c63fb369398a5b5f1db923140814701
+ source = thrust-2.1.0.tar.gz::https://github.com/thrust/thrust/archive/2.1.0.tar.gz
+ source = cub-2.1.0.tar.gz::https://github.com/thrust/cub/archive/2.1.0.tar.gz
+ sha256sums = ebfa1a31867a95b8b0555ae45fc7c45538edfa5929ec718951eae0bbc7ed3108
+ sha256sums = 60f7633c81c8c0e970bcf59fa6d19a0ed136524dbbcd52b94ea42721dde8cd6b
pkgname = thrust
diff --git a/PKGBUILD b/PKGBUILD
index c307e266386c..50ad982335d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Xiang Gao <qasdfgtyuiop@gmail.com>
pkgname=thrust
-pkgver=2.0.1
+pkgver=2.1.0
pkgrel=1
pkgdesc='A C++ parallel programming library which resembles the C++ Standard Library'
arch=('any')
@@ -17,8 +17,8 @@ optdepends=(
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/thrust/${pkgname}/archive/${pkgver}.tar.gz"
"cub-${pkgver}.tar.gz::https://github.com/thrust/cub/archive/${pkgver}.tar.gz")
-sha256sums=('06df373cf487cf3710be6798bc5441a03685b78e5c1338e2f14005f7ccd030e6'
- 'beeef0962c87eca994db06cb9e9168a71c63fb369398a5b5f1db923140814701')
+sha256sums=('ebfa1a31867a95b8b0555ae45fc7c45538edfa5929ec718951eae0bbc7ed3108'
+ '60f7633c81c8c0e970bcf59fa6d19a0ed136524dbbcd52b94ea42721dde8cd6b')
package() {
install -dm 755 "${pkgdir}/opt/${pkgname}"