summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor2019-05-08 22:07:46 -0300
committerVictor2019-05-08 22:07:46 -0300
commit237ef07e7412bc778f86d734e5bdf425ba5fc6c3 (patch)
tree3660f89d56f9caa3e260b34939346ff146148076
parentecb7a392838cb307cfa3762a415df3a534d201fa (diff)
downloadaur-237ef07e7412bc778f86d734e5bdf425ba5fc6c3.tar.gz
Update to 1.9.4 (installs to /opt/thrust)
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
2 files changed, 29 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bf56c908912e..e2349e5ca8fb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = thrust
- pkgdesc = A parallel algorithms library which resembles the C++ Standard Template Library (STL).
- pkgver = 1.8.2
+ pkgdesc = A C++ parallel programming library which resembles the C++ Standard Library.
+ pkgver = 1.9.4
pkgrel = 1
- url = http://thrust.github.io/
+ url = https://github.com/thrust/thrust
arch = any
- license = APACHE
- depends = cuda
- source = https://github.com/thrust/thrust/releases/download/1.8.2/thrust-1.8.2.zip
- sha256sums = 00925daee4d9505b7f33d0ed42ab0de0f9c68c4ffbe2a41e6d04452cdee77b2d
+ license = Apache
+ optdepends = cuda: for CUDA backend
+ optdepends = openmp: for OMP backend
+ optdepends = intel-tbb: for TBB backend
+ source = thrust-1.9.4.tar.gz::https://github.com/thrust/thrust/archive/1.9.4.tar.gz
+ sha256sums = 41931a7d73331fc39c6bea56d1eb8d4d8bbf7c73688979bbdab0e55772f538d1
pkgname = thrust
diff --git a/PKGBUILD b/PKGBUILD
index a62de24aa254..071ff99a36b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,28 @@
-# Maintainer: Xiang Gao <qasdfgtyuiop@gmail.com>
+# Maintainer: Victor <v1c70rp at gmail dot com>
+# Contributor: Xiang Gao <qasdfgtyuiop@gmail.com>
+
pkgname=thrust
-pkgver=1.8.2
+pkgver=1.9.4
pkgrel=1
+pkgdesc='A C++ parallel programming library which resembles the C++ Standard Library.'
arch=('any')
-license=('APACHE')
-url="http://thrust.github.io/"
-pkgdesc="A parallel algorithms library which resembles the C++ Standard Template Library (STL)."
-
-source=("https://github.com/thrust/thrust/releases/download/$pkgver/$pkgname-$pkgver.zip")
+url="https://github.com/thrust/$pkgname"
+license=('Apache')
-sha256sums=('00925daee4d9505b7f33d0ed42ab0de0f9c68c4ffbe2a41e6d04452cdee77b2d')
+optdepends=(
+ 'cuda: for CUDA backend'
+ 'openmp: for OMP backend'
+ 'intel-tbb: for TBB backend'
+)
-depends=('cuda')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/thrust/${pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=('41931a7d73331fc39c6bea56d1eb8d4d8bbf7c73688979bbdab0e55772f538d1')
package() {
- install -d "${pkgdir}/usr/include"
- cp -r "${srcdir}/$pkgname" "${pkgdir}/usr/include/$pkgname"
+ install -dm 755 "${pkgdir}/opt/${pkgname}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ cp -r ${pkgname} "${pkgdir}/opt/${pkgname}/"
+ cp -r examples "${pkgdir}/opt/${pkgname}/"
}
+
+# vim: ft=sh ts=2 sw=2 et