summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor2020-07-21 15:27:29 -0300
committerVictor2020-07-21 15:27:29 -0300
commit8b6b33a26f09c63214419d2c4ce9de798d8997fe (patch)
tree57e27acaa178d65425501ab42cdf61a3b4ae5a0b
parent447fe479ab503f6088382eae57ea4fe04e67fe0c (diff)
downloadaur-8b6b33a26f09c63214419d2c4ce9de798d8997fe.tar.gz
Add cub as integrated dependency
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8ba22f25c30e..3a3c6aa9de48 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,7 +9,9 @@ pkgbase = thrust
optdepends = openmp: for OMP backend
optdepends = intel-tbb: for TBB backend
source = thrust-1.9.10.tar.gz::https://github.com/thrust/thrust/archive/1.9.10.tar.gz
- sha256sums = d155dc2a260fe0c75c63c185fa4c4b4c6c5b7c444fcdac7109bb71941c9603f1
+ source = cub-1.9.10.tar.gz::https://github.com/thrust/cub/archive/1.9.10.tar.gz
+ sha256sums = 5071c995a03e97e2bcfe0c5cc265330160316733336bb87dfcea3fc381065316
+ sha256sums = 2bd7077a3d9741f0689e6c1eb58c6278fc96eccc27d964168bc8be1bc3a9040f
pkgname = thrust
diff --git a/PKGBUILD b/PKGBUILD
index 59bcc10ede55..605c0bf849e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,14 +15,18 @@ optdepends=(
'intel-tbb: for TBB backend'
)
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/thrust/${pkgname}/archive/${pkgver}.tar.gz")
-sha256sums=('5071c995a03e97e2bcfe0c5cc265330160316733336bb87dfcea3fc381065316')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/thrust/${pkgname}/archive/${pkgver}.tar.gz"
+ "cub-${pkgver}.tar.gz::https://github.com/thrust/cub/archive/${pkgver}.tar.gz")
+sha256sums=('5071c995a03e97e2bcfe0c5cc265330160316733336bb87dfcea3fc381065316'
+ '2bd7077a3d9741f0689e6c1eb58c6278fc96eccc27d964168bc8be1bc3a9040f')
package() {
install -dm 755 "${pkgdir}/opt/${pkgname}"
cd "${srcdir}/${pkgname}-${pkgver}"
cp -r ${pkgname} "${pkgdir}/opt/${pkgname}/"
cp -r examples "${pkgdir}/opt/${pkgname}/"
+ cd "${srcdir}/cub-${pkgver}"
+ cp -r cub "${pkgdir}/opt/${pkgname}/"
}
# vim: ft=sh ts=2 sw=2 et