summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2017-09-25 20:57:07 +0200
committerhaawda2017-09-25 20:57:07 +0200
commitd97a83642e20ab153d8a598f2a9a5da80bdea6a1 (patch)
tree455a60fa2197f9efad403faec9546013204d3723
parentd31a535ef20ad0a9d5579d4727aaa2ed30d5cdae (diff)
downloadaur-d97a83642e20ab153d8a598f2a9a5da80bdea6a1.tar.gz
replace . with - in pkgnames
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD20
2 files changed, 16 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 89e15b93f5ff..5264c9a441e8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,18 +10,18 @@ pkgbase = thue
pkgname = thue
arch = x86_64
- depends = thue.doc
+ depends = thue-doc
-pkgname = thue.py
+pkgname = thue-py
arch = any
- depends = thue.doc
+ depends = thue-doc
depends = python
-pkgname = thue.rb
+pkgname = thue-rb
arch = any
- depends = thue.doc
+ depends = thue-doc
depends = ruby
-pkgname = thue.doc
+pkgname = thue-doc
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index fccf9eac76be..2e9434d8bf94 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Alexander Rødseth <rodseth@gmail.com>
pkgbase=thue
-pkgname=('thue' 'thue.py' 'thue.rb' 'thue.doc')
+pkgname=('thue' 'thue-py' 'thue-rb' 'thue-doc')
arch=('x86_64')
pkgver=1.5_2015.0827
pkgrel=1
@@ -20,9 +20,9 @@ build() {
gcc thue.c -o thue
}
-package_thue.doc() {
+package_thue-doc() {
arch=('any')
- cd "${pkgname%.doc}-${pkgver/_/-}"
+ cd "${pkgname%-doc}-${pkgver/_/-}"
install -Dm644 doc/license.txt "$pkgdir/usr/share/licenses/thue/LICENSE"
install -Dm644 doc/thue.txt "$pkgdir/usr/share/doc/thue/REFERENCE"
install -Dm644 README.markdown "$pkgdir/usr/share/doc/thue/README.md"
@@ -30,23 +30,23 @@ package_thue.doc() {
}
package_thue() {
- depends=('thue.doc')
+ depends=('thue-doc')
arch=('x86_64')
cd "$pkgname-${pkgver/_/-}"/src
install -Dm755 thue "$pkgdir/usr/bin/thue"
}
-package_thue.py() {
- depends=('thue.doc' 'python')
+package_thue-py() {
+ depends=('thue-doc' 'python')
arch=('any')
- cd "${pkgname%.py}-${pkgver/_/-}"
+ cd "${pkgname%-py}-${pkgver/_/-}"
install -Dm755 src/thue.py "$pkgdir/usr/bin/thue.py"
}
-package_thue.rb() {
- depends=('thue.doc' 'ruby')
+package_thue-rb() {
+ depends=('thue-doc' 'ruby')
arch=('any')
- cd "${pkgname%.rb}-${pkgver/_/-}"
+ cd "${pkgname%-rb}-${pkgver/_/-}"
install -Dm755 src/thue.rb "$pkgdir/usr/bin/thue.rb"
}