summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTed Alff2017-11-26 20:40:01 -0500
committerTed Alff2017-11-26 20:40:01 -0500
commitd091e7825a43d8093cc08c9fb63a5366c9ac4e56 (patch)
treee851dc5b1d9c82e1272be196124422b34f414345
downloadaur-d091e7825a43d8093cc08c9fb63a5366c9ac4e56.tar.gz
Initial commit. GTK3 version 1.7.0
-rw-r--r--.SRCINFO40
-rw-r--r--PKGBUILD51
-rw-r--r--thunar.install21
3 files changed, 112 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ac4f5b5d106a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,40 @@
+# Generated by mksrcinfo v8
+# Mon Nov 27 01:39:31 UTC 2017
+pkgbase = thunar-devel
+ pkgdesc = file manager for xfce
+ pkgver = 1.7.0
+ pkgrel = 1
+ url = http://thunar.xfce.org
+ install = thunar.install
+ arch = i686
+ arch = x86_64
+ groups = xfce4-devel
+ license = GPL
+ makedepends = intltool
+ makedepends = xfce4-panel
+ makedepends = gtk-doc
+ makedepends = gobject-introspection
+ depends = desktop-file-utils
+ depends = exo
+ depends = gtk3
+ depends = hicolor-icon-theme
+ depends = libgudev
+ depends = libexif
+ depends = libnotify
+ depends = libpng
+ depends = libxfce4ui
+ depends = libxfce4util
+ optdepends = gvfs: trash support, mounting with udisks, and remote filesystems
+ optdepends = xfce4-panel: trash applet
+ optdepends = tumbler: for thumbnail previews
+ optdepends = thunar-volman: manages removable devices
+ optdepends = thunar-archive-plugin-git: create and deflate archives
+ optdepends = thunar-media-tags-plugin-git: view/edit id3/ogg tags
+ provides = thunar=1.7.0
+ provides = libthunarx-3.so
+ conflicts = thunar
+ source = http://archive.xfce.org/src/xfce/thunar/1.7/Thunar-1.7.0.tar.bz2
+ sha256sums = 36ecbe6d5a406a02f186118c8192b3587121172d9eebb1cb2df6a3bc06272400
+
+pkgname = thunar-devel
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8bd1eaab38a0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: twa022 <twa022 at gmail dot com>
+
+_pkgname=thunar
+pkgname=${_pkgname}-devel
+pkgver=1.7.0
+pkgrel=1
+pkgdesc='file manager for xfce'
+arch=('i686' 'x86_64')
+license=('GPL')
+url='http://thunar.xfce.org'
+groups=('xfce4-devel')
+depends=('desktop-file-utils' 'exo' 'gtk3' 'hicolor-icon-theme' 'libgudev'
+ 'libexif' 'libnotify' 'libpng' 'libxfce4ui' 'libxfce4util')
+makedepends=('intltool' 'xfce4-panel' 'gtk-doc' 'gobject-introspection') # 'xfce4-dev-tools')
+optdepends=('gvfs: trash support, mounting with udisks, and remote filesystems'
+ 'xfce4-panel: trash applet'
+ 'tumbler: for thumbnail previews'
+ 'thunar-volman: manages removable devices'
+ 'thunar-archive-plugin-git: create and deflate archives'
+ 'thunar-media-tags-plugin-git: view/edit id3/ogg tags')
+provides=("${_pkgname}=${pkgver}" 'libthunarx-3.so')
+conflicts=("${_pkgname}")
+install="${_pkgname}.install"
+source=("http://archive.xfce.org/src/xfce/${_pkgname}/${pkgver%.*}/${_pkgname^}-${pkgver}.tar.bz2")
+sha256sums=('36ecbe6d5a406a02f186118c8192b3587121172d9eebb1cb2df6a3bc06272400')
+
+prepare() {
+ cd "${_pkgname^}-${pkgver}"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --disable-static \
+ --enable-gio-unix \
+ --enable-gudev \
+ --enable-exif \
+ --enable-pcre \
+ --enable-gtk-doc \
+ --disable-debug
+}
+
+build() {
+ cd "${_pkgname^}-${pkgver}"
+ make
+}
+
+package() {
+ cd "${_pkgname^}-${pkgver}"
+ make DESTDIR="$pkgdir" install
+}
diff --git a/thunar.install b/thunar.install
new file mode 100644
index 000000000000..c9099f6a9d36
--- /dev/null
+++ b/thunar.install
@@ -0,0 +1,21 @@
+post_install() {
+ printf "$(tput setaf 1)$(tput bold) ==> WARNING: $(tput sgr0)"
+ echo "List of packages which are linked against the GTK2 version of thunar"
+ while read pkg; do
+ mapfile -t files < <(pacman -Qlq $pkg | grep -v /$)
+ grep -Fq 'libthunarx-2.so' "${files[@]}" <&- 2>/dev/null && echo " >> $pkg"
+ done < <(pacman -Qq | grep -E '(^(xf|libxfce|garcon|tumbler|mousepad|orage|thunar)|xfce|xfwm)' )
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ printf "$(tput setaf 1)$(tput bold) ==> WARNING: $(tput sgr0)"
+ echo "Packages linked against uninstalled version of thunar:"
+ while read pkg; do
+ mapfile -t files < <(pacman -Qlq $pkg | grep -v /$)
+ grep -Fq 'libthunarx-3.so' "${files[@]}" <&- 2>/dev/null && echo " >> $pkg"
+ done < <(pacman -Qq | grep -E '(^(xf|libxfce|garcon|tumbler|mousepad|orage|thunar)|xfce|xfwm)' )
+}