summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorConnor Behan2018-04-27 18:45:49 -0400
committerConnor Behan2018-04-27 18:45:49 -0400
commiteba2e85b5bcde77b40e76c995ca0d370041c3be9 (patch)
tree11d662763a7333fd8c52e0d29261b579fbb7e1c3
parent7b40914c136daaa5b973e128833dd22f556296a7 (diff)
downloadaur-eba2e85b5bcde77b40e76c995ca0d370041c3be9.tar.gz
Update to 1.6.15-1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
-rw-r--r--uca_num_files.patch40
3 files changed, 28 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aadf880ab8a5..a0faa140c417 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = thunar-extended
pkgdesc = Thunar with split view, cursor audio preview and extra options for trash, desktop files and user actions
- pkgver = 1.6.12
+ pkgver = 1.6.15
pkgrel = 1
url = http://thunar.xfce.org
arch = i686
@@ -34,16 +34,14 @@ pkgbase = thunar-extended
conflicts = thunar
replaces = thunar
options = !libtool
- source = http://archive.xfce.org/src/xfce/thunar/1.6/Thunar-1.6.12.tar.bz2
- source = 0001-Deactivate-SEND_MOVED-code-paths.patch::http://bug-attachment.xfce.org/attachment.cgi?id=6530
+ source = https://archive.xfce.org/src/xfce/thunar/1.6/Thunar-1.6.15.tar.bz2
source = notrash.patch
source = uca_num_files.patch
source = preview.patch
source = split_pane.patch
- md5sums = 1bdf3c4a57ff886c512341f24b5e0e88
- md5sums = 9f52b207f090b280ac25ceafe3032137
+ md5sums = 8fea2af69c3acbb273fd1a177d3d8e47
md5sums = d87f154a5fbd3709511ded0c9b9b0317
- md5sums = 69aa416e8694b8b608f767769b6dcd98
+ md5sums = ed289801d509fe72b82c01fbb6f5f715
md5sums = 60d3bb7fc185f5f881b5884bd7f28c87
md5sums = ce443cf896934131427b7789da130097
diff --git a/PKGBUILD b/PKGBUILD
index fe3801d7a944..eb3f118156b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Contributor: Connor Behan <connor.behan@gmail.com>
pkgname=thunar-extended
-pkgver=1.6.12
+pkgver=1.6.15
pkgrel=1
pkgdesc="Thunar with split view, cursor audio preview and extra options for trash, desktop files and user actions"
arch=(i686 x86_64)
@@ -22,8 +22,7 @@ optdepends=('gvfs: for trash support, mounting with udisk and remote filesystems
'thunar-archive-plugin: create and deflate archives'
'thunar-media-tags-plugin: view/edit id3/ogg tags')
options=('!libtool')
-source=(http://archive.xfce.org/src/xfce/thunar/1.6/Thunar-${pkgver}.tar.bz2
- 0001-Deactivate-SEND_MOVED-code-paths.patch::http://bug-attachment.xfce.org/attachment.cgi?id=6530
+source=(https://archive.xfce.org/src/xfce/thunar/1.6/Thunar-${pkgver}.tar.bz2
notrash.patch
uca_num_files.patch
preview.patch
@@ -37,8 +36,6 @@ build() {
patch -Np1 -i ../uca_num_files.patch
patch -Np1 -i ../preview.patch
patch -Np1 -i ../split_pane.patch
- # Upstream ones
- patch -Np1 -i ../0001-Deactivate-SEND_MOVED-code-paths.patch
mkdir m4
sed -i -e 's/Thunar_CFLAGS/thunar_CFLAGS/' -e 's/Thunar_LDADD/thunar_LDADD/' thunar/Makefile.am
@@ -58,9 +55,8 @@ package() {
make DESTDIR="${pkgdir}" install
}
-md5sums=('1bdf3c4a57ff886c512341f24b5e0e88'
- '9f52b207f090b280ac25ceafe3032137'
+md5sums=('8fea2af69c3acbb273fd1a177d3d8e47'
'd87f154a5fbd3709511ded0c9b9b0317'
- '69aa416e8694b8b608f767769b6dcd98'
+ 'ed289801d509fe72b82c01fbb6f5f715'
'60d3bb7fc185f5f881b5884bd7f28c87'
'ce443cf896934131427b7789da130097')
diff --git a/uca_num_files.patch b/uca_num_files.patch
index 499d638dadd2..21497fbed6b4 100644
--- a/uca_num_files.patch
+++ b/uca_num_files.patch
@@ -1,6 +1,6 @@
-diff -ru Thunar-1.6.3.orig/plugins/thunar-uca/thunar-uca-editor.c Thunar-1.6.3/plugins/thunar-uca/thunar-uca-editor.c
---- Thunar-1.6.3.orig/plugins/thunar-uca/thunar-uca-editor.c 2013-05-21 19:50:07.000000000 -0700
-+++ Thunar-1.6.3/plugins/thunar-uca/thunar-uca-editor.c 2013-05-21 19:50:20.000000000 -0700
+diff -ru Thunar-1.6.15.orig/plugins/thunar-uca/thunar-uca-editor.c Thunar-1.6.15/plugins/thunar-uca/thunar-uca-editor.c
+--- Thunar-1.6.15.orig/plugins/thunar-uca/thunar-uca-editor.c 2018-04-27 18:34:10.000000000 -0400
++++ Thunar-1.6.15/plugins/thunar-uca/thunar-uca-editor.c 2018-04-27 18:34:19.000000000 -0400
@@ -63,6 +63,8 @@
GtkWidget *sn_button;
GtkWidget *parameter_entry;
@@ -137,9 +137,9 @@ diff -ru Thunar-1.6.3.orig/plugins/thunar-uca/thunar-uca-editor.c Thunar-1.6.3/p
thunar_uca_editor_get_types (uca_editor));
}
-diff -ru Thunar-1.6.3.orig/plugins/thunar-uca/thunar-uca-model.c Thunar-1.6.3/plugins/thunar-uca/thunar-uca-model.c
---- Thunar-1.6.3.orig/plugins/thunar-uca/thunar-uca-model.c 2013-05-21 19:50:07.000000000 -0700
-+++ Thunar-1.6.3/plugins/thunar-uca/thunar-uca-model.c 2013-05-21 19:53:41.000000000 -0700
+diff -ru Thunar-1.6.15.orig/plugins/thunar-uca/thunar-uca-model.c Thunar-1.6.15/plugins/thunar-uca/thunar-uca-model.c
+--- Thunar-1.6.15.orig/plugins/thunar-uca/thunar-uca-model.c 2018-04-27 18:34:10.000000000 -0400
++++ Thunar-1.6.15/plugins/thunar-uca/thunar-uca-model.c 2018-04-27 18:35:36.000000000 -0400
@@ -79,6 +79,8 @@
PARSER_COMMAND,
PARSER_STARTUP_NOTIFY,
@@ -301,11 +301,11 @@ diff -ru Thunar-1.6.3.orig/plugins/thunar-uca/thunar-uca-model.c Thunar-1.6.3/pl
GList *lp;
gint n_files;
gint i, m, n;
-+ gint upper, lower;
++ gint upper, lower;
+ gchar *path_test;
g_return_val_if_fail (THUNAR_UCA_IS_MODEL (uca_model), NULL);
- g_return_val_if_fail (file_infos != NULL, NULL);
-@@ -1140,7 +1199,16 @@
+@@ -1143,7 +1202,16 @@
{
/* check if we can just ignore this item */
item = (ThunarUcaModelItem *) lp->data;
@@ -323,7 +323,7 @@ diff -ru Thunar-1.6.3.orig/plugins/thunar-uca/thunar-uca-model.c Thunar-1.6.3/pl
continue;
/* match the specified files */
-@@ -1316,6 +1384,8 @@
+@@ -1319,6 +1387,8 @@
const gchar *command,
gboolean startup_notify,
const gchar *patterns,
@@ -332,7 +332,7 @@ diff -ru Thunar-1.6.3.orig/plugins/thunar-uca/thunar-uca-model.c Thunar-1.6.3/pl
ThunarUcaTypes types)
{
ThunarUcaModelItem *item;
-@@ -1336,6 +1406,10 @@
+@@ -1339,6 +1409,10 @@
item->icon_name = g_strdup (icon);
if (G_LIKELY (command != NULL && *command != '\0'))
item->command = g_strdup (command);
@@ -343,7 +343,7 @@ diff -ru Thunar-1.6.3.orig/plugins/thunar-uca/thunar-uca-model.c Thunar-1.6.3/pl
if (G_LIKELY (description != NULL && *description != '\0'))
item->description = g_strdup (description);
item->types = types;
-@@ -1436,12 +1510,16 @@
+@@ -1439,12 +1513,16 @@
"\t<unique-id>%s</unique-id>\n"
"\t<command>%s</command>\n"
"\t<description>%s</description>\n"
@@ -360,9 +360,9 @@ diff -ru Thunar-1.6.3.orig/plugins/thunar-uca/thunar-uca-model.c Thunar-1.6.3/pl
patterns);
fprintf (fp, "%s", escaped);
g_free (patterns);
-diff -ru Thunar-1.6.3.orig/plugins/thunar-uca/thunar-uca-model.h Thunar-1.6.3/plugins/thunar-uca/thunar-uca-model.h
---- Thunar-1.6.3.orig/plugins/thunar-uca/thunar-uca-model.h 2013-05-21 19:50:07.000000000 -0700
-+++ Thunar-1.6.3/plugins/thunar-uca/thunar-uca-model.h 2013-05-21 19:50:20.000000000 -0700
+diff -ru Thunar-1.6.15.orig/plugins/thunar-uca/thunar-uca-model.h Thunar-1.6.15/plugins/thunar-uca/thunar-uca-model.h
+--- Thunar-1.6.15.orig/plugins/thunar-uca/thunar-uca-model.h 2018-04-27 18:34:10.000000000 -0400
++++ Thunar-1.6.15/plugins/thunar-uca/thunar-uca-model.h 2018-04-27 18:34:19.000000000 -0400
@@ -44,6 +44,8 @@
THUNAR_UCA_MODEL_COLUMN_UNIQUE_ID,
THUNAR_UCA_MODEL_COLUMN_COMMAND,
@@ -381,10 +381,10 @@ diff -ru Thunar-1.6.3.orig/plugins/thunar-uca/thunar-uca-model.h Thunar-1.6.3/pl
ThunarUcaTypes types);
gboolean thunar_uca_model_save (ThunarUcaModel *uca_model,
-diff -ru Thunar-1.6.3.orig/plugins/thunar-uca/uca.xml.in Thunar-1.6.3/plugins/thunar-uca/uca.xml.in
---- Thunar-1.6.3.orig/plugins/thunar-uca/uca.xml.in 2013-05-21 19:50:07.000000000 -0700
-+++ Thunar-1.6.3/plugins/thunar-uca/uca.xml.in 2013-05-21 19:50:20.000000000 -0700
-@@ -40,6 +40,8 @@
+diff -ru Thunar-1.6.15.orig/plugins/thunar-uca/uca.xml.in Thunar-1.6.15/plugins/thunar-uca/uca.xml.in
+--- Thunar-1.6.15.orig/plugins/thunar-uca/uca.xml.in 2018-04-27 18:34:10.000000000 -0400
++++ Thunar-1.6.15/plugins/thunar-uca/uca.xml.in 2018-04-27 18:34:19.000000000 -0400
+@@ -38,6 +38,8 @@
<action>
<icon>utilities-terminal</icon>
<patterns>*</patterns>
@@ -393,7 +393,7 @@ diff -ru Thunar-1.6.3.orig/plugins/thunar-uca/uca.xml.in Thunar-1.6.3/plugins/th
<_name>Open Terminal Here</_name>
<command>exo-open --working-directory %f --launch TerminalEmulator</command>
<_description>Example for a custom action</_description>
-@@ -47,4 +49,15 @@
+@@ -45,4 +47,15 @@
<directories/>
</action>