summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlad Wenter2016-04-06 18:43:41 +0200
committerAlad Wenter2016-04-06 18:43:41 +0200
commit12fc60217738b8139dae0b3e8006a9d6aebda197 (patch)
tree8d6713f2faa4c9e8e2fa6bb10a9c14525dd841c2
downloadaur-12fc60217738b8139dae0b3e8006a9d6aebda197.tar.gz
import from AUR3, cleanup
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD54
-rw-r--r--thunar-git.install12
3 files changed, 100 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e51323a0e298
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+# Generated by mksrcinfo v8
+# Wed Apr 6 16:42:30 UTC 2016
+pkgbase = thunar-git
+ pkgdesc = file manager for xfce
+ pkgver = thunar.1.6.10.r118.g82c6060
+ pkgrel = 1
+ url = http://thunar.xfce.org
+ install = thunar-git.install
+ arch = i686
+ arch = x86_64
+ groups = xfce4-git
+ license = GPL
+ makedepends = git
+ makedepends = xfce4-dev-tools
+ depends = desktop-file-utils
+ depends = exo
+ depends = gtk2
+ depends = hicolor-icon-theme
+ depends = libexif
+ depends = libnotify
+ depends = libpng
+ depends = libxfce4ui
+ depends = libxfce4util
+ optdepends = gvfs: trash support, mounting with udisks, and remote filesystems
+ optdepends = xfce4-panel: trash applet
+ provides = thunar=thunar.1.6.10
+ conflicts = thunar
+ conflicts = thunar-extended
+ options = !libtool
+ source = git://git.xfce.org/xfce/thunar
+ sha256sums = SKIP
+
+pkgname = thunar-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ad8430cc013f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Alad Wenter <alad@archlinux.info>
+# Contributor: Limao Luo <luolimao+AUR@gmail.com>
+# Contributor: Evangelos Foutras <evangelos@foutrelis.com>
+# Contributor: Andrew Simmons <andrew.simmons@gmail.com>
+
+pkgname=thunar-git
+pkgver=thunar.1.6.10.r118.g82c6060
+pkgrel=1
+pkgdesc='file manager for xfce'
+arch=('i686' 'x86_64')
+license=('GPL')
+url=http://thunar.xfce.org
+groups=('xfce4-git')
+depends=('desktop-file-utils' 'exo' 'gtk2' 'hicolor-icon-theme' 'libexif' 'libnotify' 'libpng'
+ 'libxfce4ui' 'libxfce4util')
+makedepends=('git' 'xfce4-dev-tools')
+optdepends=('gvfs: trash support, mounting with udisks, and remote filesystems'
+ 'xfce4-panel: trash applet')
+provides=(thunar="${pkgver%%.r*}")
+conflicts=(thunar{,-extended})
+options=(!libtool)
+install=$pkgname.install
+source=('git://git.xfce.org/xfce/thunar')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd thunar
+ git describe --long | sed -e 's/\([^-]*-g\)/r\1/' -e 's/-/./g'
+}
+
+build() {
+ cd thunar
+ ./autogen.sh \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --disable-static \
+ --enable-gio-unix \
+ --enable-dbus \
+ --enable-startup-notification \
+ --enable-gudev \
+ --enable-exif \
+ --enable-pcre \
+ --enable-gtk-doc \
+ --disable-debug
+ make
+}
+
+package() {
+ cd thunar
+ make DESTDIR="$pkgdir" install
+ sed -i ':x-directory/gnome-default-handler;:d' "$pkgdir"/usr/share/applications/Thunar-folder-handler.desktop
+}
diff --git a/thunar-git.install b/thunar-git.install
new file mode 100644
index 000000000000..546f26704f8d
--- /dev/null
+++ b/thunar-git.install
@@ -0,0 +1,12 @@
+post_install() {
+ update-desktop-database -q
+ gtk-update-icon-cache -qtf usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}