summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornull2016-05-25 18:05:06 -0400
committernull2016-05-25 18:05:06 -0400
commit0562d5b0bbed7111260d025a2fb9c325c2fce2b5 (patch)
treeafd8004b18f465879e5ec8f779f5cd1a38410d8e
downloadaur-0562d5b0bbed7111260d025a2fb9c325c2fce2b5.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD13
-rw-r--r--uca.xml27
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..634684cd1a36
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+# Generated by mksrcinfo v8
+# Wed May 25 22:04:56 UTC 2016
+pkgbase = thunar-hardlinkcopy
+ pkgdesc = Add a custom action to Thunar to perform hard link copies. Replace 'owner' in PKGBUILD with your username.
+ pkgver = 1.0
+ pkgrel = 1
+ arch = i686
+ arch = x86_64
+ depends = zenity
+ source = uca.xml
+ md5sums = SKIP
+
+pkgname = thunar-hardlinkcopy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..af200268ec54
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,13 @@
+pkgname=thunar-hardlinkcopy
+pkgdesc="Add a custom action to Thunar to perform hard link copies. Replace 'owner' in PKGBUILD with your username."
+pkgver=1.0
+pkgrel=1
+arch=('i686' 'x86_64')
+source=("uca.xml")
+md5sums=('SKIP')
+depends=('zenity')
+
+package() {
+ mkdir -p $pkgdir/home/owner/.config/Thunar/
+ cp uca.xml $pkgdir/home/owner/.config/Thunar/
+}
diff --git a/uca.xml b/uca.xml
new file mode 100644
index 000000000000..5ff9532e4827
--- /dev/null
+++ b/uca.xml
@@ -0,0 +1,27 @@
+<?xml encoding="UTF-8" version="1.0"?>
+<actions>
+<action>
+ <icon>utilities-terminal</icon>
+ <name>Open Terminal Here</name>
+ <unique-id>1463627916076864-1</unique-id>
+ <command>exo-open --working-directory %f --launch TerminalEmulator</command>
+ <description>Example for a custom action</description>
+ <patterns>*</patterns>
+ <startup-notify/>
+ <directories/>
+</action>
+<action>
+ <icon>edit-copy</icon>
+ <name>Hardlink Copy</name>
+ <unique-id>1464212970249938-6</unique-id>
+ <command>sh -c &quot;cp -al %f \\&quot;`zenity --title &apos;Select destination directory&apos; --file-selection --directory`\\&quot;/&quot;</command>
+ <description></description>
+ <patterns>*</patterns>
+ <directories/>
+ <audio-files/>
+ <image-files/>
+ <other-files/>
+ <text-files/>
+ <video-files/>
+</action>
+</actions>