summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTed Alff2017-11-14 22:21:27 -0500
committerTed Alff2017-11-14 22:21:27 -0500
commit5ea9abe694adc8a6310ab93684f50180af7fa513 (patch)
treed71c741c8beacfabe022b0b4852d965a6bd3c405
downloadaur-5ea9abe694adc8a6310ab93684f50180af7fa513.tar.gz
Initial commit. thunarx-3 (GTK3) version
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD40
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bc7f3b1d3ae0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Wed Nov 15 03:21:13 UTC 2017
+pkgbase = thunar-media-tags-plugin-git
+ pkgdesc = Adds special features for media files to the Thunar File Manager (git checkout)
+ pkgver = 0.2.1.r173.gea240bf
+ pkgrel = 1
+ url = http://goodies.xfce.org/projects/thunar-plugins/thunar-media-tags-plugin
+ arch = i686
+ arch = x86_64
+ groups = xfce4-goodies
+ license = GPL
+ makedepends = intltool
+ makedepends = xfce4-dev-tools
+ makedepends = git
+ depends = taglib
+ depends = thunar-git
+ provides = thunar-media-tags-plugin=0.2.1
+ conflicts = thunar-media-tags-plugin
+ source = thunar-media-tags-plugin::git://git.xfce.org/thunar-plugins/thunar-media-tags-plugin
+ sha256sums = SKIP
+
+pkgname = thunar-media-tags-plugin-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ddf777fea78d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: twa022 <twa022 at gmail dot com>
+
+_pkgname=thunar-media-tags-plugin
+pkgname=${_pkgname}-git
+pkgver=0.2.1.r173.gea240bf
+pkgrel=1
+pkgdesc="Adds special features for media files to the Thunar File Manager (git checkout)"
+arch=('i686' 'x86_64')
+license=('GPL')
+url="http://goodies.xfce.org/projects/thunar-plugins/thunar-media-tags-plugin"
+groups=('xfce4-goodies')
+depends=('taglib' 'thunar-git')
+makedepends=('intltool' 'xfce4-dev-tools' 'git')
+provides=("${_pkgname}=${pkgver%\.r*}")
+conflicts=("${_pkgname}")
+source=("${_pkgname}::git://git.xfce.org/thunar-plugins/thunar-media-tags-plugin")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git describe --long --tags | sed -r "s:^${_pkgname}.::;s/^v//;s/([^-]*-g)/r\1/;s/-/./g"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+
+ ./autogen.sh \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --disable-static \
+ --disable-debug
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ make DESTDIR="$pkgdir" install
+}