summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSeb Deligny2018-09-05 21:52:32 +0200
committerSeb Deligny2018-09-05 21:52:32 +0200
commit88e9456c811fb705f39e2a17ee02436011916320 (patch)
treeae3cd39a156452eebf30966c4147a3cf43b99e10
parent8d4820733c34b4ca2ca26359863f266586c59a6b (diff)
downloadaur-88e9456c811fb705f39e2a17ee02436011916320.tar.gz
Update to 0.3.0 for Thunar 1.7 and higher
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 18 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index da5ff24d5113..b86b49d50831 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Thu Dec 10 21:31:16 UTC 2015
pkgbase = thunar-shares-plugin
pkgdesc = Thunar plugin to quickly share a folder using Samba without requiring root access
- pkgver = 0.2.0.git
- pkgrel = 2
+ pkgver = 0.3.0.git
+ pkgrel = 1
url = http://goodies.xfce.org/projects/thunar-plugins/thunar-shares-plugin
install = thunar-shares-plugin.install
arch = i686
@@ -11,12 +9,10 @@ pkgbase = thunar-shares-plugin
license = GPL2
license = LGPL
makedepends = xfce4-dev-tools
- depends = thunar
+ depends = thunar>=1.7.0
depends = samba
- source = http://git.xfce.org/thunar-plugins/thunar-shares-plugin/snapshot/thunar-shares-plugin-053cc4e0dc484081def59769efbe3a544fe169bc.tar.bz2
- source = drop-thunar-vfs.patch::http://git.xfce.org/thunar-plugins/thunar-shares-plugin/patch/?id=3a89ca67b27d717b13fed7851fce3244f31fc94e
- sha1sums = a6c4ca62f34fc26bde7ec94f5fcc5d9b6593b282
- sha1sums = 29a0e3c31e1e48008c781c3575915398ec9e502b
+ source = https://git.xfce.org/thunar-plugins/thunar-shares-plugin/snapshot/thunar-shares-plugin-master.tar.bz2
+ sha1sums = SKIP
pkgname = thunar-shares-plugin
diff --git a/PKGBUILD b/PKGBUILD
index 78b69313dca2..238c0434a448 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,35 +2,32 @@
# Contributor: SpepS <dreamspepser at yahoo dot it>
# Contributor: vinz <vinz@archlinux.us>
# Contributor: Aurélien DESBRIÈRES <ice.cube@gmx.com>
-
+# Contributor: Daniel Jenssen <daerandin@gmail.com>
+
pkgname=thunar-shares-plugin
-pkgver=0.2.0.git
-_gitcommit=053cc4e0dc484081def59769efbe3a544fe169bc
-pkgrel=2
+pkgver=0.3.0.git
+pkgrel=1
pkgdesc="Thunar plugin to quickly share a folder using Samba without requiring root access"
arch=('i686' 'x86_64')
url="http://goodies.xfce.org/projects/thunar-plugins/${pkgname}"
license=('GPL2' 'LGPL')
-depends=('thunar' 'samba')
+depends=('thunar>=1.7.0' 'samba')
makedepends=('xfce4-dev-tools')
install="${pkgname}.install"
-source=("http://git.xfce.org/thunar-plugins/thunar-shares-plugin/snapshot/thunar-shares-plugin-${_gitcommit}.tar.bz2"
- "drop-thunar-vfs.patch::http://git.xfce.org/thunar-plugins/thunar-shares-plugin/patch/?id=3a89ca67b27d717b13fed7851fce3244f31fc94e")
-sha1sums=('a6c4ca62f34fc26bde7ec94f5fcc5d9b6593b282'
- '29a0e3c31e1e48008c781c3575915398ec9e502b')
-
+source=("https://git.xfce.org/thunar-plugins/thunar-shares-plugin/snapshot/thunar-shares-plugin-master.tar.bz2")
+sha1sums=('SKIP')
+
prepare() {
- cd "${srcdir}/${pkgname}-${_gitcommit}"
- patch -Np1 -i "${srcdir}/drop-thunar-vfs.patch"
+ cd "${srcdir}/${pkgname}-master"
}
-
+
build() {
- cd "${srcdir}/${pkgname}-${_gitcommit}"
+ cd "${srcdir}/${pkgname}-master"
./autogen.sh --prefix=/usr --enable-debug=no
make
}
-
+
package() {
- cd "${srcdir}/${pkgname}-${_gitcommit}"
+ cd "${srcdir}/${pkgname}-master"
make DESTDIR="${pkgdir}" install
}