summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorErikas2016-04-16 12:22:59 +0300
committerErikas2016-04-16 12:22:59 +0300
commit7d2cf769affed70ea06e0962a0630acaebb568f4 (patch)
tree92d348c28049f39db90d90952543f286ef93e119
parent434ae752c2f704cdc18af304c57e627d4905a8a1 (diff)
downloadaur-7d2cf769affed70ea06e0962a0630acaebb568f4.tar.gz
update
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD48
-rw-r--r--thunar-thumbnailers.install17
3 files changed, 60 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2ef209a323a4..8ecaa6ab3e61 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,24 @@
pkgbase = thunar-thumbnailers
- pkgdesc = Display various file previews (thumbnails) in Thunar file manager.
+ pkgdesc = Provides additional thumbnailers for Thunar. Patched to support OpenRaster
pkgver = 0.4.1
pkgrel = 1
- url = http://goodies.xfce.org/projects/thunar-plugins/thunar-thumbnailers
- arch = any
- license = CCPL:cc-by-nc-sa
- makedepends = git
- makedepends = xfce4-dev-tools
+ url = http://goodies.xfce.org/projects/thunar-plugins/thunar-thumbnailers/
+ install = thunar-thumbnailers.install
+ arch = i686
+ arch = x86_64
+ groups = xfce4-goodies
+ license = GPL2
+ makedepends = raw-thumbnailer
+ makedepends = dcraw
+ makedepends = unzip
depends = imagemagick
- optdepends = tetex: LaTeX files support
- optdepends = raw-thumbnailer: Raw Digital Camera Images support
- optdepends = grace: Grace files support
- optdepends = ffmpegthumbnailer: Thumbnails for video files support
- source = git://git.xfce.org/apps/thunar-thumbnailers
- md5sums = SKIP
+ depends = ffmpegthumbnailer
+ optdepends = raw-thumbnailer: support for Raw Digital Camera Images
+ optdepends = dcraw: support for Raw Digital Camera Image
+ conflicts = thunar-thumbnailers
+ options = !libtool
+ source = http://archive.xfce.org/src/apps/thunar-thumbnailers/0.4/thunar-thumbnailers-0.4.1.tar.bz2
+ sha256sums = 7b37531de23adb35ef183ccb0a970e916a8cd78dddd840adbf2970b941524209
pkgname = thunar-thumbnailers
diff --git a/PKGBUILD b/PKGBUILD
index 4fa673324f05..3bd71a4f6681 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,36 @@
# Maintainer: Erikas Rudinskas (erikmnkl@gmail.com)
-# The Thunar-thumbnailer plugin is not maintainable anymore (latest version at 2008) and should not be any updates in the future.
-# You can check at: http://git.xfce.org/apps/thunar-thumbnailers/
+#
+# All credits goes to:
+# Maintainer: Ronald van Haren <ronald.archlinux.org>
+# Contributor: boromil@gmail.com
pkgname=thunar-thumbnailers
pkgver=0.4.1
pkgrel=1
-arch=('any')
-pkgdesc="Display various file previews (thumbnails) in Thunar file manager."
-url="http://goodies.xfce.org/projects/thunar-plugins/thunar-thumbnailers"
-license=('CCPL:cc-by-nc-sa')
-depends=('imagemagick')
-makedepends=('git' 'xfce4-dev-tools')
-optdepends=(
- 'tetex: LaTeX files support'
- 'raw-thumbnailer: Raw Digital Camera Images support'
- 'grace: Grace files support'
- 'ffmpegthumbnailer: Thumbnails for video files support'
-)
-source=('git://git.xfce.org/apps/thunar-thumbnailers')
-md5sums=('SKIP')
+pkgdesc="Provides additional thumbnailers for Thunar. Patched to support OpenRaster"
+url="http://goodies.xfce.org/projects/thunar-plugins/thunar-thumbnailers/"
+license=('GPL2')
+arch=('i686' 'x86_64')
+groups=('xfce4-goodies')
+depends=('imagemagick' 'ffmpegthumbnailer')
+optdepends=('raw-thumbnailer: support for Raw Digital Camera Images'
+ 'dcraw: support for Raw Digital Camera Image')
+makedepends=('raw-thumbnailer' 'dcraw' 'unzip')
+conflicts=('thunar-thumbnailers')
+options=('!libtool')
+install=thunar-thumbnailers.install
+source=(http://archive.xfce.org/src/apps/thunar-thumbnailers/0.4/$pkgname-$pkgver.tar.bz2)
+sha256sums=('7b37531de23adb35ef183ccb0a970e916a8cd78dddd840adbf2970b941524209')
build() {
- cd "$srcdir/$pkgname"
- ./autogen.sh
- make
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr --enable-ffmpeg --enable-raw \
+ --libexecdir=/usr/lib/xfce4
+ make || return 1
+
}
package() {
- cd "$srcdir/$pkgname"
- make DESTDIR="$pkgdir/" install
-}
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR=$pkgdir install || return 1
+} \ No newline at end of file
diff --git a/thunar-thumbnailers.install b/thunar-thumbnailers.install
new file mode 100644
index 000000000000..378bdb0cb50e
--- /dev/null
+++ b/thunar-thumbnailers.install
@@ -0,0 +1,17 @@
+post_install() {
+cat << _EOF
+==> important installation notes:
+ ----------------------------------------
+ After installing it is necessary to run:
+ /usr/lib/thunar-vfs-update-thumbnailers-cache-1
+ as a user to regenerate the cache of thumbnailers.
+ You may also need to log out and back in for the new
+ thumbnailers to work.
+_EOF
+
+}
+
+post_upgrade() {
+ post_install
+}
+