summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorErikas2016-04-16 09:47:00 +0300
committerErikas2016-04-16 09:47:00 +0300
commitcdcf9d5ee01c9943c5f256e965e385bfd452d115 (patch)
tree6af058356ba205ec7ee672a2f82904c4a178f78b
downloadaur-cdcf9d5ee01c9943c5f256e965e385bfd452d115.tar.gz
Initial push
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD32
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..47e5ed9921cf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = thunar-thumbnailers
+ pkgdesc = Display various file previews (thumbnails) in Thunar file manager.
+ pkgver = 0.4.1
+ pkgrel = 1
+ url = http://goodies.xfce.org/projects/thunar-plugins/thunar-thumbnailers
+ arch = any
+ license = CCPL:cc-by-nc-sa
+ makedepends = git
+ makedepends = xfce4-dev-tools
+ optdepends = tetex: LaTeX files support
+ optdepends = raw-thumbnailer: Raw Digital Camera Images support
+ optdepends = dcraw: Addition to Raw Digital Camera Images support
+ optdepends = grace: Grace files support
+ optdepends = ffmpegthumbnailer: Video files support
+ source = git://git.xfce.org/apps/thunar-thumbnailers
+ md5sums = SKIP
+
+pkgname = thunar-thumbnailers
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..748e02006542
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Erikas Rudinskas (erikmnkl@gmail.com)
+# The Thunar-thumbnailer plugin is not maintainable anymore (latest version at 2008) and should not be any updates in the future.
+# You can check at: http://git.xfce.org/apps/thunar-thumbnailers/
+
+pkgname=thunar-thumbnailers
+pkgver=0.4.1
+pkgrel=1
+arch=('any')
+pkgdesc="Display various file previews (thumbnails) in Thunar file manager."
+url="http://goodies.xfce.org/projects/thunar-plugins/thunar-thumbnailers"
+license=('CCPL:cc-by-nc-sa')
+makedepends=('git' 'xfce4-dev-tools')
+optdepends=(
+ 'tetex: LaTeX files support'
+ 'raw-thumbnailer: Raw Digital Camera Images support'
+ 'dcraw: Addition to Raw Digital Camera Images support'
+ 'grace: Grace files support'
+ 'ffmpegthumbnailer: Video files support'
+)
+source=('git://git.xfce.org/apps/thunar-thumbnailers')
+md5sums=('SKIP')
+
+build() {
+ cd "$srcdir/$pkgname"
+ ./autogen.sh
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir/" install
+}