summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhenning mueller2015-07-05 19:52:38 +0200
committerhenning mueller2015-07-05 19:52:38 +0200
commit9cb38a278ea130e86e0166542713c444f5164bdd (patch)
tree39b93e1da3e4a2d02cb914c936e31fa5659f48de
downloadaur-9cb38a278ea130e86e0166542713c444f5164bdd.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD31
-rw-r--r--thunar-vcs-plugin.install3
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ba917cf3a1d7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = thunar-vcs-plugin
+ pkgdesc = SVN and GIT integration for Thunar.
+ pkgver = 0.1.4
+ pkgrel = 2
+ url = http://goodies.xfce.org/projects/thunar-plugins/thunar-vcs-plugin
+ install = thunar-vcs-plugin.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = intltool
+ depends = thunar
+ depends = git
+ depends = subversion
+ depends = apr
+ source = http://archive.xfce.org/src/thunar-plugins/thunar-vcs-plugin/0.1/thunar-vcs-plugin-0.1.4.tar.bz2
+ source = thunar-vcs-plugin.install
+ md5sums = b2321096c706e42b85987f0114ab73bc
+ md5sums = 70988e8f3be46644620bf85c05efa5b6
+
+pkgname = thunar-vcs-plugin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..152a71252ddc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Contributor: henning mueller <henning@orgizm.net>
+
+pkgname=thunar-vcs-plugin
+pkgver=0.1.4
+pkgrel=2
+pkgdesc="SVN and GIT integration for Thunar."
+arch=(i686 x86_64)
+license=(GPL)
+url=http://goodies.xfce.org/projects/thunar-plugins/thunar-vcs-plugin
+depends=(thunar git subversion apr)
+makedepends=(intltool)
+source=(
+ http://archive.xfce.org/src/thunar-plugins/thunar-vcs-plugin/0.1/$pkgname-$pkgver.tar.bz2
+ $pkgname.install
+)
+md5sums=(
+ b2321096c706e42b85987f0114ab73bc
+ 70988e8f3be46644620bf85c05efa5b6
+)
+install=$pkgname.install
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ ./configure --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib/xfce4
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make DESTDIR=$pkgdir install
+}
diff --git a/thunar-vcs-plugin.install b/thunar-vcs-plugin.install
new file mode 100644
index 000000000000..9cb7ab6b45e7
--- /dev/null
+++ b/thunar-vcs-plugin.install
@@ -0,0 +1,3 @@
+post_install() {
+ gtk-update-icon-cache -f /usr/share/icons/hicolor
+}