summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTed Alff2017-11-24 12:48:21 -0500
committerTed Alff2017-11-24 12:48:21 -0500
commitcae99ec13c2a165695456f6e0377ede7c344f330 (patch)
tree1dbd08534a9dda647b88c6d4df34a5aeb0d518e6
parentad5c8ab0d524e36b82c639e0a7be0f5cb2b42b4b (diff)
downloadaur-cae99ec13c2a165695456f6e0377ede7c344f330.tar.gz
Resubmit. GTK3 version from git
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD43
-rw-r--r--missing_parenthesis.patch12
-rw-r--r--thunar-volman-git.install16
4 files changed, 47 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 738a1afd3725..f41e4312cbbf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,27 @@
+# Generated by mksrcinfo v8
+# Fri Nov 24 17:48:01 UTC 2017
pkgbase = thunar-volman-git
- pkgdesc = automatic management for removeable devices in thunar
- pkgver = 434.c6164e9
+ pkgdesc = automatic management for removeable devices in thunar (
+ pkgver = 0.8.1.r67.g158c666
pkgrel = 1
+ epoch = 1
url = http://goodies.xfce.org/projects/thunar-plugins/thunar-volman
- install = thunar-volman-git.install
arch = i686
arch = x86_64
groups = xfce4-goodies-git
license = GPL2
makedepends = git
makedepends = intltool
- makedepends = pkgconfig
makedepends = xfce4-dev-tools
- depends = thunar
- depends = libxfce4ui
+ depends = thunar-git
depends = hicolor-icon-theme
- provides = thunar-volman
+ provides = thunar-volman=0.8.1
conflicts = thunar-volman
options = !libtool
- source = git://git.xfce.org/xfce/thunar-volman
- md5sums = SKIP
+ source = thunar-volman::git+https://github.com/andreldm/thunar-volman
+ source = missing_parenthesis.patch
+ sha256sums = SKIP
+ sha256sums = 96564d3cde55ae449a04b7016054c0bf1a8962c928f44d37247028f3fa836a64
pkgname = thunar-volman-git
diff --git a/PKGBUILD b/PKGBUILD
index eb61b9d75fb5..61a52e22d7c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,38 @@
-# Maintainer: Diego <cdprincipe@at@gmail@dot@com>
-#Contributor: Gadget3000 <gadget3000 at msn dot com>
+#Maintainer: twa022 <twa022 at gmail dot com>
_pkgname=thunar-volman
-pkgname=thunar-volman-git
-pkgver=434.c6164e9
+pkgname=${_pkgname}-git
+epoch=1
+pkgver=0.8.1.r67.g158c666
pkgrel=1
-pkgdesc="automatic management for removeable devices in thunar"
+pkgdesc="automatic management for removeable devices in thunar ("
arch=(i686 x86_64)
license=('GPL2')
url="http://goodies.xfce.org/projects/thunar-plugins/thunar-volman"
groups=('xfce4-goodies-git')
-#depends=('thunar-git' 'libxfce4ui' 'hicolor-icon-theme')
-depends=('thunar' 'libxfce4ui' 'hicolor-icon-theme')
-makedepends=('git' 'intltool' 'pkgconfig' 'xfce4-dev-tools')
-conflicts=(thunar-volman)
-provides=(thunar-volman)
+depends=('thunar-git' 'hicolor-icon-theme')
+makedepends=('git' 'intltool' 'xfce4-dev-tools')
+conflicts=("${_pkgname}")
+provides=("${_pkgname}=${pkgver%\.r*}")
options=('!libtool')
-install=${pkgname}.install
-source=('git://git.xfce.org/xfce/thunar-volman')
-md5sums=('SKIP')
+source=("${_pkgname}::git+https://github.com/andreldm/thunar-volman"
+ 'missing_parenthesis.patch')
+#source=("${_pkgname}::git://git.xfce.org/xfce/thunar-volman")
+sha256sums=('SKIP'
+ '96564d3cde55ae449a04b7016054c0bf1a8962c928f44d37247028f3fa836a64')
pkgver() {
- cd "$srcdir/$_pkgname"
-# git describe --always | sed 's|-|.|g'
- echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+ cd "${srcdir}/${_pkgname}"
+ git describe --long --tags | sed -r "s/^${_pkgname}.//;s/([^-]*-g)/r\1/;s/-/./g"
+}
+
+prepare() {
+ cd "${srcdir}/${_pkgname}"
+ patch -uNp2 -r- -i ../missing_parenthesis.patch
}
build() {
- cd "$srcdir/$_pkgname"
+ cd "${srcdir}/${_pkgname}"
./autogen.sh \
--prefix=/usr \
@@ -40,6 +45,6 @@ build() {
}
package() {
- cd "$srcdir/$_pkgname"
- make DESTDIR="$pkgdir/" install
+ cd "${srcdir}/${_pkgname}"
+ make DESTDIR="${pkgdir}" install
}
diff --git a/missing_parenthesis.patch b/missing_parenthesis.patch
new file mode 100644
index 000000000000..17a8d30740e3
--- /dev/null
+++ b/missing_parenthesis.patch
@@ -0,0 +1,12 @@
+diff -Naur ./thunar-volman.orig/thunar-volman-settings/main.c ./thunar-volman/thunar-volman-settings/main.c
+--- ./thunar-volman.orig/thunar-volman-settings/main.c 2017-11-24 12:40:49.883100185 -0500
++++ ./thunar-volman/thunar-volman-settings/main.c 2017-11-24 12:40:55.439716611 -0500
+@@ -101,7 +101,7 @@
+ g_signal_connect (plug, "delete-event", G_CALLBACK (gtk_main_quit), NULL);
+ gtk_widget_show (plug);
+
+- list = gtk_container_get_children (GTK_CONTAINER (gtk_dialog_get_content_area (GTK_DIALOG (dialog)));
++ list = gtk_container_get_children (GTK_CONTAINER (gtk_dialog_get_content_area (GTK_DIALOG (dialog))));
+ plug_child = list->data;
+ g_list_free (list);
+
diff --git a/thunar-volman-git.install b/thunar-volman-git.install
deleted file mode 100644
index 23fe3cd3a895..000000000000
--- a/thunar-volman-git.install
+++ /dev/null
@@ -1,16 +0,0 @@
-post_install() {
- gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
-}
-
-post_upgrade() {
- post_install
-}
-
-post_remove() {
- post_install
-}
-
-op=$1
-shift
-
-$op $*