summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTed Alff2017-12-20 21:18:40 -0500
committerTed Alff2017-12-20 21:18:40 -0500
commit071276453a01d3e1927b0dbc7e1d1deaec491e9b (patch)
tree0b2a278d68788461526eb2b591a612a47a68fcf6
parentd8fb85855c733daebbb774f8a07ba8a95b2420cf (diff)
downloadaur-071276453a01d3e1927b0dbc7e1d1deaec491e9b.tar.gz
Version bump 0.4.0. Detect thunar version at build time and use 0.3.0 if thunarx-2 (thunar<1.7.0) installed or 0.4.0 if thunarx-3 (thunar>=1.7.0) installed
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD51
-rw-r--r--pygtk.patch12
-rw-r--r--python2.patch13
-rw-r--r--thunarx-python.install13
5 files changed, 77 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 867bbf3da44d..56fee246261d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,25 @@
+# Generated by mksrcinfo v8
+# Thu Dec 21 02:17:29 UTC 2017
pkgbase = thunarx-python
pkgdesc = Thunarx Python Bindings
pkgver = 0.3.0
- pkgrel = 3
- url = http://rabbitvcs.org/
+ pkgrel = 1
+ epoch = 1
+ url = http://goodies.xfce.org/projects/bindings/thunarx-python
+ install = thunarx-python.install
arch = i686
arch = x86_64
license = GPL
- depends = python2
- depends = thunar>=0.4.0
- depends = pygtk>=2.6.0
+ makedepends = thunar
+ depends = thunar<1.7.0
depends = python2-gobject2
- source = http://archive.xfce.org/src/bindings/thunarx-python/0.3/thunarx-python-0.3.0.tar.bz2
+ depends = pygtk
+ source = https://archive.xfce.org/src/bindings/thunarx-python/0.3/thunarx-python-0.3.0.tar.bz2
source = python2.patch
- md5sums = 86a28c4c34cae534f2793133b4755794
- md5sums = 6144a91d626ad14b52723edc471369c2
+ source = pygtk.patch
+ sha256sums = 5650e045565af82f3a5f67bbecb46182b502a37f94d08c23adac697dbb4ce258
+ sha256sums = 40c8ec1598142962349314eedb30fab5e115c719571490dcc39d1bcc793451e9
+ sha256sums = c1386f440d3e3b10ee69afeed48f349b91720111aad2d2956b3767085ed8ff87
pkgname = thunarx-python
diff --git a/PKGBUILD b/PKGBUILD
index e4f698f915ce..5ee74836fc98 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,48 @@
-# Maintainer: D. Can Celasun <dcelasun[at]gmail[dot]com>
+# Maintainer: twa022 <twa022 at gmail dot com>
+# Contributor: D. Can Celasun <dcelasun[at]gmail[dot]com>
# Contributor: Dmitry Batenkov <dima dot batenkov at gmail dot com>
pkgname=thunarx-python
-pkgver=0.3.0
-pkgrel=3
+epoch=1
+pkgver=0.4.0
+pkgrel=1
pkgdesc="Thunarx Python Bindings"
arch=('i686' 'x86_64')
-url="http://rabbitvcs.org/"
-depends=('python2' 'thunar>=0.4.0' 'pygtk>=2.6.0' 'python2-gobject2')
+url='http://goodies.xfce.org/projects/bindings/thunarx-python'
+makedepends=('thunar')
license=('GPL')
+install="${pkgname}.install"
+sha256sums=('435f4750f660575c6a854663bfc93f2f16d445128db0e8190e901aa09c15a615'
+ '40c8ec1598142962349314eedb30fab5e115c719571490dcc39d1bcc793451e9'
+ 'c1386f440d3e3b10ee69afeed48f349b91720111aad2d2956b3767085ed8ff87')
+if [[ "`pkg-config --modversion thunarx-3 2>/dev/null`" != '' ]] ; then
+ depends+=('thunar>=1.7.0' 'python2-gobject')
+elif [[ "`pkg-config --modversion thunarx-2 2>/dev/null`" != '' ]] ; then
+ depends+=('thunar<1.7.0' 'python2-gobject2' 'pygtk')
+ pkgver=0.3.0
+ sha256sums[0]='5650e045565af82f3a5f67bbecb46182b502a37f94d08c23adac697dbb4ce258'
+else
+ return 1
+fi
+source=("https://archive.xfce.org/src/bindings/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.bz2"
+ 'python2.patch'
+ 'pygtk.patch')
-source=(http://archive.xfce.org/src/bindings/thunarx-python/0.3/${pkgname}-${pkgver}.tar.bz2 python2.patch)
-md5sums=('86a28c4c34cae534f2793133b4755794'
- '6144a91d626ad14b52723edc471369c2')
-build(){
- cd "${srcdir}"/${pkgname}-${pkgver}
- patch -p1 -i $srcdir/python2.patch
- PYTHON=python2 ./configure
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ patch -p1 -i ../python2.patch
+ if [[ `vercmp "${pkgver}" '0.3.0'` -le 0 ]] ; then
+ patch -p1 -i ../pygtk.patch
+ fi
+}
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ PYTHON=python2 ./configure --prefix=/usr
make
}
package() {
- cd "${srcdir}"/${pkgname}-${pkgver}
- make DESTDIR=${pkgdir} install || return 1
+ cd "${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
}
-
diff --git a/pygtk.patch b/pygtk.patch
new file mode 100644
index 000000000000..e9000018c963
--- /dev/null
+++ b/pygtk.patch
@@ -0,0 +1,12 @@
+diff -aur package.pristine/configure package.new/configure
+--- package.pristine/configure 2011-03-12 23:12:15.000000000 +0200
++++ package.new/configure 2011-03-12 23:21:31.000000000 +0200
+@@ -13339,7 +13339,7 @@
+
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for pygtk codegen" >&5
+ $as_echo_n "checking for pygtk codegen... " >&6; }
+-PYGTK_CODEGEN="/usr/bin/python `$PKG_CONFIG --variable=codegendir pygobject-2.0`/codegen.py"
++PYGTK_CODEGEN="$PYTHON `$PKG_CONFIG --variable=codegendir pygobject-2.0`/codegen.py"
+
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: $PYGTK_CODEGEN" >&5
+ $as_echo "$PYGTK_CODEGEN" >&6; }
diff --git a/python2.patch b/python2.patch
index 831a6e509c72..a58317d4315a 100644
--- a/python2.patch
+++ b/python2.patch
@@ -12,14 +12,5 @@ diff -aur package.pristine/configure package.new/configure
+PYTHON_LIBS="`python2-config --libs`"
+PYTHON_LDFLAGS="`python2-config --ldflags`"
-
-
-@@ -13339,7 +13339,7 @@
-
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for pygtk codegen" >&5
- $as_echo_n "checking for pygtk codegen... " >&6; }
--PYGTK_CODEGEN="/usr/bin/python `$PKG_CONFIG --variable=codegendir pygobject-2.0`/codegen.py"
-+PYGTK_CODEGEN="$PYTHON `$PKG_CONFIG --variable=codegendir pygobject-2.0`/codegen.py"
-
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $PYGTK_CODEGEN" >&5
- $as_echo "$PYGTK_CODEGEN" >&6; }
+
+
diff --git a/thunarx-python.install b/thunarx-python.install
new file mode 100644
index 000000000000..65e72cf20bb4
--- /dev/null
+++ b/thunarx-python.install
@@ -0,0 +1,13 @@
+post_install() {
+ if [[ "`pkg-config --modversion thunarx-2 2>/dev/null`" != '' ]] ; then
+ printf "$(tput setaf 1)$(tput bold) ==> NOTE: $(tput sgr0)"
+ echo "You have installed thunarx-python 0.3.0 for the GTK2 version of"
+ echo " thunar. Do not upgrade to verson 0.4.0 until you install the GTK3 version of"
+ echo " thunar (version >=1.7.0) which has not yet been added to the extra repo"
+ fi
+}
+
+post_upgrade() {
+ post_install
+}
+