summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornikatar2019-04-07 23:27:47 +0300
committernikatar2019-04-07 23:27:47 +0300
commit1d2df901945b6ec35fc9146df54a234809ce8a7b (patch)
tree7cb4dd70a81bbe33f4176cc089b7b7e81d99199b
parent4f33e1f1e790c8f0af784cd59031c9e40566877f (diff)
downloadaur-1d2df901945b6ec35fc9146df54a234809ce8a7b.tar.gz
60.6.1-2
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD20
-rw-r--r--rust-1.33.patch70
3 files changed, 90 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7a658d2b60d2..25e724ff5521 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = thunderbird-appmenu
pkgdesc = Thunderbird from extra with appmenu patch
- pkgver = 60.5.3
+ pkgver = 60.6.1
pkgrel = 2
url = https://aur.archlinux.org/packages/thunderbird-appmenu/
arch = x86_64
@@ -36,15 +36,17 @@ pkgbase = thunderbird-appmenu
depends = ttf-font
depends = icu
optdepends = libcanberra: sound support
- provides = thunderbird=60.5.3
+ provides = thunderbird=60.6.1
conflicts = thunderbird
options = !emptydirs
options = !makeflags
- source = https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/60.5.3/source/thunderbird-60.5.3.source.tar.xz
+ source = https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/60.6.1/source/thunderbird-60.6.1.source.tar.xz
source = thunderbird.desktop
+ source = rust-1.33.patch
source = unity-menubar.patch
- sha256sums = 83c91c4dc9b537aca99db45f99ccf2258cd830c704fb4aa994df18272c8a5211
+ sha256sums = 17aef9232a76bdc812422883c02b01b4ecb7633c3ee9870da5e4ec0e20ba5f67
sha256sums = 3534ea85d8e0e35dba5f40a7a07844df19f3a480e1358fc50c2502f122dab789
+ sha256sums = 97bdb978d59cf5f0f967750e9d8dfbc8fc73367b08437838c44a308fe2ee5442
sha256sums = 22786f52773b93046fdb12378f67343b1d7d3390e83a00ff4aa03948c2b1c9e2
pkgname = thunderbird-appmenu
diff --git a/PKGBUILD b/PKGBUILD
index 27ba0e24b784..1eccb8095450 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
_pkgname=thunderbird
pkgname=thunderbird-appmenu
-pkgver=60.5.3
+pkgver=60.6.1
pkgrel=2
pkgdesc="Thunderbird from extra with appmenu patch"
arch=(x86_64)
@@ -24,9 +24,11 @@ conflicts=("thunderbird")
options=(!emptydirs !makeflags)
source=(https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/$pkgver/source/thunderbird-$pkgver.source.tar.xz
$_pkgname.desktop
+ rust-1.33.patch
unity-menubar.patch)
-sha256sums=('83c91c4dc9b537aca99db45f99ccf2258cd830c704fb4aa994df18272c8a5211'
+sha256sums=('17aef9232a76bdc812422883c02b01b4ecb7633c3ee9870da5e4ec0e20ba5f67'
'3534ea85d8e0e35dba5f40a7a07844df19f3a480e1358fc50c2502f122dab789'
+ '97bdb978d59cf5f0f967750e9d8dfbc8fc73367b08437838c44a308fe2ee5442'
'22786f52773b93046fdb12378f67343b1d7d3390e83a00ff4aa03948c2b1c9e2')
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
@@ -44,6 +46,12 @@ _mozilla_api_key=16674381-f021-49de-8622-3021c5942aff
prepare() {
cd $_pkgname-$pkgver
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=1539901 (Patch from Fedora)
+ patch -Np1 -i ../rust-1.33.patch
+
+ # actual appmenu patch from ubuntu repos
+ patch -Np1 -i ../unity-menubar.patch
+
echo -n "$_google_api_key" >google-api-key
echo -n "$_mozilla_api_key" >mozilla-api-key
@@ -56,7 +64,8 @@ ac_add_options --enable-release
ac_add_options --enable-linker=gold
ac_add_options --enable-hardening
ac_add_options --enable-optimize
-ac_add_options --enable-rust-simd
+# https://bugzilla.mozilla.org/show_bug.cgi?id=1521249
+#ac_add_options --enable-rust-simd
# Branding
ac_add_options --enable-official-branding
@@ -64,7 +73,8 @@ ac_add_options --enable-update-channel=release
ac_add_options --with-distribution-id=org.archlinux
# Keys
-ac_add_options --with-google-api-keyfile=${PWD@Q}/google-api-key
+ac_add_options --with-google-location-service-api-keyfile=${PWD@Q}/google-api-key
+ac_add_options --with-google-safebrowsing-api-keyfile=${PWD@Q}/google-api-key
ac_add_options --with-mozilla-api-keyfile=${PWD@Q}/mozilla-api-key
# System libraries
@@ -86,8 +96,6 @@ ac_add_options --disable-crashreporter
ac_add_options --disable-updater
END
- # actual appmenu patch from ubuntu repos
- patch -Np1 -i ../unity-menubar.patch
}
build() {
diff --git a/rust-1.33.patch b/rust-1.33.patch
new file mode 100644
index 000000000000..30da2437a037
--- /dev/null
+++ b/rust-1.33.patch
@@ -0,0 +1,70 @@
+diff -up thunderbird-60.5.3/servo/components/style/gecko/regen_atoms.py.rust-1.33-build thunderbird-60.5.3/servo/components/style/gecko/regen_atoms.py
+--- thunderbird-60.5.3/servo/components/style/gecko/regen_atoms.py.rust-1.33-build 2019-03-04 19:17:31.000000000 +0100
++++ thunderbird-60.5.3/servo/components/style/gecko/regen_atoms.py 2019-03-13 15:05:58.965726109 +0100
+@@ -202,6 +202,7 @@ RULE_TEMPLATE = ('("{atom}") =>\n '
+ ' }}}};')
+
+ MACRO = '''
++/// Returns a static atom by passing the literal string it represents.
+ #[macro_export]
+ macro_rules! atom {{
+ {}
+diff -up thunderbird-60.5.3/servo/components/style/gecko_string_cache/namespace.rs.rust-1.33-build thunderbird-60.5.3/servo/components/style/gecko_string_cache/namespace.rs
+--- thunderbird-60.5.3/servo/components/style/gecko_string_cache/namespace.rs.rust-1.33-build 2019-03-04 19:17:27.000000000 +0100
++++ thunderbird-60.5.3/servo/components/style/gecko_string_cache/namespace.rs 2019-03-13 15:05:58.966726107 +0100
+@@ -11,6 +11,7 @@ use std::fmt;
+ use std::ops::Deref;
+ use string_cache::{Atom, WeakAtom};
+
++/// Macro text
+ #[macro_export]
+ macro_rules! ns {
+ () => { $crate::string_cache::Namespace(atom!("")) };
+diff -up thunderbird-60.5.3/servo/components/style/properties/properties.mako.rs.rust-1.33-build thunderbird-60.5.3/servo/components/style/properties/properties.mako.rs
+--- thunderbird-60.5.3/servo/components/style/properties/properties.mako.rs.rust-1.33-build 2019-03-04 19:17:30.000000000 +0100
++++ thunderbird-60.5.3/servo/components/style/properties/properties.mako.rs 2019-03-13 15:05:58.966726107 +0100
+@@ -55,6 +55,7 @@ use style_adjuster::StyleAdjuster;
+
+ pub use self::declaration_block::*;
+
++/// Generated
+ #[cfg(feature = "gecko")]
+ #[macro_export]
+ macro_rules! property_name {
+@@ -3852,7 +3853,7 @@ impl fmt::Debug for AliasId {
+ }
+ }
+
+-// NOTE(emilio): Callers are responsible to deal with prefs.
++/// Callers are responsible to deal with prefs.
+ #[macro_export]
+ macro_rules! css_properties_accessors {
+ ($macro_name: ident) => {
+@@ -3875,6 +3876,7 @@ macro_rules! css_properties_accessors {
+ }
+ }
+
++/// Neco
+ #[macro_export]
+ macro_rules! longhand_properties_idents {
+ ($macro_name: ident) => {
+diff -up thunderbird-60.5.3/servo/components/style_traits/values.rs.rust-1.33-build thunderbird-60.5.3/servo/components/style_traits/values.rs
+--- thunderbird-60.5.3/servo/components/style_traits/values.rs.rust-1.33-build 2019-03-04 19:17:27.000000000 +0100
++++ thunderbird-60.5.3/servo/components/style_traits/values.rs 2019-03-13 15:37:34.077560034 +0100
+@@ -135,6 +135,7 @@ where
+ }
+ }
+
++/// Neco
+ #[macro_export]
+ macro_rules! serialize_function {
+ ($dest: expr, $name: ident($( $arg: expr, )+)) => {
+@@ -404,7 +405,7 @@ impl_to_css_for_predefined_type!(::csspa
+ impl_to_css_for_predefined_type!(::cssparser::Color);
+ impl_to_css_for_predefined_type!(::cssparser::UnicodeRange);
+
+-#[macro_export]
++/// Define an enum type with unit variants that each correspond to a CSS keyword.
+ macro_rules! define_css_keyword_enum {
+ (pub enum $name:ident { $($variant:ident = $css:expr,)+ }) => {
+ #[allow(missing_docs)]