summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorΝικόλαος Κυριάκος Φυτίλης2022-02-05 20:22:41 +0200
committerΝικόλαος Κυριάκος Φυτίλης2022-02-05 20:22:41 +0200
commit702d6cf196bdea44c5b5b74814596302c9c6d450 (patch)
tree5494a363ca55a039505818decea49b882cb2f48a
parente5e266db5b6d6e16bd83b957342ad21cb2b8270c (diff)
downloadaur-702d6cf196bdea44c5b5b74814596302c9c6d450.tar.gz
test rel for osc
-rw-r--r--0002-Bug-1745560-Add-missing-stub-for-wl_proxy_marshal_fl.patch28
-rw-r--r--PKGBUILD6
2 files changed, 32 insertions, 2 deletions
diff --git a/0002-Bug-1745560-Add-missing-stub-for-wl_proxy_marshal_fl.patch b/0002-Bug-1745560-Add-missing-stub-for-wl_proxy_marshal_fl.patch
new file mode 100644
index 000000000000..bcd5e25822c0
--- /dev/null
+++ b/0002-Bug-1745560-Add-missing-stub-for-wl_proxy_marshal_fl.patch
@@ -0,0 +1,28 @@
+From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
+From: Kevin Daudt <kdaudt@alpinelinux.org>
+Date: Sun, 12 Dec 2021 13:38:48 +0000
+Subject: [PATCH] Bug 1745560 - Add missing stub for wl_proxy_marshal_flags,
+ r=stransky
+
+Firefox fails to build against wayland 1.20 because this symbol is missing
+
+Differential Revision: https://phabricator.services.mozilla.com/D133583
+---
+ widget/gtk/mozwayland/mozwayland.c | 7 +++++++
+ 1 file changed, 7 insertions(+)
+
+diff --git a/widget/gtk/mozwayland/mozwayland.c b/widget/gtk/mozwayland/mozwayland.c
+index 7a448e6321e2..1a86468b4f3d 100644
+--- a/widget/gtk/mozwayland/mozwayland.c
++++ b/widget/gtk/mozwayland/mozwayland.c
+@@ -200,3 +200,10 @@ MOZ_EXPORT int wl_list_empty(const struct wl_list* list) { return -1; }
+
+ MOZ_EXPORT void wl_list_insert_list(struct wl_list* list,
+ struct wl_list* other) {}
++
++MOZ_EXPORT struct wl_proxy* wl_proxy_marshal_flags(
++ struct wl_proxy* proxy, uint32_t opcode,
++ const struct wl_interface* interface, uint32_t version, uint32_t flags,
++ ...) {
++ return NULL;
++}
diff --git a/PKGBUILD b/PKGBUILD
index 38a12dab6141..0c1d28fc610e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -46,7 +46,8 @@ source=(https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/$pkgver/sou
distribution.ini
mozconfig.cfg
unity-menubar.patch
- fix-wayland.patch)
+ fix-wayland.patch
+ 0002-Bug-1745560-Add-missing-stub-for-wl_proxy_marshal_fl.patch)
md5sums=('SKIP'
'SKIP'
'10872ca39ebb8844ec753203c55bccc4'
@@ -54,7 +55,8 @@ md5sums=('SKIP'
'1ef0f094e533a68399b96dc8080c6a6e'
'c6963498e5ceddedb13af44efa70d86f'
'0d7f0fe667c3e9e54f95fa51e9560eed'
- 'eb9fd90a3b18bfeebbed7e0e6056079c')
+ 'eb9fd90a3b18bfeebbed7e0e6056079c'
+'SKIP')
validpgpkeys=(14F26682D0916CDD81E37B6D61B7B526D98F0353) # Mozilla Software Releases <release@mozilla.com>