summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornikatar2020-05-02 20:21:05 +0300
committernikatar2020-05-02 20:21:05 +0300
commitb2ae78f54ba559d311708c4b62b545618b6da576 (patch)
tree24f6dcc8f57ed84544b287cb3555910a2aee1c32
parent39787a00799405dabcc89378562419594c7ecb0a (diff)
downloadaur-b2ae78f54ba559d311708c4b62b545618b6da576.tar.gz
rust 1.43.patch & icu 67.1 rebuild
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
-rw-r--r--rust-1.43.patch71
3 files changed, 80 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 638b42fefbed..69492280386f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = thunderbird-appmenu
pkgdesc = Thunderbird from extra with appmenu patch
pkgver = 68.7.0
- pkgrel = 1
+ pkgrel = 2
url = https://www.mozilla.org/thunderbird/
arch = x86_64
license = MPL
@@ -46,11 +46,13 @@ pkgbase = thunderbird-appmenu
source = https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/68.7.0/source/thunderbird-68.7.0.source.tar.xz
source = https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/68.7.0/source/thunderbird-68.7.0.source.tar.xz.asc
source = thunderbird.desktop
+ source = rust-1.43.patch
source = unity-menubar.patch
validpgpkeys = 14F26682D0916CDD81E37B6D61B7B526D98F0353
sha512sums = fae763030b7a54930291a10f298b7fa4ffc400849082f576556b9040d095f1007ae686daf1241dff8b73bac35c14acf21c156a18a3e16d62a7719c6cc34e4d1f
sha512sums = SKIP
sha512sums = fa28ec547f87658cf72d160e9c2a7867d3e8a9b8c76ffa29d1098fddfc9331f65cc6dbf24c15da28c5d1b4ffa587d14d529d5da522a8805b073ad89986a552c9
+ sha512sums = 8833130802e2bfb34036444d6855c96a5b819f90c9835decd816bbf50dc507a71b2c343fd53d3fec0d79df791bb56436b06f2430abbeb70c726574a57c385d54
sha512sums = f3aa468974780016de60fa61a61f7e67a2cc51b4f888b223d16b9afaa42e82100c3b3d7f9491dfd0de3c5667ad4ac0fc58b96d81ef448ccf6e924cdc49066ad5
pkgname = thunderbird-appmenu
diff --git a/PKGBUILD b/PKGBUILD
index 226e5eebca4b..ebcebc863813 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@
_pkgname=thunderbird
pkgname=thunderbird-appmenu
pkgver=68.7.0
-pkgrel=1
+pkgrel=2
pkgdesc="Thunderbird from extra with appmenu patch"
arch=(x86_64)
license=(MPL GPL LGPL)
@@ -27,10 +27,12 @@ conflicts=("thunderbird")
options=(!emptydirs !makeflags)
source=(https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/$pkgver/source/thunderbird-$pkgver.source.tar.xz{,.asc}
$_pkgname.desktop
+ rust-1.43.patch
unity-menubar.patch)
sha512sums=('fae763030b7a54930291a10f298b7fa4ffc400849082f576556b9040d095f1007ae686daf1241dff8b73bac35c14acf21c156a18a3e16d62a7719c6cc34e4d1f'
'SKIP'
'fa28ec547f87658cf72d160e9c2a7867d3e8a9b8c76ffa29d1098fddfc9331f65cc6dbf24c15da28c5d1b4ffa587d14d529d5da522a8805b073ad89986a552c9'
+ '8833130802e2bfb34036444d6855c96a5b819f90c9835decd816bbf50dc507a71b2c343fd53d3fec0d79df791bb56436b06f2430abbeb70c726574a57c385d54'
'f3aa468974780016de60fa61a61f7e67a2cc51b4f888b223d16b9afaa42e82100c3b3d7f9491dfd0de3c5667ad4ac0fc58b96d81ef448ccf6e924cdc49066ad5')
validpgpkeys=(14F26682D0916CDD81E37B6D61B7B526D98F0353) # Mozilla Software Releases <release@mozilla.com>
@@ -48,8 +50,11 @@ _mozilla_api_key=16674381-f021-49de-8622-3021c5942aff
prepare() {
cd $_pkgname-$pkgver
+
+ patch -Np1 -i ../rust-1.43.patch
# Actual appmenu patch from ubuntu repos
+ # http://archive.ubuntu.com/ubuntu/pool/main/t/thunderbird/thunderbird_68.7.0+build1-0ubuntu0.18.04.1.debian.tar.xz
patch -Np1 -i ../unity-menubar.patch
echo -n "$_google_api_key" >google-api-key
diff --git a/rust-1.43.patch b/rust-1.43.patch
new file mode 100644
index 000000000000..de717a7f6d32
--- /dev/null
+++ b/rust-1.43.patch
@@ -0,0 +1,71 @@
+
+# HG changeset patch
+# User Emilio Cobos Álvarez <emilio@crisal.io>
+# Date 1568322567 0
+# Node ID 773adf85740c7f5f295f9e17bba1d8a95888ee32
+# Parent a1824d4c404b8926930c2fbde5c9a14c7bd05763
+Bug 1580963 - Cherry-pick some servo changes from a rustc upgrade.
+
+This cherry-picks from Servo commit 98e4a53b724.
+
+Differential Revision: https://phabricator.services.mozilla.com/D45738
+
+diff --git a/servo/components/style/stylesheets/viewport_rule.rs b/servo/components/style/stylesheets/viewport_rule.rs
+--- a/servo/components/style/stylesheets/viewport_rule.rs
++++ b/servo/components/style/stylesheets/viewport_rule.rs
+@@ -286,38 +286,47 @@ impl<'a, 'b, 'i> DeclarationParser<'i> f
+
+ fn parse_value<'t>(
+ &mut self,
+ name: CowRcStr<'i>,
+ input: &mut Parser<'i, 't>,
+ ) -> Result<Vec<ViewportDescriptorDeclaration>, ParseError<'i>> {
+ macro_rules! declaration {
+ ($declaration:ident($parse:expr)) => {
+- declaration!($declaration(value: try!($parse(input)),
+- important: input.try(parse_important).is_ok()))
++ declaration!($declaration {
++ value: $parse(input)?,
++ important: input.try(parse_important).is_ok(),
++ })
+ };
+- ($declaration:ident(value: $value:expr, important: $important:expr)) => {
++ ($declaration:ident { value: $value:expr, important: $important:expr, }) => {
+ ViewportDescriptorDeclaration::new(
+ self.context.stylesheet_origin,
+ ViewportDescriptor::$declaration($value),
+- $important)
+- }
++ $important,
++ )
++ };
+ }
+
+ macro_rules! ok {
+ ($declaration:ident($parse:expr)) => {
+ Ok(vec![declaration!($declaration($parse))])
+ };
+ (shorthand -> [$min:ident, $max:ident]) => {{
+ let shorthand = parse_shorthand(self.context, input)?;
+ let important = input.try(parse_important).is_ok();
+
+ Ok(vec![
+- declaration!($min(value: shorthand.0, important: important)),
+- declaration!($max(value: shorthand.1, important: important)),
++ declaration!($min {
++ value: shorthand.0,
++ important: important,
++ }),
++ declaration!($max {
++ value: shorthand.1,
++ important: important,
++ }),
+ ])
+ }};
+ }
+
+ match_ignore_ascii_case! { &*name,
+ "min-width" => ok!(MinWidth(|i| ViewportLength::parse(self.context, i))),
+ "max-width" => ok!(MaxWidth(|i| ViewportLength::parse(self.context, i))),
+ "width" => ok!(shorthand -> [MinWidth, MaxWidth]),
+