summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDet2017-08-26 16:36:01 +0300
committerDet2017-08-26 16:36:01 +0300
commitd8b1c422209b8e4a678707a00a8e6e07edde3dc9 (patch)
tree8db296e27cd60d0db0460b1d824d2f3ef4cc74ad
parentf4a234d1064b2a0bb25e728eee1681cd41f4bf46 (diff)
downloadaur-d8b1c422209b8e4a678707a00a8e6e07edde3dc9.tar.gz
Fixes
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
-rw-r--r--no-crmf.diff11
-rw-r--r--rust-i686.patch16
4 files changed, 10 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5e4cbf10a0ab..48c12f61189e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -22,6 +22,8 @@ pkgbase = thunderbird-beta
makedepends = xorg-server-xvfb
makedepends = autoconf2.13
makedepends = cargo
+ makedepends = clang
+ makedepends = llvm
depends = gtk3
depends = gtk2
depends = mozilla-common
@@ -44,13 +46,11 @@ pkgbase = thunderbird-beta
source = thunderbird-beta.desktop
source = thunderbird-install-dir.patch
source = no-crmf.diff
- source = rust-i686.patch
source = fix-wifi-scanner.diff
sha512sums = 566b82510cd83d49441a2c4506add99d2496e160e28c853f809f68fe9d4be491c23cbe838104399c8bd8699201b23eb30a73f84df0d6c074282695518e76f1ed
sha512sums = e5649ddee3ca9cfdcf56652e9c8e6160d52c69d1439f9135b0c0d436ce61a25f17758afc0dd6cac3434c26234c584828eb07fdf9604797f7dd3f617ec194b79a
sha512sums = 8100fd3ea37d998905498d41c8504bfdd6d86766542d6b93107c92382a7525da7f75a83f8ff1e15ad95039d51da2add7e6b18af76d45516a41cdfd1e9f98f262
- sha512sums = 08572139508d4fd4e2b855d294ebee3286151da80dfeae656ae29b49ce6d72185f4cfa73dfb827c1bcce6bc8c544d0cf4a00164c9059dff316351901601fb6ea
- sha512sums = b38d8a2cb1719d652d93160bfbdfa7cbeca36fbee84b217ca0f5b0b4074b6e151c582b1e0f62901c418fb68a5018f6e21d734d6775836da5b0b44593071c3351
+ sha512sums = 951667941520e66e7b6aad55619ec2b38364da58c5cf8a71775a3032921cfc0a8e5c7ba14e0df35588175f94a6b4785566d39177ff536ab9cefcbd19a03dc065
sha512sums = 1bd2804bea1fe8c85b602f8c5f8777f4ba470c9e767ad284cb3d0287c6d6e1b126e760738d7c671f38933ee3ec6b8931186df8e978995b5109797ae86dfdd85a
pkgname = thunderbird-beta
diff --git a/PKGBUILD b/PKGBUILD
index cc7718b7da1d..53cf11c71c3b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,3 +1,4 @@
+
# Maintainer: Det <nimetonmaili g-mail>
# Based on [extra]'s thunderbird: https://git.archlinux.org/svntogit/packages.git/tree/trunk?h=packages/thunderbird
@@ -13,7 +14,7 @@ url="https://www.mozilla.org/thunderbird/"
depends=(gtk3 gtk2 mozilla-common libxt startup-notification mime-types dbus-glib alsa-lib ffmpeg
nss hunspell sqlite ttf-font icu libvpx)
makedepends=(unzip zip diffutils python2 yasm mesa imake gconf libpulse inetutils xorg-server-xvfb
- autoconf2.13 cargo)
+ autoconf2.13 cargo clang llvm)
optdepends=('libcanberra: sound support')
options=(!emptydirs !makeflags)
install=$pkgname.install
@@ -21,13 +22,11 @@ source=(https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/$pkgver/sou
$pkgname.desktop
thunderbird-install-dir.patch
no-crmf.diff
- rust-i686.patch
fix-wifi-scanner.diff)
sha512sums=('566b82510cd83d49441a2c4506add99d2496e160e28c853f809f68fe9d4be491c23cbe838104399c8bd8699201b23eb30a73f84df0d6c074282695518e76f1ed'
'e5649ddee3ca9cfdcf56652e9c8e6160d52c69d1439f9135b0c0d436ce61a25f17758afc0dd6cac3434c26234c584828eb07fdf9604797f7dd3f617ec194b79a'
'8100fd3ea37d998905498d41c8504bfdd6d86766542d6b93107c92382a7525da7f75a83f8ff1e15ad95039d51da2add7e6b18af76d45516a41cdfd1e9f98f262'
- '08572139508d4fd4e2b855d294ebee3286151da80dfeae656ae29b49ce6d72185f4cfa73dfb827c1bcce6bc8c544d0cf4a00164c9059dff316351901601fb6ea'
- 'b38d8a2cb1719d652d93160bfbdfa7cbeca36fbee84b217ca0f5b0b4074b6e151c582b1e0f62901c418fb68a5018f6e21d734d6775836da5b0b44593071c3351'
+ '951667941520e66e7b6aad55619ec2b38364da58c5cf8a71775a3032921cfc0a8e5c7ba14e0df35588175f94a6b4785566d39177ff536ab9cefcbd19a03dc065'
'1bd2804bea1fe8c85b602f8c5f8777f4ba470c9e767ad284cb3d0287c6d6e1b126e760738d7c671f38933ee3ec6b8931186df8e978995b5109797ae86dfdd85a')
# RC
if [[ $_build = ? ]]; then
@@ -62,15 +61,12 @@ prepare() {
msg2 "fix-wifi-scanner.diff: https://bugzilla.mozilla.org/show_bug.cgi?id=1314968"
patch -d mozilla -Np1 < ../fix-wifi-scanner.diff
- msg2 "Build with the rust targets we actually ship"
- patch -d mozilla -Np1 < ../rust-i686.patch
-
# API keys
echo -n "$_google_api_key" >google-api-key
echo -n "$_mozilla_api_key" >mozilla-api-key
# mozconfig
- cat > .mozconfig <<END
+ cat >.mozconfig <<END
ac_add_options --enable-application=mail
ac_add_options --enable-calendar
@@ -80,7 +76,7 @@ ac_add_options --enable-release
ac_add_options --enable-gold
ac_add_options --enable-pie
ac_add_options --enable-optimize="-O2"
-ac_add_options --enable-rust
+#ac_add_options --enable-rust
# Branding
ac_add_options --enable-official-branding
@@ -195,4 +191,5 @@ END
# https://bugzilla.mozilla.org/show_bug.cgi?id=658850
ln -srf "$pkgdir/usr/bin/$pkgname" \
"$pkgdir/opt/$pkgname/thunderbird-bin"
-} \ No newline at end of file
+}
+
diff --git a/no-crmf.diff b/no-crmf.diff
index 73e545de0eed..702e7f6270c7 100644
--- a/no-crmf.diff
+++ b/no-crmf.diff
@@ -1,14 +1,3 @@
-diff -u -rN thunderbird-52.1.1/mozilla/config/external/nss/crmf/moz.build thunderbird-52.1.1-nocrmf/mozilla/config/external/nss/crmf/moz.build
---- thunderbird-52.1.1/mozilla/config/external/nss/crmf/moz.build 2017-05-09 23:35:13.000000000 +0200
-+++ thunderbird-52.1.1-nocrmf/mozilla/config/external/nss/crmf/moz.build 2017-06-14 01:51:36.686773132 +0200
-@@ -8,7 +8,6 @@
-
- if CONFIG['MOZ_SYSTEM_NSS']:
- OS_LIBS += [l for l in CONFIG['NSS_LIBS'] if l.startswith('-L')]
-- OS_LIBS += ['-lcrmf']
- else:
- USE_LIBS += [
- # The dependency on nss is not real, but is required to force the
diff -u -rN thunderbird-52.1.1/mozilla/old-configure thunderbird-52.1.1-nocrmf/mozilla/old-configure
--- thunderbird-52.1.1/mozilla/old-configure 2017-05-09 23:35:35.000000000 +0200
+++ thunderbird-52.1.1-nocrmf/mozilla/old-configure 2017-06-14 01:50:28.726873231 +0200
diff --git a/rust-i686.patch b/rust-i686.patch
deleted file mode 100644
index 85512e1436b8..000000000000
--- a/rust-i686.patch
+++ /dev/null
@@ -1,16 +0,0 @@
- build/moz.configure/rust.configure | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git c/build/moz.configure/rust.configure i/build/moz.configure/rust.configure
-index cd86b24153debb1b..44911715e25d95e3 100644
---- c/build/moz.configure/rust.configure
-+++ i/build/moz.configure/rust.configure
-@@ -81,7 +81,7 @@ def rust_target(rust_compiler, rustc, target, cross_compiling):
- # OpenBSD
- ('x86_64', 'OpenBSD'): 'x86_64-unknown-openbsd',
- # Linux
-- ('x86', 'Linux'): 'i586-unknown-linux-gnu',
-+ ('x86', 'Linux'): 'i686-unknown-linux-gnu',
- # Linux
- ('x86_64', 'Linux'): 'x86_64-unknown-linux-gnu',
- # OS X and iOS