summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJavier Tia2015-10-21 20:45:32 -0600
committerJavier Tia2015-10-21 20:45:39 -0600
commit011181c31d4f35c56bc418ecf9cae7806bd1e158 (patch)
tree51aa961169f24aaa9f110c651a0a8dcad5be282d
parent5a64cbe6b78bd18a8101247d9a0d3e0f53164aa6 (diff)
downloadaur-011181c31d4f35c56bc418ecf9cae7806bd1e158.tar.gz
Bump to thunderbird-exchangecalendar 3.4.0 rev 7
Changelog: - Create package from .xpi, instead of .tar.gz - Add to office group - Add version to provide field - Disable warn and check for new extension version - Don't look for .so files
-rw-r--r--PKGBUILD65
1 files changed, 26 insertions, 39 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6f90f2c28639..2e705ffb979a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,60 +1,47 @@
# Maintainer: Javier Tia <javier dot tia at gmail dot com>
# Creator: Javier Vasquez <j dot e dot vasquez dot v at gmail dot com>
pkgname=thunderbird-exchangecalendar
+_name=exchangecalendar
pkgver=3.4.0
-_pkgver=3.4.0
-pkgrel=2
-pkgdesc="Thunderbird Addon/Extension and Provider for Microsoft Exchange 2007/2010/2013 Calendar, Tasks, Contacts and Global Address List (GAL)"
-url="https://github.com/Ericsson/exchangecalendar"
+pkgrel=7
+pkgdesc='Thunderbird Addon/Extension and Provider for Microsoft Exchange 2007/2010/2013 Calendar, Tasks, Contacts and Global Address List (GAL)'
+url='https://github.com/Ericsson/exchangecalendar'
arch=('any')
+groups=('office')
license=('GPL3')
depends=('thunderbird' 'thunderbird-lightning-bin')
makedepends=('zip')
options=('!strip' '!libtool' '!staticlibs' '!docs')
conflicts=('thunderbird-exchangecalendar-git')
-provides=('thunderbird-exchangecalendar')
-source=(https://github.com/Ericsson/exchangecalendar/archive/v${_pkgver}.tar.gz)
-sha256sums=('fc6d9fc1a645cbd32d5b5af565b7bbad7316234301d41d32434c209ba70e432f')
-_name=exchangecalendar
-
-build() {
- cd ${srcdir}/${_name}-${_pkgver}
-
- # Allow warnings of new packages, though do not make it required
- sed -i 's|\(warnAboutNewAddOnVersion", \)false|\1true|' defaults/preferences/update_disable.txt
- sed -i 's|\(checkForNewAddOnVersion", \)false|\1true|' defaults/preferences/update_disable.txt
-
- ./build.sh -d
-}
+provides=("${_name}=${pkgver}")
+source=("${pkgname}-${pkgver}.xpi::https://github.com/Ericsson/${_name}/releases/download/v${pkgver}/${_name}-v${pkgver}.xpi")
+sha256sums=('086025910cf507aa72b4ff8d8a7811935f79d4b75f42d686b08c71a2f6d2ff9f')
package() {
- # Extract extension version
- _emver=$(grep -m 1 em:version ${srcdir}/${_name}-${_pkgver}/install.rdf \
- | sed 's/.*>\(.*\)<.*/\1/')
+ _extdir=usr/lib/thunderbird/extensions
+ mkdir -p ${pkgdir}/${_extdir}/${pkgname}
+ cd ${pkgdir}/${_extdir}/${pkgname}
+ bsdtar -x -f ${srcdir}/${pkgname}-${pkgver}.xpi
# Extract extension name
- _emid=$(grep -m 1 em:id ${srcdir}/${_name}-${_pkgver}/install.rdf \
- | sed 's/.*>\(.*\)<.*/\1/')
-
- # Thunderbird extensions directory path
- _pkgsrc=usr/lib/thunderbird/extensions
-
- # Create thunderbird extensions directory with another emid directory
- # extension name
- mkdir -p ${pkgdir}/${_pkgsrc}/${_emid}
+ _emid=$(grep -m 1 em:id install.rdf | sed 's/.*>\(.*\)<.*/\1/')
- # Work under thunderbird extensions directory
- cd ${pkgdir}/${_pkgsrc}
+ # Change extension name
+ cd ..
+ mv ${pkgname} ${_emid}
+ cd ${_emid}
- # Extract all files from .xpi file in emid directory
- bsdtar -x --cd ${_emid} \
- -f ${srcdir}/${_name}-${_pkgver}/${_name}-${_emver}.xpi
+ # Disable warn and check about new version
+ sed -i 's|\(warnAboutNewAddOnVersion", \)true|\1false|' \
+ defaults/preferences/update_disable.txt
+ sed -i 's|\(checkForNewAddOnVersion", \)true|\1false|' \
+ defaults/preferences/update_disable.txt
+ cat defaults/preferences/update_disable.txt > defaults/preferences/update.js
# Fix permissions in emid extension directory
- find ${_emid} -type d -exec chmod 0755 \{\} \+
- find ${_emid} -type f -exec chmod 0644 \{\} \+
- find ${_emid} -name '*.so' -exec chmod 0755 \{\} \+
- chown -R root:root ${_emid}
+ find . -type d -exec chmod 0755 \{\} \+
+ find . -type f -exec chmod 0644 \{\} \+
+ chown -R root:root .
}
# vim:set ft=sh ts=2 sw=2 ft=sh et: