summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJavier Tia2015-08-17 14:15:16 -0600
committerJavier Tia2015-08-17 14:15:16 -0600
commit6e6f98cf374190e241383f47c384f8ab42eb2a9b (patch)
tree507089fcddf85f9e96398fa0ddb0443266b163e1
downloadaur-6e6f98cf374190e241383f47c384f8ab42eb2a9b.tar.gz
Initial release thunderbird-exchangecalendar-3.4.0.beta5
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD53
2 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..441568e6f93f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = thunderbird-exchangecalendar
+ pkgdesc = Thunderbird Addon/Extension and Provider for Microsoft Exchange 2007/2010/2013 Calendar, Tasks, Contacts and Global Address List (GAL).
+ pkgver = 3.4.0.beta5
+ pkgrel = 1
+ url = https://github.com/Ericsson/exchangecalendar
+ arch = any
+ license = GPL3
+ makedepends = zip
+ depends = thunderbird
+ depends = thunderbird-lightning-bin
+ provides = thunderbird-exchangecalendar
+ conflicts = thunderbird-exchangecalendar-git
+ options = !strip
+ options = !libtool
+ options = !staticlibs
+ options = !docs
+ source = https://github.com/Ericsson/exchangecalendar/archive/3.4.0-beta5.tar.gz
+ sha256sums = 032739bac7f4d1295e5ffe462ef6fa2c4440604193094923e3d7c8757f8e225c
+
+pkgname = thunderbird-exchangecalendar
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8c1b1cf7b13d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Javier Tia <javier dot tia at gmail dot com>
+# Creator: Javier Vasquez <j dot e dot vasquez dot v at gmail dot com>
+pkgname=thunderbird-exchangecalendar
+pkgver=3.4.0.beta5
+_pkgver=3.4.0-beta5
+pkgrel=1
+pkgdesc="Thunderbird Addon/Extension and Provider for Microsoft Exchange 2007/2010/2013 Calendar, Tasks, Contacts and Global Address List (GAL)."
+url="https://github.com/Ericsson/exchangecalendar"
+arch=('any')
+license=('GPL3')
+depends=('thunderbird' 'thunderbird-lightning-bin')
+makedepends=('zip')
+options=('!strip' '!libtool' '!staticlibs' '!docs')
+conflicts=('thunderbird-exchangecalendar-git')
+provides=('thunderbird-exchangecalendar')
+source=(https://github.com/Ericsson/exchangecalendar/archive/${_pkgver}.tar.gz)
+sha256sums=('032739bac7f4d1295e5ffe462ef6fa2c4440604193094923e3d7c8757f8e225c')
+_name=exchangecalendar
+
+build() {
+ cd ${srcdir}/${_name}-${_pkgver}
+
+ # Allow warnings of new packages, though do not make it required
+ sed -i 's|\(warnAboutNewAddOnVersion", \)false|\1true|' defaults/preferences/update_disable.txt
+ sed -i 's|\(checkForNewAddOnVersion", \)false|\1true|' defaults/preferences/update_disable.txt
+
+ ./build.sh -d
+}
+
+package() {
+ # Extract extension version
+ _emver=$(grep -m 1 em:version ${srcdir}/${_name}-${_pkgver}/install.rdf \
+ | sed 's/.*>\(.*\)<.*/\1/')
+
+ # Extract all files from extension .xpi file
+ _pkgsrc=usr/lib/thunderbird/extensions
+ mkdir -p ${pkgdir}/${_pkgsrc}/${pkgname}-${pkgver}
+ bsdtar -x --cd ${pkgdir}/${_pkgsrc}/${pkgname}-${pkgver} \
+ -f ${srcdir}/${_name}-${_pkgver}/${_name}-${_emver}.xpi
+
+ # Extract extension name
+ _emid=$(grep -m 1 em:id ${srcdir}/${_name}-${_pkgver}/install.rdf \
+ | sed 's/.*>\(.*\)<.*/\1/')
+ mv ${srcdir}/${_name}-${_pkgver} ${_emid}
+
+ # Fix permissions in extension directory
+ find ${_emid} -type d -exec chmod 0755 \{\} \+
+ find ${_emid} -type f -exec chmod 0644 \{\} \+
+ find ${_emid} -name '*.so' -exec chmod 0755 \{\} \+
+ chown -R root:root ${_emid}
+}
+
+# vim:set ft=sh ts=2 sw=2 ft=sh et: