summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQuentin Retornaz2017-06-15 17:13:45 +0200
committerQuentin Retornaz2017-06-15 17:13:45 +0200
commit5824878dcfe4aaa42f0c4d2119e693492caee3ea (patch)
treef0f80508e8bd5646631346440129e6efdf585e11
parentc5b2c54766e064429afcb45b605363f353a48a6d (diff)
downloadaur-5824878dcfe4aaa42f0c4d2119e693492caee3ea.tar.gz
Revert "remove rust"
This reverts commit c5b2c54766e064429afcb45b605363f353a48a6d.
-rw-r--r--.SRCINFO4
-rw-r--r--0001-Bug-1338655-Don-t-try-to-build-mp4parse-bindings.-r-.patch48
-rw-r--r--PKGBUILD6
3 files changed, 57 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 790d009c722b..f770dfeaa0b1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Thu Jun 15 14:26:01 UTC 2017
+# Thu Jun 15 13:25:13 UTC 2017
pkgbase = thunderbird-gtk2
pkgdesc = Standalone mail and news reader from mozilla.org
pkgver = 52.2.0
@@ -46,11 +46,13 @@ pkgbase = thunderbird-gtk2
options = !makeflags
source = https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/52.2.0/source/thunderbird-52.2.0.source.tar.xz
source = thunderbird.desktop
+ source = 0001-Bug-1338655-Don-t-try-to-build-mp4parse-bindings.-r-.patch
source = 0001-Bug-54395-remove-hardcoded-flag-lcrmf.patch
source = thunderbird-install-dir.patch
source = fix-wifi-scanner.diff
sha256sums = c65c66244ac113996002bcfa9e387f14291163cfb7009a9126e3a8d4a970e72d
sha256sums = e44c55501f650a4e80b9c353b81f33e07ca65808db831eff6ca616aded233827
+ sha256sums = 413cd6d366d78f325d80ebebccfd0afa0d266b40b2e54b66ba2fa03c15f3ea67
sha256sums = 93c495526c1a1227f76dda5f3a43b433bc7cf217aaf74bd06b8fc187d285f593
sha256sums = 24599eab8862476744fe1619a9a53a5b8cdcab30b3fc5767512f31d3529bd05d
sha256sums = 9765bca5d63fb5525bbd0520b7ab1d27cabaed697e2fc7791400abc3fa4f13b8
diff --git a/0001-Bug-1338655-Don-t-try-to-build-mp4parse-bindings.-r-.patch b/0001-Bug-1338655-Don-t-try-to-build-mp4parse-bindings.-r-.patch
new file mode 100644
index 000000000000..cf2e0eb9b80b
--- /dev/null
+++ b/0001-Bug-1338655-Don-t-try-to-build-mp4parse-bindings.-r-.patch
@@ -0,0 +1,48 @@
+From bbd48a5613c872883616884cfaf41665b0e4ec9b Mon Sep 17 00:00:00 2001
+From: Ralph Giles <giles@mozilla.com>
+Date: Fri, 10 Feb 2017 12:58:18 -0800
+Subject: [PATCH] Bug 1338655 - Don't try to build mp4parse bindings. r=froydnj
+
+We use the cheddar crate to generate a C header file
+for our mp4parse_capi wrapper crate. Currently we
+do this at code check-in time via update-rust.sh.
+
+Cargo 0.18 and later will try to execute a build.rs
+file in the crate source tree regardless of whether
+it's specified in Cargo.toml so patching out that
+line just results in 'crate cheddar not found'.
+
+This change restores the old behaviour by substituting
+a 'build = false' line instead.
+
+We do have syntex vendored, but we don't currently build
+it by default, so I prefer this solution to just vendoring
+cheddar and generating the header at build time. The syntex
+crate is quite large and adds significantly to our compile
+time.
+
+MozReview-Commit-ID: InJRRODWAdP
+
+--HG--
+extra : rebase_source : 29378fcbc86015ce6cc22dc66d38a43ddbac204e
+---
+ media/libstagefright/binding/mp4parse-cargo.patch | 5 +++--
+ media/libstagefright/binding/mp4parse_capi/Cargo.toml | 2 ++
+ 2 files changed, 5 insertions(+), 2 deletions(-)
+
+diff --git a/media/libstagefright/binding/mp4parse_capi/Cargo.toml b/media/libstagefright/binding/mp4parse_capi/Cargo.toml
+index aee7ee947151a27c..d7e3f55119d3f4b6 100644
+--- a/media/libstagefright/binding/mp4parse_capi/Cargo.toml
++++ b/media/libstagefright/binding/mp4parse_capi/Cargo.toml
+@@ -18,6 +18,8 @@ exclude = [
+ "*.mp4",
+ ]
+
++build = false
++
+ [dependencies]
+ byteorder = "1.0.0"
+ "mp4parse" = {version = "0.6.0", path = "../mp4parse"}
+--
+2.12.2
+
diff --git a/PKGBUILD b/PKGBUILD
index 9c39f21df555..5d1fe34f9aef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,10 +24,12 @@ provides=("thunderbird=${pkgver}-${pkgrel}")
conflicts=("thunderbird")
source=(https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/$pkgver/source/thunderbird-$pkgver.source.tar.xz
thunderbird.desktop
+ 0001-Bug-1338655-Don-t-try-to-build-mp4parse-bindings.-r-.patch
0001-Bug-54395-remove-hardcoded-flag-lcrmf.patch
thunderbird-install-dir.patch fix-wifi-scanner.diff)
sha256sums=('c65c66244ac113996002bcfa9e387f14291163cfb7009a9126e3a8d4a970e72d'
'e44c55501f650a4e80b9c353b81f33e07ca65808db831eff6ca616aded233827'
+ '413cd6d366d78f325d80ebebccfd0afa0d266b40b2e54b66ba2fa03c15f3ea67'
'93c495526c1a1227f76dda5f3a43b433bc7cf217aaf74bd06b8fc187d285f593'
'24599eab8862476744fe1619a9a53a5b8cdcab30b3fc5767512f31d3529bd05d'
'9765bca5d63fb5525bbd0520b7ab1d27cabaed697e2fc7791400abc3fa4f13b8')
@@ -54,6 +56,9 @@ prepare() {
# https://bugzilla.mozilla.org/show_bug.cgi?id=1314968
patch -d mozilla -Np1 < ../fix-wifi-scanner.diff
+ # https://bugs.archlinux.org/task/53890
+ patch -Np1 -i ../0001-Bug-1338655-Don-t-try-to-build-mp4parse-bindings.-r-.patch
+
# https://bugs.archlinux.org/task/54395 // https://bugzilla.mozilla.org/show_bug.cgi?id=1371991
patch -Np1 -i ../0001-Bug-54395-remove-hardcoded-flag-lcrmf.patch
@@ -68,6 +73,7 @@ ac_add_options --prefix=/usr
ac_add_options --enable-release
ac_add_options --enable-gold
ac_add_options --enable-pie
+ac_add_options --enable-rust
ac_add_options --enable-default-toolkit=cairo-gtk2