summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDet2017-11-04 15:01:45 +0200
committerDet2017-11-04 15:01:45 +0200
commit33ed9070fec3ebc1433f525dc83cef2fe30a03ec (patch)
tree2c72ccc78d9b318b16b7a6b2de3c1e44aa525f51
parentad0a5b0f17de92ffefd0df794410d821038b7316 (diff)
downloadaur-33ed9070fec3ebc1433f525dc83cef2fe30a03ec.tar.gz
Spell-check/hyphenation + certs
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD11
2 files changed, 12 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 24185d02b90b..5603becdcdc4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -34,13 +34,14 @@ pkgbase = thunderbird-hg
depends = dbus-glib
depends = alsa-lib
depends = ffmpeg
- depends = nss>=3.33
- depends = hunspell
+ depends = nss
depends = sqlite
depends = ttf-font
depends = icu
depends = libvpx
- optdepends = libcanberra: for sound support
+ optdepends = hunspell: Spell checking
+ optdepends = hyphen: Hyphenation
+ optdepends = libcanberra: Sound support
options = !emptydirs
options = !makeflags
source = hg+http://hg.mozilla.org/comm-central
diff --git a/PKGBUILD b/PKGBUILD
index 3ef12bb485d0..623976093edb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,10 +9,12 @@ arch=(i686 x86_64)
license=(MPL GPL LGPL)
url="https://www.mozilla.org/thunderbird/"
depends=(gtk3 gtk2 mozilla-common libxt startup-notification mime-types dbus-glib alsa-lib ffmpeg
- 'nss>=3.33' hunspell sqlite ttf-font icu libvpx)
+ nss sqlite ttf-font icu libvpx)
makedepends=(unzip zip diffutils python2 yasm mesa imake gconf libpulse inetutils xorg-server-xvfb
autoconf2.13 cargo mercurial clang llvm)
-optdepends=('libcanberra: for sound support')
+optdepends=('hunspell: Spell checking'
+ 'hyphen: Hyphenation'
+ 'libcanberra: Sound support')
options=(!emptydirs !makeflags)
install=$pkgname.install
source=(hg+http://hg.mozilla.org/comm-central
@@ -190,5 +192,8 @@ END
# https://bugzilla.mozilla.org/show_bug.cgi?id=658850
ln -srf "$pkgdir/usr/bin/$pkgname" \
"$pkgdir/opt/$pkgname/thunderbird-bin"
-}
+ # Use system certificates
+ ln -srf "$pkgdir/usr/lib/libnssckbi.so" \
+ "$pkgdir/opt/$pkgname/libnssckbi.so"
+}