summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDet2015-06-14 04:13:28 +0300
committerDet2015-06-14 04:14:16 +0300
commitc296c671d294bfceb7be2e169384e24f74ad9264 (patch)
tree0cf7ae62786b6c3aca13a0c3b2872e56ec8bd495
downloadaur-c296c671d294bfceb7be2e169384e24f74ad9264.tar.gz
Initial import: 41.0a1.r18019.c352d4695e28-1
-rw-r--r--.SRCINFO59
-rw-r--r--PKGBUILD127
-rw-r--r--mozconfig42
-rw-r--r--mozconfig-pgo45
-rw-r--r--thunderbird-hg-safe.desktop11
-rw-r--r--thunderbird-hg.desktop11
-rw-r--r--thunderbird-hg.install34
-rw-r--r--vendor.js9
8 files changed, 338 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b6f293a36112
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,59 @@
+pkgbase = thunderbird-hg
+ pkgdesc = Standalone Mail/News reader - Mercurial version with optional PGO
+ pkgver = 41.0a1.r18019.c352d4695e28
+ pkgrel = 1
+ url = https://www.mozilla.org/thunderbird
+ install = thunderbird-hg.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = LGPL
+ license = MPL
+ makedepends = autoconf2.13
+ makedepends = mercurial
+ makedepends = mesa
+ makedepends = python2
+ makedepends = unzip
+ makedepends = wireless_tools
+ makedepends = yasm
+ makedepends = zip
+ depends = alsa-lib
+ depends = dbus-glib
+ depends = desktop-file-utils
+ depends = fontconfig
+ depends = freetype2
+ depends = gtk-update-icon-cache
+ depends = gtk2
+ depends = hicolor-icon-theme
+ depends = hunspell
+ depends = libjpeg
+ depends = libnotify
+ depends = libpng
+ depends = libvpx
+ depends = libxt
+ depends = mime-types
+ depends = mozilla-common
+ depends = nspr
+ depends = nss
+ depends = pixman
+ depends = sqlite
+ depends = startup-notification
+ optdepends = libcanberra: for sound support
+ provides = thunderbird=41.0a1.r18019.c352d4695e28
+ options = !emptydirs
+ options = !makeflags
+ source = hg+https://hg.mozilla.org/comm-central
+ source = mozconfig
+ source = mozconfig-pgo
+ source = thunderbird-hg.desktop
+ source = thunderbird-hg-safe.desktop
+ source = vendor.js
+ md5sums = SKIP
+ md5sums = 0c5dbb39b27bb72f837921b88a9e48c8
+ md5sums = 7b0cf4656fa25e75187aac4a44376ab9
+ md5sums = 5699093fbb0bb8d29b15a892ce1cbd52
+ md5sums = 603059a0e97ee8b89b71ec4760225b64
+ md5sums = 5a53179d14ae9631b7afe5e4d0fc0b25
+
+pkgname = thunderbird-hg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a31b90daaf06
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,127 @@
+# Maintainer: Det <nimetonmaili g-mail>
+# Based on [extra]'s thunderbird
+
+# NOTE: Enable PGO on x86_64?: http://en.wikipedia.org/wiki/Profile-guided_optimization
+_pgo=0 # "1" to enable
+
+pkgname=thunderbird-hg
+pkgver=41.0a1.r18019.c352d4695e28
+pkgrel=1
+pkgdesc="Standalone Mail/News reader - Mercurial version with optional PGO"
+arch=('i686' 'x86_64')
+license=('GPL' 'LGPL' 'MPL')
+url="https://www.mozilla.org/thunderbird"
+depends=('alsa-lib' 'dbus-glib' 'desktop-file-utils' 'fontconfig' 'freetype2' 'gtk-update-icon-cache' 'gtk2'
+ 'hicolor-icon-theme' 'hunspell' 'libjpeg' 'libnotify' 'libpng' 'libvpx' 'libxt' 'mime-types'
+ 'mozilla-common' 'nspr' 'nss' 'pixman' 'sqlite' 'startup-notification')
+makedepends=('autoconf2.13' 'mercurial' 'mesa' 'python2' 'unzip' 'wireless_tools' 'yasm' 'zip')
+[[ $_pgo = 1 ]] && makedepends+=('imake' 'xorg-server-xvfb')
+optdepends=('libcanberra: for sound support')
+provides=("thunderbird=$pkgver")
+install=$pkgname.install
+options=('!emptydirs' '!makeflags')
+source=('hg+https://hg.mozilla.org/comm-central'
+ 'mozconfig'
+ 'mozconfig-pgo'
+ "$pkgname.desktop"
+ "$pkgname-safe.desktop"
+ 'vendor.js')
+md5sums=('SKIP'
+ '0c5dbb39b27bb72f837921b88a9e48c8'
+ '7b0cf4656fa25e75187aac4a44376ab9'
+ '5699093fbb0bb8d29b15a892ce1cbd52'
+ '603059a0e97ee8b89b71ec4760225b64'
+ '5a53179d14ae9631b7afe5e4d0fc0b25')
+_hgrepo="comm-central"
+
+pkgver() {
+ cd $_hgrepo
+ echo $(cat mail/config/version.txt).r$(hg identify -n).$(hg identify -i)
+}
+
+prepare() {
+ cd $_hgrepo
+
+ # Create directories
+ msg2 "Creating directory structure..."
+ install -d "$pkgdir"/usr/bin
+ install -d "$pkgdir"/usr/share/applications
+ install -d "$pkgdir"/opt
+
+ # Update local copy
+ msg2 "Updating local copy..."
+ python2 client.py checkout
+
+ # PGO?
+ if [[ $CARCH = x86_64 ]] && [[ $_pgo = 1 ]]; then
+ cp "$srcdir"/mozconfig-pgo .mozconfig
+ else
+ cp "$srcdir"/mozconfig .mozconfig
+ fi
+
+ # configure script misdetects the preprocessor without an optimization level
+ # https://bugs.archlinux.org/task/34644
+ sed -i '/ac_cpp=/s/$CPPFLAGS/& -O2/' mozilla/configure
+}
+
+build() {
+ cd $_hgrepo
+
+ # Build flags
+ export LDFLAGS="$LDFLAGS -Wl,-rpath,/opt/$pkgname-r$pkgver"
+ export PYTHON="/usr/bin/python2"
+
+ if [[ $CARCH = x86_64 ]] && [[ $_pgo = 1 ]]; then
+ # Set up PGO
+ msg2 "Running Xvfb..."
+ export DISPLAY=:99
+ Xvfb -nolisten tcp -extension GLX -screen 0 1280x1024x24 $DISPLAY &
+
+ # Build
+ msg2 "Running make..."
+ if ! make -f client.mk build MOZ_MAKE_FLAGS="$MAKEFLAGS" MOZ_PGO=1; then
+ kill $!
+ return 1
+ fi
+
+ # Kill leftovers
+ kill $! || true
+ else
+ msg2 "Running make..."
+ make -f client.mk build MOZ_MAKE_FLAGS="$MAKEFLAGS"
+ fi
+}
+
+package() {
+ cd $_hgrepo/obj-*
+
+ # Put together
+ msg2 "Running make install.."
+ make package
+
+ # Install
+ msg2 "Moving stuff in place..."
+ cd dist
+ tar -xf thunderbird-*.tar.bz2
+ cp -r thunderbird/ "$pkgdir"/opt/$pkgname-r$pkgver/
+
+ # /usr/bin symlink
+ ln -sf /opt/$pkgname-r$pkgver/thunderbird "$pkgdir"/usr/bin/$pkgname
+
+ # vendor.js
+ install -Dm644 "$srcdir"/vendor.js "$pkgdir"/opt/$pkgname-r$pkgver/defaults/preferences/vendor.js
+
+ # Icons
+ for i in 16x16 22x22 24x24 32x32 48x48 256x256; do
+ install -Dm644 "$srcdir"/$_hgrepo/other-licenses/branding/thunderbird/mailicon${i/x*/}.png \
+ "$pkgdir"/usr/share/icons/hicolor/$i/apps/$pkgname.png
+ done
+
+ # Desktop
+ install -m644 "$srcdir"/*.desktop "$pkgdir"/usr/share/applications/
+
+ # Dictionaries/hyphenation
+ rm -rf "$pkgdir"/opt/$pkgname-r$pkgver/{dictionaries,hyphenation}
+ ln -sf /usr/share/hunspell "$pkgdir"/opt/$pkgname-r$pkgver/dictionaries
+ ln -sf /usr/share/hyphen "$pkgdir"/opt/$pkgname-r$pkgver/hyphenation
+}
diff --git a/mozconfig b/mozconfig
new file mode 100644
index 000000000000..623fd4f45df8
--- /dev/null
+++ b/mozconfig
@@ -0,0 +1,42 @@
+mk_add_options MOZ_CO_PROJECT=mail
+ac_add_options --enable-application=mail
+
+ac_add_options --prefix=/opt
+ac_add_options --libdir=/usr/lib
+
+# System libraries
+ac_add_options --with-system-nspr
+ac_add_options --with-system-nss
+ac_add_options --with-system-jpeg
+ac_add_options --with-system-zlib
+ac_add_options --with-system-bz2
+ac_add_options --with-system-png
+ac_add_options --with-system-libevent
+ac_add_options --with-system-libvpx
+ac_add_options --enable-system-hunspell
+ac_add_options --enable-system-sqlite
+ac_add_options --enable-system-ffi
+#ac_add_options --enable-system-cairo
+ac_add_options --enable-system-pixman
+ac_add_options --with-pthreads
+
+# Features
+ac_add_options --enable-official-branding
+ac_add_options --enable-safe-browsing
+ac_add_options --enable-startup-notification
+ac_add_options --enable-gio
+
+ac_add_options --disable-gstreamer
+ac_add_options --disable-gnomevfs
+ac_add_options --disable-crashreporter
+ac_add_options --disable-updater
+ac_add_options --disable-tests
+ac_add_options --disable-mochitest
+ac_add_options --disable-installer
+ac_add_options --disable-debug-symbols
+
+# Optimization
+ac_add_options --enable-optimize
+
+export MOZILLA_OFFICIAL=1
+mk_add_options MOZILLA_OFFICIAL=1
diff --git a/mozconfig-pgo b/mozconfig-pgo
new file mode 100644
index 000000000000..a234012b1d39
--- /dev/null
+++ b/mozconfig-pgo
@@ -0,0 +1,45 @@
+mk_add_options MOZ_CO_PROJECT=mail
+ac_add_options --enable-application=mail
+
+ac_add_options --prefix=/opt
+ac_add_options --libdir=/usr/lib
+
+# System libraries
+ac_add_options --with-system-nspr
+ac_add_options --with-system-nss
+ac_add_options --with-system-jpeg
+ac_add_options --with-system-zlib
+ac_add_options --with-system-bz2
+ac_add_options --with-system-png
+ac_add_options --with-system-libevent
+ac_add_options --with-system-libvpx
+ac_add_options --enable-system-hunspell
+ac_add_options --enable-system-sqlite
+ac_add_options --enable-system-ffi
+#ac_add_options --enable-system-cairo
+ac_add_options --enable-system-pixman
+ac_add_options --with-pthreads
+
+# Features
+ac_add_options --enable-official-branding
+ac_add_options --enable-safe-browsing
+ac_add_options --enable-startup-notification
+ac_add_options --enable-gio
+
+ac_add_options --disable-gstreamer
+ac_add_options --disable-gnomevfs
+ac_add_options --disable-crashreporter
+ac_add_options --disable-updater
+ac_add_options --disable-tests
+ac_add_options --disable-mochitest
+ac_add_options --disable-installer
+ac_add_options --disable-debug-symbols
+
+# Optimization
+ac_add_options --enable-optimize
+
+export MOZILLA_OFFICIAL=1
+mk_add_options MOZILLA_OFFICIAL=1
+
+# PGO
+mk_add_options PROFILE_GEN_SCRIPT='EXTRA_TEST_ARGS=10 $(MAKE) -C $(MOZ_OBJDIR) pgo-profile-run'
diff --git a/thunderbird-hg-safe.desktop b/thunderbird-hg-safe.desktop
new file mode 100644
index 000000000000..879e0e8e700f
--- /dev/null
+++ b/thunderbird-hg-safe.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Name=Thunderbird - Safe Mode (Mercurial version)
+Comment=Read Mail & News in Safe Mode (Mercurial version)
+GenericName=Mail Client & News Reader - Safe Mode (Mercurial version)
+Exec=thunderbird-hg -safe-mode %u
+Icon=thunderbird-hg
+Terminal=false
+Type=Application
+Categories=Network;Email;
+MimeType=message/rfc822;x-scheme-handler/mailto;
+StartupNotify=true \ No newline at end of file
diff --git a/thunderbird-hg.desktop b/thunderbird-hg.desktop
new file mode 100644
index 000000000000..775d674e887a
--- /dev/null
+++ b/thunderbird-hg.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Name=Thunderbird (Mercurial version)
+Comment=Read Mail & News (Mercurial version)
+GenericName=Mail Client & News Reader (Mercurial version)
+Exec=thunderbird-hg %u
+Icon=thunderbird-hg
+Terminal=false
+Type=Application
+Categories=Network;Email;
+MimeType=message/rfc822;x-scheme-handler/mailto;
+StartupNotify=true \ No newline at end of file
diff --git a/thunderbird-hg.install b/thunderbird-hg.install
new file mode 100644
index 000000000000..4f08f918e7fa
--- /dev/null
+++ b/thunderbird-hg.install
@@ -0,0 +1,34 @@
+# Colored makepkg-like functions
+msg_blue() {
+ printf "${blue}==>${bold} $1${all_off}\n"
+}
+
+note() {
+ printf "${blue}==>${yellow} NOTE:$1${bold} $2${all_off}\n"
+}
+
+all_off="$(tput sgr0)"
+bold="${all_off}$(tput bold)"
+blue="${bold}$(tput setaf 4)"
+yellow="${bold}$(tput setaf 3)"
+
+_update() {
+ msg_blue "Updating desktop database..."
+ update-desktop-database -q
+ msg_blue "Updating icon cache.."
+ gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
+}
+
+post_install() {
+ _update
+ note 1 "This package installs side-by-side with [extra]'s thunderbird."
+ note 2 "The binary is called 'thunderbird-hg'."
+}
+
+post_upgrade() {
+ _update
+}
+
+post_remove() {
+ post_upgrade
+} \ No newline at end of file
diff --git a/vendor.js b/vendor.js
new file mode 100644
index 000000000000..170b505a8dcc
--- /dev/null
+++ b/vendor.js
@@ -0,0 +1,9 @@
+// Use LANG environment variable to choose locale
+pref("intl.locale.matchOS", true);
+
+// Disable default mailer checking.
+pref("mail.shell.checkDefaultMail", false);
+
+// Don't disable our bundled extensions in the application directory
+pref("extensions.autoDisableScopes", 11);
+pref("extensions.shownSelectionUI", true);