summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDet2017-03-05 13:34:52 +0200
committerDet2017-03-05 13:34:52 +0200
commitda8a81254606353943d8d148e0bdf5010279fc8d (patch)
tree33067cc9a1a9274eefa790018b2186e54a6c52a7
parent8dfc13f531a73885d0a558073686bf29ea0956d8 (diff)
downloadaur-da8a81254606353943d8d148e0bdf5010279fc8d.tar.gz
Further futile fixes
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD18
2 files changed, 14 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ca4105022553..1db625634532 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sun Mar 5 11:02:53 UTC 2017
+# Sun Mar 5 11:34:52 UTC 2017
pkgbase = thunderbird-hg
pkgdesc = Standalone mail and news reader from mozilla.org - Mercurial version
pkgver = 54.0a1.r21260.cbc772c7b1b4
diff --git a/PKGBUILD b/PKGBUILD
index 31b1f10c4569..515e36fb24c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -38,17 +38,17 @@ _google_api_key=AIzaSyDwr302FpOSkGRpLlUpPThNTDPbXcIn_FM
_mozilla_api_key=16674381-f021-49de-8622-3021c5942aff
prepare() {
+ # Link Python2
+ mkdir -p path
+ ln -sf /usr/bin/python2 path/python
+
cd $_hgrepo
# Sync local copy
msg2 "Syncing local copy..."
python2 client.py checkout
- #
- mkdir -p path
- ln -sf /usr/bin/python2 path/python
-
-
+ # API keys
echo -n "$_google_api_key" > google-api-key
echo -n "$_mozilla_api_key" > mozilla-api-key
@@ -151,9 +151,15 @@ package() {
# ln -sf /opt/$pkgname-r$pkgver/thunderbird "$pkgdir"/usr/bin/$pkgname
cd $_hgrepo
+
+ # Install
+ msg2 "Running make client.mk install.."
make -f client.mk DESTDIR="$pkgdir" INSTALL_SDK= install
+
+ # Rename dir
mv "$pkgdir"/opt/thunderbird/ "$pkgdir"/opt/thunderbird-hg/
+ # vendor.js
_vendorjs="$pkgdir/opt/thunderbird-hg/defaults/preferences/vendor.js"
install -Dm644 /dev/stdin "$_vendorjs" <<END
// Use LANG environment variable to choose locale
@@ -167,11 +173,13 @@ pref("extensions.autoDisableScopes", 11);
pref("extensions.shownSelectionUI", true);
END
+ # Icons
for i in 16 22 24 32 48 256; do
install -Dm644 other-licenses/branding/thunderbird/mailicon$i.png \
"$pkgdir/usr/share/icons/hicolor/${i}x${i}/apps/thunderbird-hg.png"
done
+ # Desktop
install -Dm644 ../thunderbird-hg.desktop \
"$pkgdir/usr/share/applications/thunderbird-hg.desktop"