summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYurii Kolesnykov2020-03-19 18:38:05 +0200
committerYurii Kolesnykov2020-03-19 18:38:05 +0200
commit467934324d7739ba6ea7d69d027a093059d6183c (patch)
tree54511b271af92efdebe1ffef1e6ea6ca4ded2706
downloadaur-467934324d7739ba6ea7d69d027a093059d6183c.tar.gz
init
Signed-off-by: Yurii Kolesnykov <root@yurikoles.com>
-rw-r--r--.SRCINFO44
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD181
-rw-r--r--thunderbird-localized-beta-bin.desktop173
-rw-r--r--thunderbird-localized-beta-bin.install18
5 files changed, 420 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..84a8ec2403e8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,44 @@
+pkgbase = thunderbird-localized-beta-bin
+ pkgdesc = Standalone mail and news reader from mozilla.org
+ pkgver = 75.0b1
+ pkgrel = 1
+ url = https://www.mozilla.org/thunderbird
+ install = thunderbird-localized-beta-bin.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = LGPL
+ license = MPL
+ depends = gtk3
+ depends = mozilla-common
+ depends = libxt
+ depends = startup-notification
+ depends = mime-types
+ depends = dbus-glib
+ depends = alsa-lib
+ depends = nss
+ depends = hunspell
+ depends = sqlite
+ depends = ttf-font
+ depends = icu
+ optdepends = hunspell: Spell checking
+ optdepends = hyphen: Hyphenation
+ optdepends = libcanberra: Sound support
+ provides = thunderbird=75.0b1
+ provides = thunderbird-beta=75.0b1
+ conflicts = thunderbird-beta
+ conflicts = thunderbird-beta-bin
+ source = thunderbird-localized-beta-bin.desktop
+ validpgpkeys = 14F26682D0916CDD81E37B6D61B7B526D98F0353
+ sha256sums = e44c55501f650a4e80b9c353b81f33e07ca65808db831eff6ca616aded233827
+ source_i686 = https://ftp.mozilla.org/pub/thunderbird/releases/75.0b1/linux-i686/uk/thunderbird-75.0b1.tar.bz2
+ source_i686 = https://ftp.mozilla.org/pub/thunderbird/releases/75.0b1/linux-i686/uk/thunderbird-75.0b1.tar.bz2.asc
+ sha256sums_i686 = aa512fc24aa309bf77ecfe5c66435dfcd432ed900478871e13f3e0f978eb84bd
+ sha256sums_i686 = SKIP
+ source_x86_64 = https://ftp.mozilla.org/pub/thunderbird/releases/75.0b1/linux-x86_64/uk/thunderbird-75.0b1.tar.bz2
+ source_x86_64 = https://ftp.mozilla.org/pub/thunderbird/releases/75.0b1/linux-x86_64/uk/thunderbird-75.0b1.tar.bz2.asc
+ sha256sums_x86_64 = aa512fc24aa309bf77ecfe5c66435dfcd432ed900478871e13f3e0f978eb84bd
+ sha256sums_x86_64 = SKIP
+
+pkgname = thunderbird-localized-beta-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..934f0489f207
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.*
+src/
+pkg/
+*.pkg.* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..95074789b003
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,181 @@
+# Maintainer: Yurii Kolesnykov <root@yurikoles.com>
+# Based on thunderbird-beta-bin: Det <nimetonmaili g-mail>
+# Based on [extra]'s thunderbird: Levente Polyak <anthraxx[at]archlinux[dot]org>
+# Based on tor-browser: grufo <madmurphy333 AT gmail DOT com>
+#
+# Before running makepkg, you must do this (as normal user):
+#
+# gpg --auto-key-locate nodefault,wkd --locate-keys release@mozilla.com
+#
+
+pkgname=thunderbird-localized-beta-bin
+_pkgname=thunderbird-beta
+_product=thunderbird
+pkgver=75.0b1
+_major=${pkgver/rc*}
+_build=${pkgver/*rc}
+pkgrel=1
+pkgdesc='Standalone mail and news reader from mozilla.org'
+arch=('i686' 'x86_64')
+url="https://www.mozilla.org/thunderbird"
+license=('GPL' 'LGPL' 'MPL')
+depends=(gtk3 mozilla-common libxt startup-notification mime-types dbus-glib alsa-lib
+ nss hunspell sqlite ttf-font icu)
+optdepends=('hunspell: Spell checking'
+ 'hyphen: Hyphenation'
+ 'libcanberra: Sound support')
+provides=("$_product=$pkgver" "$_pkgname=$pkgver")
+conflicts=("$_pkgname" "$_pkgname-bin")
+install=$pkgname.install
+
+_arch32='linux-i686'
+_arch64='linux-x86_64'
+_urlbase="https://ftp.mozilla.org/pub/thunderbird/releases/${pkgver}"
+_archstr=$([[ "${CARCH}" == 'x86_64' ]] && echo -n "${_arch64}" || echo -n "${_arch32}")
+
+_localemoz() {
+ #
+ # Checking if a `tor-browser` package exists for current locale; a different language can be
+ # chosen by giving a `THUNDERBIRD_PKGLANG` environment variable to `makepkg`, for instance:
+ #
+ # THUNDERBIRD_PKGLANG='en-US' makepkg
+ #
+
+ if [[ -n "${THUNDERBIRD_PKGLANG}" ]]; then
+ echo -n "${THUNDERBIRD_PKGLANG}"
+ return 0
+ fi
+
+ local _fulllocale="$(locale | grep LANG | cut -d= -f2 | cut -d. -f1 | sed s/_/\-/)"
+ local _shortlocale="$(locale | grep LANG | cut -d= -f2 | cut -d_ -f1)"
+
+ if curl --output /dev/null --silent --head --fail "${_urlbase}/${_archstr}/${_fulllocale}/${_product}-${pkgver}.tar.bz2"; then
+ echo -n "${_fulllocale}"
+ elif curl --output /dev/null --silent --head --fail "${_urlbase}/${_archstr}/${_shortlocale}/${_product}-${pkgver}.tar.bz2"; then
+ echo -n "${_shortlocale}"
+ else
+ echo -n 'en-US'
+ fi
+
+}
+
+_language="$(_localemoz)"
+
+validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353')
+
+# Syntax: _dist_checksum 'linux-i686'/'linux-x86_64'
+#linux-i686/ar/thunderbird-75.0b1.tar.bz2
+_dist_checksum() {
+ curl --silent --fail "${_urlbase}/SHA256SUMS" | grep "${1}\/${_language}\/${_product}-${pkgver}.tar.xz" | cut -d ' ' -f1
+}
+
+source_i686=("${_urlbase}/${_arch32}/${_language}/${_product}-${pkgver}.tar.bz2"{,.asc})
+source_x86_64=("${_urlbase}/${_arch64}/${_language}/${_product}-${pkgver}.tar.bz2"{,.asc})
+source=("${pkgname}.desktop")
+
+### IMPORTANT #################################################################
+# No need for `makepkg -g`: the following sha256sums¸don't need to be updated #
+# with each release, everything is done automatically! Leave them like this! #
+###############################################################################
+sha256sums=('e44c55501f650a4e80b9c353b81f33e07ca65808db831eff6ca616aded233827')
+sha256sums_i686=('aa512fc24aa309bf77ecfe5c66435dfcd432ed900478871e13f3e0f978eb84bd'
+ 'SKIP')
+sha256sums_x86_64=('aa512fc24aa309bf77ecfe5c66435dfcd432ed900478871e13f3e0f978eb84bd'
+ 'SKIP')
+
+prepare() {
+
+ # use colors only if we have them
+ if [[ $(which tput > /dev/null 2>&1 && tput -T "${TERM}" colors || echo -n '0') -ge 8 ]] ; then
+ local _COL_YELLOW_='\e[0;33m'
+ local _COL_LIGHTGREY_='\e[0;37m'
+ local _COL_BRED_='\e[1;31m'
+ local _COL_BBLUE_='\e[1;34m'
+ local _COL_BWHITE_='\e[1;37m'
+ local _COL_DEFAULT_='\e[0m'
+ fi
+
+ msg "Packaging ${pkgname} (language: ${_language})..."
+
+ if [[ -z "${THUNDERBIRD_PKGLANG}" ]]; then
+ echo -e "\n ${_COL_BBLUE_}->${_COL_DEFAULT_} ${_COL_BRED_}NOTE:${_COL_DEFAULT_} If you want to package ${_COL_BWHITE_}${pkgname}${_COL_DEFAULT_} in a different language, please"
+ echo -e " set a \`${_COL_YELLOW_}THUNDERBIRD_PKGLANG${_COL_DEFAULT_}\` environment variable before running makepkg.\n"
+ echo ' For instance:'
+ echo -e "\n ${_COL_LIGHTGREY_}THUNDERBIRD_PKGLANG='en-US' makepkg${_COL_DEFAULT_}\n"
+ fi
+
+ # we search and replace using sed with / as delimiter below so don't allow slashes in these vars.
+ # makepkg already enforces that there're no slashes in ${pkgname}, so we don't check that again here.
+ if [[ ${pkgver} = */* || ${_language} = */* || ${pkgdesc} = */* ]]; then
+ error '${pkgver}, ${_language} and ${pkgdesc} for this package are not allowed to contain /' >&2
+ return 1
+ fi
+
+}
+
+package() {
+ # Create directories
+ msg2 "Creating directory structure..."
+ install -d "$pkgdir"/usr/bin
+ install -d "$pkgdir"/usr/share/applications
+ install -d "$pkgdir"/opt
+
+ msg2 "Moving stuff in place..."
+ # Install
+ cp -r thunderbird/ "$pkgdir"/opt/$_pkgname
+
+ # Launchers
+ ln -s /opt/$_pkgname/thunderbird "$pkgdir"/usr/bin/$_pkgname
+ # breaks application as of 68.0b1
+ # ln -sf thunderbird "$pkgdir"/opt/$_pkgname/thunderbird-bin
+
+ _vendorjs="$pkgdir/opt/$_pkgname/defaults/preferences/vendor.js"
+ install -Dm644 /dev/stdin "$_vendorjs" <<END
+// Use LANG environment variable to choose locale
+pref("intl.locale.requested", "");
+
+// Use system-provided dictionaries
+pref("spellchecker.dictionary_path", "/usr/share/hunspell");
+
+// Disable default mailer checking.
+pref("mail.shell.checkDefaultMail", false);
+
+// Don't disable our bundled extensions in the application directory
+pref("extensions.autoDisableScopes", 11);
+pref("extensions.shownSelectionUI", true);
+END
+
+ _distini="$pkgdir/opt/$_pkgname/distribution/distribution.ini"
+ install -Dm644 /dev/stdin "$_distini" <<END
+[Global]
+id=archlinux
+version=1.0
+about=Mozilla Thunderbird for Arch Linux
+
+[Preferences]
+app.distributor=archlinux
+app.distributor.channel=$pkgname
+END
+
+ for i in 16 22 24 32 48 64 128 256; do
+ install -d "$pkgdir"/usr/share/icons/hicolor/${i}x${i}/apps/
+ ln -s /opt/$_pkgname/chrome/icons/default/default$i.png \
+ "$pkgdir"/usr/share/icons/hicolor/${i}x${i}/apps/$_pkgname.png
+ done
+
+ install -Dm644 ../$pkgname.desktop \
+ "$pkgdir/usr/share/applications"
+
+ # Use system-provided dictionaries
+ ln -Ts /usr/share/hunspell "$pkgdir"/opt/$_pkgname/dictionaries
+ ln -Ts /usr/share/hyphen "$pkgdir"/opt/$_pkgname/hyphenation
+
+ # Install a wrapper to avoid confusion about binary path
+ install -Dm755 /dev/stdin "$pkgdir/usr/bin/$pkgname" <<END
+#!/bin/sh
+exec /opt/$_pkgname/thunderbird "\$@"
+END
+
+ # Use system certificates
+ ln -sf /usr/lib/libnssckbi.so "$pkgdir"/opt/$_pkgname/libnssckbi.so
+}
diff --git a/thunderbird-localized-beta-bin.desktop b/thunderbird-localized-beta-bin.desktop
new file mode 100644
index 000000000000..1d08d8efe7d1
--- /dev/null
+++ b/thunderbird-localized-beta-bin.desktop
@@ -0,0 +1,173 @@
+[Desktop Entry]
+Name=Thunderbird
+Comment=Send and receive mail with Thunderbird
+Comment[ast]=Lleer y escribir corréu electrónicu
+Comment[ca]=Llegiu i escriviu correu
+Comment[cs]=Čtení a psaní pošty
+Comment[da]=Skriv/læs e-post/nyhedsgruppe med Mozilla Thunderbird
+Comment[de]=E-Mails und Nachrichten mit Thunderbird lesen und schreiben
+Comment[el]=Διαβάστε και γράψτε γράμματα με το Mozilla Thunderbird
+Comment[es]=Lea y escriba correos y noticias con Thunderbird
+Comment[fi]=Lue ja kirjoita sähköposteja
+Comment[fr]=Lire et écrire des courriels
+Comment[gl]=Lea e escriba correo electrónico
+Comment[he]=קריאה/כתיבה של דוא״ל/חדשות באמצעות Mozilla Thunderbird
+Comment[hr]=Čitajte/šaljite e-poštu s Thunderbird
+Comment[hu]=Levelek írása és olvasása a Thunderbirddel
+Comment[it]=Per leggere e scrivere email
+Comment[ja]=メールの読み書き
+Comment[ko]=Mozilla Thunderbird 메일/뉴스 읽기 및 쓰기 클라이언트
+Comment[nl]=E-mail/nieuws lezen en schrijven met Mozilla Thunderbird
+Comment[pl]=Czytanie i wysyłanie e-maili
+Comment[pt_BR]=Leia e escreva suas mensagens
+Comment[ru]=Читайте и пишите письма
+Comment[sk]=Čítajte a píšte poštu pomocou programu Thunderbird
+Comment[sv]=Läs och skriv e-post
+Comment[ug]=ئېلخەت ۋە خەۋەرلەرنى Mozilla Thunderbird دا كۆرۈش ۋە يېزىش
+Comment[uk]=Читання та написання листів
+Comment[vi]=Đọc và soạn thư điện tử
+Comment[zh_CN]=阅读邮件或新闻
+Comment[zh_TW]=以 Mozilla Thunderbird 讀寫郵件或新聞
+GenericName=Mail Client
+GenericName[ast]=Client de correu
+GenericName[ca]=Client de correu
+GenericName[cs]=Poštovní klient
+GenericName[da]=E-postklient
+GenericName[de]=E-Mail-Anwendung
+GenericName[el]=Λογισμικό αλληλογραφίας
+GenericName[es]=Cliente de correo
+GenericName[fi]=Sähköpostiohjelma
+GenericName[fr]=Client de messagerie
+GenericName[gl]=Cliente de correo electrónico
+GenericName[he]=לקוח דוא״ל
+GenericName[hr]=Klijent e-pošte
+GenericName[hu]=Levelezőkliens
+GenericName[it]=Client email
+GenericName[ja]=電子メールクライアント
+GenericName[ko]=메일 클라이언트
+GenericName[nl]=E-mailprogramma
+GenericName[pl]=Klient poczty
+GenericName[pt_BR]=Cliente de E-mail
+GenericName[ru]=Почтовый клиент
+GenericName[sk]=Poštový klient
+GenericName[ug]=ئېلخەت دېتالى
+GenericName[uk]=Поштова програма
+GenericName[vi]=Phần mềm khách quản lý thư điện tử
+GenericName[zh_CN]=邮件新闻客户端
+GenericName[zh_TW]=郵件用戶端
+Exec=/usr/lib/thunderbird/thunderbird %u
+Terminal=false
+Type=Application
+Icon=thunderbird
+Categories=Network;Email;
+MimeType=message/rfc822;x-scheme-handler/mailto;application/x-xpinstall;
+StartupNotify=true
+Actions=ComposeMessage;OpenAddressBook;
+
+[Desktop Action ComposeMessage]
+Name=Write new message
+Name[ar]=اكتب رسالة جديدة
+Name[ast]=Redactar mensaxe nuevu
+Name[be]=Напісаць новы ліст
+Name[bg]=Съставяне на ново съобщение
+Name[br]=Skrivañ ur gemennadenn nevez
+Name[ca]=Escriu un missatge nou
+Name[cs]=Napsat novou zprávu
+Name[da]=Skriv en ny meddelelse
+Name[de]=Neue Nachricht verfassen
+Name[el]=Σύνταξη νέου μηνύματος
+Name[es_AR]=Escribir un nuevo mensaje
+Name[es_ES]=Redactar nuevo mensaje
+Name[et]=Kirjuta uus kiri
+Name[eu]=Idatzi mezu berria
+Name[fi]=Kirjoita uusi viesti
+Name[fr]=Rédiger un nouveau message
+Name[fy_NL]=Skriuw in nij berjocht
+Name[ga_IE]=Scríobh teachtaireacht nua
+Name[gd]=Sgrìobh teachdaireachd ùr
+Name[gl]=Escribir unha nova mensaxe
+Name[he]=כתיבת הודעה חדשה
+Name[hr]=Piši novu poruku
+Name[hu]=Új üzenet írása
+Name[hy_AM]=Գրել նոր նամակ
+Name[is]=SKrifa nýjan póst
+Name[it]=Scrivi nuovo messaggio
+Name[ja]=新しいメッセージを作成する
+Name[ko]=새 메시지 작성
+Name[lt]=Rašyti naują laišką
+Name[nb_NO]=Skriv ny melding
+Name[nl]=Nieuw bericht aanmaken
+Name[nn_NO]=Skriv ny melding
+Name[pl]=Nowa wiadomość
+Name[pt_BR]=Nova mensagem
+Name[pt_PT]=Escrever nova mensagem
+Name[rm]=Scriver in nov messadi
+Name[ro]=Scrie un mesaj nou
+Name[ru]=Создать новое сообщение
+Name[si]=නව ලිපියක් ලියන්න
+Name[sk]=Nová e-mailová správa
+Name[sl]=Sestavi novo sporočilo
+Name[sq]=Shkruani mesazh të ri
+Name[sr]=Писање нове поруке
+Name[sv_SE]=Skriv ett nytt meddelande
+Name[ta_LK]=புதிய செய்தியை எழுதுக
+Name[tr]=Yeni ileti yaz
+Name[uk]=Написати нового листа
+Name[vi]=Viết thư mới
+Name[zh_CN]=编写新消息
+Name[zh_TW]=寫一封新訊息
+Exec=/usr/lib/thunderbird/thunderbird -compose
+
+[Desktop Action OpenAddressBook]
+Name=Open address book
+Name[ar]=افتح دفتر العناوين
+Name[ast]=Abrir llibreta de direiciones
+Name[be]=Адкрыць адрасную кнігу
+Name[bg]=Отваряне на адресник
+Name[br]=Digeriñ ur c'harned chomlec'hioù
+Name[ca]=Obre la llibreta d'adreces
+Name[cs]=Otevřít Adresář
+Name[da]=Åbn adressebog
+Name[de]=Adressbuch öffnen
+Name[el]=Άνοιγμα ευρετηρίου διευθύνσεων
+Name[es_AR]=Abrir libreta de direcciones
+Name[es_ES]=Abrir libreta de direcciones
+Name[et]=Ava aadressiraamat
+Name[eu]=Ireki helbide-liburua
+Name[fi]=Avaa osoitekirja
+Name[fr]=Ouvrir un carnet d'adresses
+Name[fy_NL]=Iepenje adresboek
+Name[ga_IE]=Oscail leabhar seoltaí
+Name[gd]=Fosgail leabhar-sheòlaidhean
+Name[gl]=Abrir a axenda de enderezos
+Name[he]=פתיחת ספר כתובות
+Name[hr]=Otvori adresar
+Name[hu]=Címjegyzék megnyitása
+Name[hy_AM]=Բացել Հասցեագիրքը
+Name[is]=Opna nafnaskrá
+Name[it]=Apri rubrica
+Name[ja]=アドレス帳を開く
+Name[ko]=주소록 열기
+Name[lt]=Atverti adresų knygą
+Name[nb_NO]=Åpne adressebok
+Name[nl]=Adresboek openen
+Name[nn_NO]=Opne adressebok
+Name[pl]=Książka adresowa
+Name[pt_BR]=Catálogo de endereços
+Name[pt_PT]=Abrir livro de endereços
+Name[rm]=Avrir il cudeschet d'adressas
+Name[ro]=Deschide agenda de contacte
+Name[ru]=Открыть адресную книгу
+Name[si]=ලිපින පොත විවෘත කරන්න
+Name[sk]=Otvoriť adresár
+Name[sl]=Odpri adressar
+Name[sq]=Hapni libër adresash
+Name[sr]=Отвори адресар
+Name[sv_SE]=Öppna adressboken
+Name[ta_LK]=முகவரி பத்தகத்தை திறக்க
+Name[tr]=Adres defterini aç
+Name[uk]=Відкрити адресну книгу
+Name[vi]=Mở sổ địa chỉ
+Name[zh_CN]=打开通讯录
+Name[zh_TW]=開啟通訊錄
+Exec=/usr/lib/thunderbird/thunderbird -addressbook
diff --git a/thunderbird-localized-beta-bin.install b/thunderbird-localized-beta-bin.install
new file mode 100644
index 000000000000..3210bd567082
--- /dev/null
+++ b/thunderbird-localized-beta-bin.install
@@ -0,0 +1,18 @@
+# Colored makepkg-like functions
+msg_blue() {
+ printf "${blue}==>${bold} $1${all_off}\n"
+}
+
+note() {
+ printf "${blue}==>${yellow} NOTE$1:${bold} $2${all_off}\n"
+}
+
+all_off="$(tput sgr0)"
+bold="${all_off}$(tput bold)"
+blue="${bold}$(tput setaf 4)"
+yellow="${bold}$(tput setaf 3)"
+
+post_install() {
+ note 1 "This package installs side-by-side with [extra]'s thunderbird."
+ note 2 "The launcher is called: 'thunderbird-beta'."
+}