summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederik Schwan2020-07-10 00:40:36 +0200
committerFrederik Schwan2020-07-10 00:40:36 +0200
commit8bdd1b195be75ba43ae5a8442007c5ac1bcc177a (patch)
treed35a3c4a0ccb9b81917f6df157f1db8b2a7b05de
parentcefe069d583639f26292d4305120217e656de1be (diff)
downloadaur-8bdd1b195be75ba43ae5a8442007c5ac1bcc177a.tar.gz
upgpkg: thunderbird-nightly-bin 80.0a1.20200709-1
closes #2
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
-rw-r--r--policies.json5
3 files changed, 32 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index afe69ad78638..d3bc212b75c4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,9 @@
pkgbase = thunderbird-nightly-bin
pkgdesc = Standalone Mail/News reader - Nightly build
- pkgver = 79.0a1.20200611
- pkgrel = 2
+ pkgver = 80.0a1.20200709
+ pkgrel = 1
url = https://www.mozilla.org/thunderbird
install = thunderbird-nightly.install
- arch = i686
arch = x86_64
license = MPL
license = GPL
@@ -31,17 +30,23 @@ pkgbase = thunderbird-nightly-bin
depends = sqlite
depends = startup-notification
optdepends = libcanberra: for sound support
- provides = thunderbird=79.0a1
+ provides = thunderbird=80.0a1
provides = thunderbird-nightly
conflicts = thunderbird-nightly
- source = https://download-installer.cdn.mozilla.net/pub/thunderbird/nightly/latest-comm-central/thunderbird-79.0a1.en-US.linux-x86_64.txt
- source = https://download-installer.cdn.mozilla.net/pub/thunderbird/nightly/latest-comm-central/thunderbird-79.0a1.en-US.linux-x86_64.tar.bz2
+ source = https://download-installer.cdn.mozilla.net/pub/thunderbird/nightly/latest-comm-central/thunderbird-80.0a1.en-US.linux-x86_64.txt
+ source = https://download-installer.cdn.mozilla.net/pub/thunderbird/nightly/latest-comm-central/thunderbird-80.0a1.en-US.linux-x86_64.tar.bz2
source = thunderbird-nightly.desktop
source = vendor.js
+ source = policies.json
b2sums = SKIP
b2sums = SKIP
b2sums = 1f954c9a23842367be37c1f56b853de6a336c1b4156df42f88b14f1614d194c2f996f1cc589cdbfcea398bb9cedcd527ef3c6fb8b01e2f07c46290043e24c6b7
b2sums = 674d1ee883e675c37b0af0ac97c339a8c0f2b53cb06e64db64aaa3f22f83d7179b6fa3e122344f3413ccb9956776288db9bc608b5cedef640cbd223838be7476
+ b2sums = f8df63721191d84d8f1ceec263f63c44fd5dadeae0939baf9a4a6b1852516722b2a3d94b8d403cc7b6c6b525d5236f357ab65a72d716aab1f5bef47800b5a18c
pkgname = thunderbird-nightly-bin
+pkgname = thunderbird-nightly-bin-noupdate
+ pkgdesc = Standalone Mail/News reader - Nightly build with disabled update notifications
+ depends = thunderbird-nightly-bin
+
diff --git a/PKGBUILD b/PKGBUILD
index 3c8700dc2699..478af0b6c2fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
# Contributor: Det <nimetonmaili at gmail a-dot com>
# Based on [extra]'s thunderbird
-pkgname=thunderbird-nightly-bin
-pkgver=79.0a1.20200611
-_version=79.0a1
-pkgrel=2
+pkgname=(thunderbird-nightly-bin thunderbird-nightly-bin-noupdate)
+pkgver=80.0a1.20200709
+_version=80.0a1
+pkgrel=1
pkgdesc='Standalone Mail/News reader - Nightly build'
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="https://www.mozilla.org/thunderbird"
license=('MPL' 'GPL' 'LGPL')
depends=('alsa-lib' 'cairo' 'dbus-glib' 'desktop-file-utils' 'fontconfig'
@@ -26,18 +26,20 @@ FX_SRC_URI="https://download-installer.cdn.mozilla.net/pub/thunderbird/nightly/l
source=("${FX_SRC_URI}.txt"
"${FX_SRC_URI}.tar.bz2"
"${pkgname%-bin}.desktop"
- "vendor.js")
+ vendor.js
+ policies.json)
b2sums=('SKIP'
'SKIP'
'1f954c9a23842367be37c1f56b853de6a336c1b4156df42f88b14f1614d194c2f996f1cc589cdbfcea398bb9cedcd527ef3c6fb8b01e2f07c46290043e24c6b7'
- '674d1ee883e675c37b0af0ac97c339a8c0f2b53cb06e64db64aaa3f22f83d7179b6fa3e122344f3413ccb9956776288db9bc608b5cedef640cbd223838be7476')
+ '674d1ee883e675c37b0af0ac97c339a8c0f2b53cb06e64db64aaa3f22f83d7179b6fa3e122344f3413ccb9956776288db9bc608b5cedef640cbd223838be7476'
+ 'f8df63721191d84d8f1ceec263f63c44fd5dadeae0939baf9a4a6b1852516722b2a3d94b8d403cc7b6c6b525d5236f357ab65a72d716aab1f5bef47800b5a18c')
pkgver(){
echo "${_version}.$(head -n1 "${FX_SRC}.txt" |cut -c -8)"
}
-package() {
+package_thunderbird-nightly-bin() {
install -d "${pkgdir}"/{usr/bin,opt}
cp -a thunderbird "${pkgdir}"/opt/${pkgname%-bin}-${pkgver}
cp vendor.js "${pkgdir}"/opt/${pkgname%-bin}-${pkgver}/defaults/pref/
@@ -49,3 +51,9 @@ package() {
rm -rf "${pkgdir}"/opt/${pkgname%-bin}-${pkgver}/dictionaries/
ln -sf /usr/share/hunspell/ "${pkgdir}"/opt/${pkgname%-bin}-${pkgver}/dictionaries
}
+
+package_thunderbird-nightly-bin-noupdate() {
+ pkgdesc='Standalone Mail/News reader - Nightly build with disabled update notifications'
+ depends=('thunderbird-nightly-bin')
+ install -Dm644 -t "${pkgdir}"/opt/${pkgname%-bin-noupdate}-${pkgver}/distribution policies.json
+}
diff --git a/policies.json b/policies.json
new file mode 100644
index 000000000000..f36622021fcd
--- /dev/null
+++ b/policies.json
@@ -0,0 +1,5 @@
+{
+ "policies": {
+ "DisableAppUpdate": true
+ }
+}