summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederik Schwan2020-05-17 04:43:32 +0200
committerFrederik Schwan2020-05-17 04:43:32 +0200
commite953354960089820c33f9c6c7b1879fa4ec66b44 (patch)
tree36797d3e81a76df53a0926a51fcaa70fe6ae833b
downloadaur-e953354960089820c33f9c6c7b1879fa4ec66b44.tar.gz
initial commit
-rw-r--r--.SRCINFO47
-rw-r--r--PKGBUILD51
-rw-r--r--thunderbird-nightly.desktop13
-rw-r--r--thunderbird-nightly.install15
-rw-r--r--vendor.js9
5 files changed, 135 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2f604d353cfc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,47 @@
+pkgbase = thunderbird-nightly-bin
+ pkgdesc = Standalone Mail/News reader - Nightly build
+ pkgver = 78.0a1.20200515
+ pkgrel = 1
+ url = https://www.mozilla.org/thunderbird
+ install = thunderbird-nightly.install
+ arch = i686
+ arch = x86_64
+ license = MPL
+ license = GPL
+ license = LGPL
+ depends = alsa-lib
+ depends = cairo
+ depends = dbus-glib
+ depends = desktop-file-utils
+ depends = fontconfig
+ depends = freetype2
+ depends = gtk3
+ depends = hicolor-icon-theme
+ depends = hunspell
+ depends = libevent
+ depends = libjpeg
+ depends = libmng
+ depends = libpng
+ depends = libvpx
+ depends = libxt
+ depends = mozilla-common
+ depends = nspr
+ depends = nss
+ depends = shared-mime-info
+ depends = sqlite
+ depends = startup-notification
+ optdepends = libcanberra: for sound support
+ provides = thunderbird=78.0a1
+ provides = thunderbird-nightly
+ conflicts = thunderbird-nightly
+ source = https://download-installer.cdn.mozilla.net/pub/thunderbird/nightly/latest-comm-central/thunderbird-78.0a1.en-US.linux-x86_64.txt
+ source = https://download-installer.cdn.mozilla.net/pub/thunderbird/nightly/latest-comm-central/thunderbird-78.0a1.en-US.linux-x86_64.tar.bz2
+ source = thunderbird-nightly.desktop
+ source = vendor.js
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = 1f954c9a23842367be37c1f56b853de6a336c1b4156df42f88b14f1614d194c2f996f1cc589cdbfcea398bb9cedcd527ef3c6fb8b01e2f07c46290043e24c6b7
+ b2sums = 674d1ee883e675c37b0af0ac97c339a8c0f2b53cb06e64db64aaa3f22f83d7179b6fa3e122344f3413ccb9956776288db9bc608b5cedef640cbd223838be7476
+
+pkgname = thunderbird-nightly-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..adb736014faf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Frederik Schwan <freswa at archlinux dot org>
+# Contributor: Cedric Girard <girard.cedric@gmail.com>
+# Contributor: Det <nimetonmaili at gmail a-dot com>
+# Based on [extra]'s thunderbird
+
+pkgname=thunderbird-nightly-bin
+pkgver=78.0a1.20200515
+_version=78.0a1
+pkgrel=1
+pkgdesc='Standalone Mail/News reader - Nightly build'
+arch=('i686' 'x86_64')
+url="https://www.mozilla.org/thunderbird"
+license=('MPL' 'GPL' 'LGPL')
+depends=('alsa-lib' 'cairo' 'dbus-glib' 'desktop-file-utils' 'fontconfig'
+ 'freetype2' 'gtk3' 'hicolor-icon-theme' 'hunspell' 'libevent' 'libjpeg'
+ 'libmng' 'libpng' 'libvpx' 'libxt' 'mozilla-common' 'nspr' 'nss'
+ 'shared-mime-info' 'sqlite' 'startup-notification')
+optdepends=('libcanberra: for sound support')
+provides=("thunderbird=${_version}" 'thunderbird-nightly')
+conflicts=('thunderbird-nightly')
+install="${pkgname%-bin}.install"
+
+FX_SRC="thunderbird-${_version}.en-US.linux-${CARCH}"
+FX_SRC_URI="https://download-installer.cdn.mozilla.net/pub/thunderbird/nightly/latest-comm-central/${FX_SRC}"
+
+source=("${FX_SRC_URI}.txt"
+ "${FX_SRC_URI}.tar.bz2"
+ "${pkgname%-bin}.desktop"
+ "vendor.js")
+
+b2sums=('SKIP'
+ 'SKIP'
+ '1f954c9a23842367be37c1f56b853de6a336c1b4156df42f88b14f1614d194c2f996f1cc589cdbfcea398bb9cedcd527ef3c6fb8b01e2f07c46290043e24c6b7'
+ '674d1ee883e675c37b0af0ac97c339a8c0f2b53cb06e64db64aaa3f22f83d7179b6fa3e122344f3413ccb9956776288db9bc608b5cedef640cbd223838be7476')
+
+pkgver(){
+ echo "${_version}.$(head -n1 "${FX_SRC}.txt" |cut -c -8)"
+}
+
+package() {
+ install -d "${pkgdir}"/{usr/bin,opt}
+ cp -a thunderbird "${pkgdir}"/opt/${pkgname%-bin}-${pkgver}
+ cp vendor.js "${pkgdir}"/opt/${pkgname%-bin}-${pkgver}/defaults/pref/
+ ln -s /opt/${pkgname%-bin}-${pkgver}/thunderbird "${pkgdir}"/usr/bin/${pkgname}
+ for i in 16x16 32x32 48x48 64x64 128x128; do
+ install -Dm644 thunderbird/chrome/icons/default/default${i/x*/}.png "${pkgdir}"/usr/share/icons/hicolor/${i}/apps/${pkgname}.png
+ done
+ install -Dm644 ${pkgname%-bin}.desktop "${pkgdir}"/usr/share/applications/${pkgname}.desktop
+ rm -rf "${pkgdir}"/opt/${pkgname%-bin}-${pkgver}/dictionaries/
+ ln -sf /usr/share/hunspell/ "${pkgdir}"/opt/${pkgname%-bin}-${pkgver}/dictionaries
+}
diff --git a/thunderbird-nightly.desktop b/thunderbird-nightly.desktop
new file mode 100644
index 000000000000..97b3ca98aa37
--- /dev/null
+++ b/thunderbird-nightly.desktop
@@ -0,0 +1,13 @@
+[Desktop Entry]
+Version=1.0
+Name=Thunderbird (Nightly)
+Comment=Mail & News Reader (Nightly)
+GenericName=Mail Client & News Reader (Nightly)
+Exec=thunderbird-nightly %u
+TryExec=thunderbird-nightly
+Icon=thunderbird-nightly
+Terminal=false
+Type=Application
+Categories=Network;Email;
+MimeType=message/rfc822;x-scheme-handler/mailto;
+StartupNotify=true \ No newline at end of file
diff --git a/thunderbird-nightly.install b/thunderbird-nightly.install
new file mode 100644
index 000000000000..b8e62243ac01
--- /dev/null
+++ b/thunderbird-nightly.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo ""
+ echo "Note: the binary is called 'thunderbird-nightly'"
+ echo ""
+ post_upgrade
+}
+
+post_upgrade() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_remove() {
+ post_upgrade
+}
diff --git a/vendor.js b/vendor.js
new file mode 100644
index 000000000000..170b505a8dcc
--- /dev/null
+++ b/vendor.js
@@ -0,0 +1,9 @@
+// Use LANG environment variable to choose locale
+pref("intl.locale.matchOS", true);
+
+// Disable default mailer checking.
+pref("mail.shell.checkDefaultMail", false);
+
+// Don't disable our bundled extensions in the application directory
+pref("extensions.autoDisableScopes", 11);
+pref("extensions.shownSelectionUI", true);