summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClaudia Pellegrino2022-09-24 22:00:56 +0200
committerClaudia Pellegrino2022-09-24 22:00:56 +0200
commit172d687dd28e023079077dd47f438a10f9f19fba (patch)
treee1e7343424c9a00a1a6ff0f3ad9f3c5a5e1b2d62
parentd21734332560e6998db2bc9d8c33299bf4f13081 (diff)
downloadaur-172d687dd28e023079077dd47f438a10f9f19fba.tar.gz
thunderbird-tbsync v4.1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD19
2 files changed, 15 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7fc54298cadd..4faba97f386b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
pkgbase = thunderbird-tbsync
pkgdesc = Sync contacts, tasks and calendars to thunderbird using Exchange ActiveSync (EAS) and CalDAV/CardDAV
- pkgver = 2.19
+ pkgver = 4.1
pkgrel = 1
url = https://github.com/jobisoft/TbSync
arch = any
groups = office
license = MPL-2.0
- depends = thunderbird>=78
- depends = thunderbird<79
- provides = tbsync=2.19
- noextract = tbsync-2.19-tb.xpi
- source = https://addons.thunderbird.net/thunderbird/downloads/file/1017830/tbsync-2.19-tb.xpi
- sha256sums = 1f1b5245e532d8ae216798435f610e46d4934447bdf5ede7561e93515a44fa16
+ depends = thunderbird>=102
+ depends = thunderbird<103
+ noextract = TbSync-4.1.xpi
+ source = TbSync-4.1.xpi::https://github.com/jobisoft/TbSync/releases/download/v4.1/TbSync.xpi
+ sha512sums = b06b590d335e25403d251bd8f3ba75a9272cebe6889c9f4cf0eeef2e9013b797ec88aafd9c8e7fec13621f4ce622b8c240c210ebdf9c54c51cfe9dda5defeb66
pkgname = thunderbird-tbsync
-
diff --git a/PKGBUILD b/PKGBUILD
index 581ece2445b8..7b0933979cd9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,23 @@
-# Maintainer: Michal Wojdyla < micwoj9292 at gmail dot com>
+# Maintainer: Claudia Pellegrino <aur ät cpellegrino.de>
+# Contributor: Michal Wojdyla < micwoj9292 at gmail dot com>
# Contributor: Javier Tiá <javier dot tia at gmail dot com>
pkgname=thunderbird-tbsync
-pkgver=2.19
+_name=TbSync
+pkgver=4.1
pkgrel=1
-_file=1017830
-_name=tbsync
pkgdesc="Sync contacts, tasks and calendars to thunderbird using Exchange ActiveSync (EAS) and CalDAV/CardDAV"
arch=('any')
url="https://github.com/jobisoft/TbSync"
license=('MPL-2.0')
groups=('office')
-depends=('thunderbird>=78' 'thunderbird<79')
-provides=("${_name}=${pkgver}")
-source=("https://addons.thunderbird.net/thunderbird/downloads/file/$_file/$_name-$pkgver-tb.xpi")
-noextract=("$_name-$pkgver-tb.xpi")
-sha256sums=('1f1b5245e532d8ae216798435f610e46d4934447bdf5ede7561e93515a44fa16')
+depends=('thunderbird>=102' 'thunderbird<103')
+source=("${_name}-${pkgver}.xpi::https://github.com/jobisoft/${_name}/releases/download/v${pkgver}/${_name}.xpi")
+noextract=("${_name}-${pkgver}.xpi")
+sha512sums=('b06b590d335e25403d251bd8f3ba75a9272cebe6889c9f4cf0eeef2e9013b797ec88aafd9c8e7fec13621f4ce622b8c240c210ebdf9c54c51cfe9dda5defeb66')
package() {
_extension_id="tbsync@jobisoft.de"
_extension_dest="${pkgdir}/usr/lib/thunderbird/extensions/${_extension_id}"
- install -Dm644 "${srcdir}"/$_name-$pkgver-tb.xpi "${_extension_dest}.xpi"
+ install -Dm644 "${srcdir}/${_name}-${pkgver}.xpi" "${_extension_dest}.xpi"
}