summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClaudia2023-08-18 15:21:15 +0200
committerClaudia2023-08-18 15:21:15 +0200
commit5961185e0728f47ee3e04b5ed2ca9642a6e53cfb (patch)
tree48cff711a08e5f0391705f2e7bd30d1ed796af00
parent2dd76bf002be74531529c77dc3f87538bf8031de (diff)
downloadaur-5961185e0728f47ee3e04b5ed2ca9642a6e53cfb.tar.gz
thunderbird-tbsync v4.5
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD15
2 files changed, 14 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 746de9ef12ff..a7847dca7292 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = thunderbird-tbsync
pkgdesc = Sync contacts, tasks and calendars to thunderbird using Exchange ActiveSync (EAS) and CalDAV/CardDAV
- pkgver = 4.3
+ pkgver = 4.5
pkgrel = 1
url = https://github.com/jobisoft/TbSync
arch = any
groups = office
license = MPL2
- depends = thunderbird>=102
- depends = thunderbird<103
- noextract = TbSync-4.3.xpi
- source = TbSync-4.3.xpi::https://github.com/jobisoft/TbSync/releases/download/v4.3/TbSync-beta.xpi
- sha512sums = f166db7671b1eaa48136da7070293763948cf76f202ae9bfe5a16fa50a9f89bdec865a85976e9ff976ecccd6d32fbe6a223367ef40c0f4d335953b3af785bd2b
+ depends = thunderbird>=102.3
+ depends = thunderbird<116
+ noextract = tbsync-4.5-tb.xpi
+ source = https://addons.thunderbird.net/thunderbird/downloads/file/1023901/tbsync-4.5-tb.xpi
+ sha512sums = 348fddc9e0d322160de9e6bd173a4ecfc03af5d1084df2ff6cb7bcbe4b50bb982a47531590c32645599015a3c8cfebc737b74a22c55cb824475e42660fa852c6
pkgname = thunderbird-tbsync
diff --git a/PKGBUILD b/PKGBUILD
index 604ef4d8e3b4..bb864002b211 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,21 +3,22 @@
# Contributor: Javier TiĆ” <javier dot tia at gmail dot com>
pkgname=thunderbird-tbsync
-_name=TbSync
-pkgver=4.3
+_name=tbsync
+_file=1023901
+pkgver=4.5
pkgrel=1
pkgdesc="Sync contacts, tasks and calendars to thunderbird using Exchange ActiveSync (EAS) and CalDAV/CardDAV"
arch=('any')
url="https://github.com/jobisoft/TbSync"
license=('MPL2')
groups=('office')
-depends=('thunderbird>=102' 'thunderbird<103')
-source=("${_name}-${pkgver}.xpi::https://github.com/jobisoft/${_name}/releases/download/v${pkgver}/${_name}-beta.xpi")
-noextract=("${_name}-${pkgver}.xpi")
-sha512sums=('f166db7671b1eaa48136da7070293763948cf76f202ae9bfe5a16fa50a9f89bdec865a85976e9ff976ecccd6d32fbe6a223367ef40c0f4d335953b3af785bd2b')
+depends=('thunderbird>=102.3' 'thunderbird<116')
+source=("https://addons.thunderbird.net/thunderbird/downloads/file/${_file}/${_name}-${pkgver}-tb.xpi")
+noextract=("${_name}-${pkgver}-tb.xpi")
+sha512sums=('348fddc9e0d322160de9e6bd173a4ecfc03af5d1084df2ff6cb7bcbe4b50bb982a47531590c32645599015a3c8cfebc737b74a22c55cb824475e42660fa852c6')
package() {
_extension_id="tbsync@jobisoft.de"
_extension_dest="${pkgdir}/usr/lib/thunderbird/extensions/${_extension_id}"
- install -Dm644 "${srcdir}/${_name}-${pkgver}.xpi" "${_extension_dest}.xpi"
+ install -Dm644 "${srcdir}/${_name}-${pkgver}-tb.xpi" "${_extension_dest}.xpi"
}